Lim-Plugin-OpenDNSSEC

Metadata

Analyzed metadata and errors of Lim-Plugin-OpenDNSSEC.

{
   "abstracts_in_pod" : {
      "Lim::Plugin::OpenDNSSEC" : "OpenDNSSEC management plugin for Lim"
   },
   "author" : "JELU",
   "buildfile_executable" : 0,
   "dir_lib" : "lib",
   "dir_t" : "t",
   "dirs_array" : [
      "lib/Lim/Plugin/OpenDNSSEC",
      "lib/Lim/Plugin",
      "lib/Lim",
      "lib",
      "t",
      "t"
   ],
   "dist" : "Lim-Plugin-OpenDNSSEC",
   "dynamic_config" : 0,
   "error" : {
      "no_invalid_versions" : {
         "lib/Lim/Plugin/OpenDNSSEC/CLI.pm" : {
            "Lim::Plugin::OpenDNSSEC::CLI" : "our $VERSION = $Lim::Plugin::OpenDNSSEC::VERSION;"
         },
         "lib/Lim/Plugin/OpenDNSSEC/Client.pm" : {
            "Lim::Plugin::OpenDNSSEC::Client" : "our $VERSION = $Lim::Plugin::OpenDNSSEC::VERSION;"
         },
         "lib/Lim/Plugin/OpenDNSSEC/Server.pm" : {
            "Lim::Plugin::OpenDNSSEC::Server" : "our $VERSION = $Lim::Plugin::OpenDNSSEC::VERSION;"
         }
      }
   },
   "extension" : "tar.gz",
   "extractable" : 1,
   "extracts_nicely" : 1,
   "file__build" : 0,
   "file_blib" : 0,
   "file_build" : 0,
   "file_changelog" : "Changes",
   "file_makefile" : 0,
   "file_makefile_pl" : "Makefile.PL",
   "file_manifest" : "MANIFEST",
   "file_meta_yml" : "META.yml",
   "file_pm_to_blib" : 0,
   "file_readme" : "README",
   "files_array" : [
      "Changes",
      "MANIFEST",
      "META.yml",
      "Makefile.PL",
      "README",
      "lib/Lim/Plugin/OpenDNSSEC/CLI.pm",
      "lib/Lim/Plugin/OpenDNSSEC/Client.pm",
      "lib/Lim/Plugin/OpenDNSSEC/Server.pm",
      "lib/Lim/Plugin/OpenDNSSEC.pm"
   ],
   "files_hash" : {
      "Changes" : {
         "mtime" : 1375941601,
         "size" : 172
      },
      "MANIFEST" : {
         "mtime" : 1375941741,
         "size" : 322
      },
      "META.yml" : {
         "mtime" : 1375941741,
         "size" : 1030
      },
      "Makefile.PL" : {
         "mtime" : 1375941374,
         "size" : 1761,
         "used" : [
            "5.006",
            "ExtUtils::MakeMaker",
            "strict",
            "warnings"
         ]
      },
      "README" : {
         "mtime" : 1375875950,
         "size" : 1005
      },
      "lib/Lim/Plugin/OpenDNSSEC.pm" : {
         "license" : "GPL_1,GPL_2,GPL_3",
         "module" : "Lim::Plugin::OpenDNSSEC",
         "mtime" : 1375941537,
         "size" : 46032,
         "used" : [
            "Lim::Component",
            "common::sense"
         ]
      },
      "lib/Lim/Plugin/OpenDNSSEC/CLI.pm" : {
         "license" : "GPL_1,GPL_2,GPL_3",
         "module" : "Lim::Plugin::OpenDNSSEC::CLI",
         "mtime" : 1375875950,
         "size" : 74058,
         "used" : [
            "Getopt::Long",
            "Lim::Component::CLI",
            "Lim::Plugin::OpenDNSSEC",
            "Scalar::Util",
            "common::sense"
         ]
      },
      "lib/Lim/Plugin/OpenDNSSEC/Client.pm" : {
         "license" : "GPL_1,GPL_2,GPL_3",
         "module" : "Lim::Plugin::OpenDNSSEC::Client",
         "mtime" : 1375875950,
         "size" : 1233,
         "used" : [
            "Lim::Component::Client",
            "Lim::Plugin::OpenDNSSEC",
            "common::sense"
         ]
      },
      "lib/Lim/Plugin/OpenDNSSEC/Server.pm" : {
         "license" : "GPL_1,GPL_2,GPL_3",
         "module" : "Lim::Plugin::OpenDNSSEC::Server",
         "mtime" : 1375875950,
         "size" : 123615,
         "used" : [
            "Digest::SHA",
            "Fcntl",
            "IO::File",
            "Lim::Component::Server",
            "Lim::Plugin::OpenDNSSEC",
            "Lim::Util",
            "Scalar::Util",
            "common::sense"
         ]
      },
      "t/00-load.t" : {
         "mtime" : 1375875512,
         "no_index" : 1,
         "size" : 205,
         "used" : [
            "Test::More"
         ]
      },
      "t/manifest.t" : {
         "mtime" : 1375875512,
         "no_index" : 1,
         "size" : 272,
         "used" : [
            "Test::More",
            "strict",
            "warnings"
         ],
         "used_in_eval" : [
            "Test::CheckManifest"
         ]
      },
      "t/pod-coverage.t" : {
         "mtime" : 1375875512,
         "no_index" : 1,
         "size" : 551,
         "used" : [
            "Test::More",
            "strict",
            "warnings"
         ],
         "used_in_eval" : [
            "Pod::Coverage",
            "Test::Pod::Coverage"
         ]
      },
      "t/pod.t" : {
         "mtime" : 1375875512,
         "no_index" : 1,
         "size" : 232,
         "used" : [
            "Test::More",
            "strict",
            "warnings"
         ],
         "used_in_eval" : [
            "Test::Pod"
         ]
      }
   },
   "got_prereq_from" : "META.yml",
   "kwalitee" : {
      "buildtool_not_executable" : 1,
      "consistent_version" : 1,
      "distname_matches_name_in_meta" : 1,
      "extractable" : 1,
      "extracts_nicely" : 1,
      "has_abstract_in_pod" : 1,
      "has_buildtool" : 1,
      "has_changelog" : 1,
      "has_human_readable_license" : 1,
      "has_known_license_in_source_file" : 1,
      "has_license_in_source_file" : 1,
      "has_manifest" : 1,
      "has_meta_yml" : 1,
      "has_proper_version" : 1,
      "has_readme" : 1,
      "has_separate_license_file" : 0,
      "has_tests" : 1,
      "has_tests_in_t_dir" : 1,
      "has_version" : 1,
      "kwalitee" : "95.45",
      "manifest_matches_dist" : 1,
      "meta_json_conforms_to_known_spec" : 1,
      "meta_json_is_parsable" : 1,
      "meta_yml_conforms_to_known_spec" : 1,
      "meta_yml_declares_perl_version" : 0,
      "meta_yml_has_license" : 1,
      "meta_yml_has_provides" : 0,
      "meta_yml_has_repository_resource" : 1,
      "meta_yml_is_parsable" : 1,
      "no_abstract_stub_in_pod" : 1,
      "no_broken_auto_install" : 1,
      "no_broken_module_install" : 1,
      "no_dot_dirs" : 1,
      "no_dot_underscore_files" : 1,
      "no_generated_files" : 1,
      "no_invalid_versions" : 0,
      "no_local_dirs" : 1,
      "no_mymeta_files" : 1,
      "no_pax_headers" : 1,
      "no_pod_errors" : 1,
      "no_stdin_for_prompting" : 1,
      "no_symlinks" : 1,
      "package_version_matches_dist_version" : 1,
      "portable_filenames" : 1,
      "proper_libs" : 1,
      "use_strict" : 1,
      "use_warnings" : 1,
      "valid_signature" : 1
   },
   "latest_mtime" : 1375941741,
   "license" : "perl defined in META.yml",
   "license_from_yaml" : "perl",
   "license_in_pod" : 1,
   "licenses" : {
      "GPL_1" : [
         "lib/Lim/Plugin/OpenDNSSEC.pm",
         "lib/Lim/Plugin/OpenDNSSEC/CLI.pm",
         "lib/Lim/Plugin/OpenDNSSEC/Client.pm",
         "lib/Lim/Plugin/OpenDNSSEC/Server.pm"
      ],
      "GPL_2" : [
         "lib/Lim/Plugin/OpenDNSSEC.pm",
         "lib/Lim/Plugin/OpenDNSSEC/CLI.pm",
         "lib/Lim/Plugin/OpenDNSSEC/Client.pm",
         "lib/Lim/Plugin/OpenDNSSEC/Server.pm"
      ],
      "GPL_3" : [
         "lib/Lim/Plugin/OpenDNSSEC.pm",
         "lib/Lim/Plugin/OpenDNSSEC/CLI.pm",
         "lib/Lim/Plugin/OpenDNSSEC/Client.pm",
         "lib/Lim/Plugin/OpenDNSSEC/Server.pm"
      ]
   },
   "manifest_matches_dist" : 1,
   "meta_yml" : {
      "abstract" : "OpenDNSSEC management plugin for Lim",
      "author" : [
         "Jerry Lundström <lundstrom.jerry@gmail.com>"
      ],
      "build_requires" : {
         "Digest::SHA" : "5",
         "Getopt::Long" : "2",
         "Lim" : "0.16",
         "Pod::Usage" : "1",
         "Scalar::Util" : "1",
         "Test::More" : "0",
         "common::sense" : "3"
      },
      "configure_requires" : {
         "ExtUtils::MakeMaker" : "0"
      },
      "distribution_type" : "module",
      "generated_by" : "ExtUtils::MakeMaker version 6.57_05",
      "license" : "perl",
      "meta-spec" : {
         "url" : "http://module-build.sourceforge.net/META-spec-v1.4.html",
         "version" : "1.4"
      },
      "name" : "Lim-Plugin-OpenDNSSEC",
      "no_index" : {
         "directory" : [
            "t",
            "inc"
         ]
      },
      "requires" : {
         "Digest::SHA" : "5",
         "Getopt::Long" : "2",
         "Lim" : "0.16",
         "Pod::Usage" : "1",
         "Scalar::Util" : "1",
         "common::sense" : "3"
      },
      "resources" : {
         "bugtracker" : "http://github.com/jelu/lim-plugin-opendnssec/issues",
         "homepage" : "http://github.com/jelu/lim-plugin-opendnssec/wiki",
         "repository" : "http://github.com/jelu/lim-plugin-opendnssec"
      },
      "version" : "0.14"
   },
   "meta_yml_is_parsable" : 1,
   "meta_yml_spec_version" : "1.4",
   "modules" : [
      {
         "file" : "lib/Lim/Plugin/OpenDNSSEC/CLI.pm",
         "in_basedir" : 0,
         "in_lib" : 1,
         "module" : "Lim::Plugin::OpenDNSSEC::CLI"
      },
      {
         "file" : "lib/Lim/Plugin/OpenDNSSEC/Client.pm",
         "in_basedir" : 0,
         "in_lib" : 1,
         "module" : "Lim::Plugin::OpenDNSSEC::Client"
      },
      {
         "file" : "lib/Lim/Plugin/OpenDNSSEC/Server.pm",
         "in_basedir" : 0,
         "in_lib" : 1,
         "module" : "Lim::Plugin::OpenDNSSEC::Server"
      },
      {
         "file" : "lib/Lim/Plugin/OpenDNSSEC.pm",
         "in_basedir" : 0,
         "in_lib" : 1,
         "module" : "Lim::Plugin::OpenDNSSEC"
      }
   ],
   "no_index" : "^inc/;^t/",
   "no_pax_headers" : 1,
   "package" : "Lim-Plugin-OpenDNSSEC-0.14.tar.gz",
   "prereq" : [
      {
         "is_prereq" : 1,
         "requires" : "Scalar::Util",
         "type" : "runtime_requires",
         "version" : "1"
      },
      {
         "is_build_prereq" : 1,
         "requires" : "Scalar::Util",
         "type" : "build_requires",
         "version" : "1"
      },
      {
         "is_prereq" : 1,
         "requires" : "common::sense",
         "type" : "runtime_requires",
         "version" : "3"
      },
      {
         "is_build_prereq" : 1,
         "requires" : "common::sense",
         "type" : "build_requires",
         "version" : "3"
      },
      {
         "is_prereq" : 1,
         "requires" : "Pod::Usage",
         "type" : "runtime_requires",
         "version" : "1"
      },
      {
         "is_build_prereq" : 1,
         "requires" : "Pod::Usage",
         "type" : "build_requires",
         "version" : "1"
      },
      {
         "is_build_prereq" : 1,
         "requires" : "Test::More",
         "type" : "build_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "Getopt::Long",
         "type" : "runtime_requires",
         "version" : "2"
      },
      {
         "is_build_prereq" : 1,
         "requires" : "Getopt::Long",
         "type" : "build_requires",
         "version" : "2"
      },
      {
         "requires" : "ExtUtils::MakeMaker",
         "type" : "configure_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "Digest::SHA",
         "type" : "runtime_requires",
         "version" : "5"
      },
      {
         "is_build_prereq" : 1,
         "requires" : "Digest::SHA",
         "type" : "build_requires",
         "version" : "5"
      },
      {
         "is_prereq" : 1,
         "requires" : "Lim",
         "type" : "runtime_requires",
         "version" : "0.16"
      },
      {
         "is_build_prereq" : 1,
         "requires" : "Lim",
         "type" : "build_requires",
         "version" : "0.16"
      }
   ],
   "released_epoch" : 1375942421,
   "size_packed" : 23202,
   "size_unpacked" : 250488,
   "uses" : {
      "used_in_code" : {
         "Digest::SHA" : 1,
         "Fcntl" : 1,
         "Getopt::Long" : 1,
         "IO::File" : 1,
         "Lim::Component" : 1,
         "Lim::Component::CLI" : 1,
         "Lim::Component::Client" : 1,
         "Lim::Component::Server" : 1,
         "Lim::Util" : 1,
         "Scalar::Util" : 2,
         "common::sense" : 4
      },
      "used_in_config" : {
         "5.006" : 1,
         "ExtUtils::MakeMaker" : 1,
         "strict" : 1,
         "warnings" : 1
      },
      "used_in_eval_in_tests" : {
         "Pod::Coverage" : 1,
         "Test::CheckManifest" : 1,
         "Test::Pod" : 1,
         "Test::Pod::Coverage" : 1
      },
      "used_in_tests" : {
         "Test::More" : 4,
         "strict" : 3,
         "warnings" : 3
      }
   },
   "valid_signature" : -1,
   "version" : "0.14",
   "versions" : {
      "lib/Lim/Plugin/OpenDNSSEC.pm" : {
         "Lim::Plugin::OpenDNSSEC" : "0.14"
      }
   },
   "vname" : "Lim-Plugin-OpenDNSSEC-0.14"
}