Kwalitee Issues

no_pod_errors

Remove the POD errors. You can check for POD errors automatically by including Test::Pod to your test suite.

Error: LinkLocal-IPv4-Interface-0.19_01/lib/LinkLocal/IPv4/Interface/Cache.pm -- Around line 193: You forgot a '=back' before '=head3'Around line 195: '=item' outside of any '=over'Around line 197: You forgot a '=back' before '=head3'Around line 199: '=item' outside of any '=over'Around line 211: You forgot a '=back' before '=head3'Around line 213: '=item' outside of any '=over'Around line 219: You forgot a '=back' before '=head3'Around line 221: '=item' outside of any '=over'Around line 236: You forgot a '=back' before '=head3'Around line 238: '=item' outside of any '=over' LinkLocal-IPv4-Interface-0.19_01/lib/LinkLocal/IPv4/Interface/Logger.pm -- Around line 233: You forgot a '=back' before '=head3'Around line 235: '=item' outside of any '=over'Around line 237: You forgot a '=back' before '=head3'Around line 239: '=item' outside of any '=over'Around line 247: Unknown directive: =over4Around line 251: '=item' outside of any '=over'Around line 256: You forgot a '=back' before '=head3'Around line 258: '=item' outside of any '=over'Around line 286: You forgot a '=back' before '=head3'Around line 288: '=item' outside of any '=over'

prereq_matches_use

List all used modules in META.yml requires

Error:

  • Net::Frame::Device
  • Net::Frame::Dump::Online
  • Net::Frame::Simple
  • Net::Netmask
  • Net::Write::Layer2
  • feature

use_strict

Add 'use strict' (or its equivalents) to all modules, or convince us that your favorite module is well-known enough and people can easily see the modules are strictly written.

Error: LinkLocal::IPv4::Interface::Constants

has_meta_json

Add a META.json to the distribution. Your buildtool should be able to autogenerate it.

meta_yml_declares_perl_version

If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.

use_warnings

Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: LinkLocal::IPv4::Interface::Constants

has_separate_license_file

This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.

meta_yml_has_provides

Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.

Modules

Name Abstract Version View
LinkLocal::IPv4::Interface IPv4 link-local interface wrapper 0.19_01 metacpan
LinkLocal::IPv4::Interface::ARP An ARP packet wrapper, this class allows for the easy construction of either link-local Probe or Announce ARP Requests. 0.19_01 metacpan
LinkLocal::IPv4::Interface::Cache IPv4 link-local address caching object. 0.19_01 metacpan
LinkLocal::IPv4::Interface::Constants IPv4 link-local protocol constants as defined in RFC-3927 0.19_01 metacpan
LinkLocal::IPv4::Interface::Logger A Moose-wrapped syslog interface. 0.19_01 metacpan
LinkLocal::IPv4::Interface::Types A collection of shared Moose subtype definitions and coercions. 0.19_01 metacpan

Other Files

Changes metacpan
MANIFEST metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan