Kwalitee Issues

no_pax_headers

If you use Mac OS X >= 10.6, use gnu tar (/usr/bin/gnutar) to avoid PAX headers. It's also important to rename (shorten) long file names (>= 100 characters) in the distribution.

Error: ./PaxHeaders.11707/Linux-Smaps-0.13,./PaxHeaders.11707/Linux-Smaps-0.13,Linux-Smaps-0.13/PaxHeaders.11707/MANIFEST,Linux-Smaps-0.13/PaxHeaders.11707/MANIFEST,Linux-Smaps-0.13/PaxHeaders.11707/META.json,Linux-Smaps-0.13/PaxHeaders.11707/META.json,Linux-Smaps-0.13/PaxHeaders.11707/Makefile.PL,Linux-Smaps-0.13/PaxHeaders.11707/Makefile.PL,Linux-Smaps-0.13/PaxHeaders.11707/mk_README.sh,Linux-Smaps-0.13/PaxHeaders.11707/mk_README.sh,Linux-Smaps-0.13/PaxHeaders.11707/META.yml,Linux-Smaps-0.13/PaxHeaders.11707/META.yml,Linux-Smaps-0.13/PaxHeaders.11707/Changes,Linux-Smaps-0.13/PaxHeaders.11707/Changes,Linux-Smaps-0.13/PaxHeaders.11707/README,Linux-Smaps-0.13/PaxHeaders.11707/README,Linux-Smaps-0.13/PaxHeaders.11707/t,Linux-Smaps-0.13/PaxHeaders.11707/t,Linux-Smaps-0.13/t/PaxHeaders.11707/smaps-VmFlags,Linux-Smaps-0.13/t/PaxHeaders.11707/smaps-VmFlags,Linux-Smaps-0.13/t/PaxHeaders.11707/double-vdso,Linux-Smaps-0.13/t/PaxHeaders.11707/double-vdso,Linux-Smaps-0.13/t/PaxHeaders.11707/03.t,Linux-Smaps-0.13/t/PaxHeaders.11707/03.t,Linux-Smaps-0.13/t/PaxHeaders.11707/06-VmFlags.t,Linux-Smaps-0.13/t/PaxHeaders.11707/06-VmFlags.t,Linux-Smaps-0.13/t/PaxHeaders.11707/02.t,Linux-Smaps-0.13/t/PaxHeaders.11707/02.t,Linux-Smaps-0.13/t/PaxHeaders.11707/single-vdso,Linux-Smaps-0.13/t/PaxHeaders.11707/single-vdso,Linux-Smaps-0.13/t/PaxHeaders.11707/04.t,Linux-Smaps-0.13/t/PaxHeaders.11707/04.t,Linux-Smaps-0.13/t/PaxHeaders.11707/smaps,Linux-Smaps-0.13/t/PaxHeaders.11707/smaps,Linux-Smaps-0.13/t/PaxHeaders.11707/smaps64,Linux-Smaps-0.13/t/PaxHeaders.11707/smaps64,Linux-Smaps-0.13/t/PaxHeaders.11707/01.t,Linux-Smaps-0.13/t/PaxHeaders.11707/01.t,Linux-Smaps-0.13/PaxHeaders.11707/perl-Linux-Smaps.spec,Linux-Smaps-0.13/PaxHeaders.11707/perl-Linux-Smaps.spec,Linux-Smaps-0.13/PaxHeaders.11707/lib,Linux-Smaps-0.13/PaxHeaders.11707/lib,Linux-Smaps-0.13/lib/PaxHeaders.11707/Linux,Linux-Smaps-0.13/lib/PaxHeaders.11707/Linux,Linux-Smaps-0.13/lib/Linux/PaxHeaders.11707/Smaps.pm,Linux-Smaps-0.13/lib/Linux/PaxHeaders.11707/Smaps.pm

meta_yml_declares_perl_version

If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.

meta_yml_has_license

Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.

has_separate_license_file

This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.

meta_yml_has_provides

Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.

meta_yml_has_repository_resource

Add a 'repository' resource to the META.yml via 'meta_add' accessor (for Module::Build) or META_ADD parameter (for ExtUtils::MakeMaker).

Modules

Name Abstract Version View
Linux::Smaps a Perl interface to /proc/PID/smaps 0.13 metacpan

Provides

Name File View
Linux::Smaps::VMA lib/Linux/Smaps.pm metacpan

Other Files

Changes metacpan
MANIFEST metacpan
META.json metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan