Kwalitee Issues

meta_yml_conforms_to_known_spec

Take a look at the META.yml Spec at http://module-build.sourceforge.net/META-spec-v1.4.html (for version 1.4) or http://search.cpan.org/perldoc?CPAN::Meta::Spec (for version 2), and change your META.yml accordingly.

Error: '<undef>' for 'Config::IniFiles' is not a valid version. (requires -> Config::IniFiles) [Validation: 1.0];'<undef>' for 'FindBin' is not a valid version. (requires -> FindBin) [Validation: 1.0];'<undef>' for 'Log::Log4perl' is not a valid version. (requires -> Log::Log4perl) [Validation: 1.0];'<undef>' for 'Params::Validate' is not a valid version. (requires -> Params::Validate) [Validation: 1.0];'<undef>' for 'Test::More' is not a valid version. (requires -> Test::More) [Validation: 1.0]

prereq_matches_use

List all used modules in META.yml requires

Error:

  • Carp
  • Exporter

has_meta_json

Add a META.json to the distribution. Your buildtool should be able to autogenerate it.

meta_yml_declares_perl_version

If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.

meta_yml_has_license

Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.

meta_yml_has_provides

Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.

meta_yml_has_repository_resource

Add a 'repository' resource to the META.yml via 'meta_add' accessor (for Module::Build) or META_ADD parameter (for ExtUtils::MakeMaker).

Modules

Name Abstract Version View
Log::Log4perl::ConfigByInifile Get Log::Log4perl config from an ini-File 0.04 metacpan

Other Files

Changes metacpan
MANIFEST metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan