Loop-Flow-Object

Metadata

Analyzed metadata and errors of Loop-Flow-Object.

{
   "abstracts_in_pod" : {
      "Loop::Flow::Object" : "запуск цикла для объекта с контролем и переключением ветвления (fork), выполнение кода в указанных методах объекта."
   },
   "author" : "MCHE",
   "buildfile_executable" : 0,
   "dir_lib" : "lib",
   "dir_t" : "t",
   "dirs_array" : [
      "lib/Loop/Flow",
      "lib/Loop",
      "lib",
      "t",
      "t"
   ],
   "dist" : "Loop-Flow-Object",
   "dynamic_config" : 1,
   "error" : {
      "no_pod_errors" : "Loop-Flow-Object-0.03/lib/Loop/Flow/Object.pm --  Around line 224:  You forgot a '=back' before '=head1'"
   },
   "extension" : "tar.gz",
   "extractable" : 1,
   "extracts_nicely" : 1,
   "file__build" : 0,
   "file_blib" : 0,
   "file_build" : 0,
   "file_build_pl" : "Build.PL",
   "file_changelog" : "Changes",
   "file_makefile" : 0,
   "file_makefile_pl" : "Makefile.PL",
   "file_manifest" : "MANIFEST",
   "file_meta_json" : "META.json",
   "file_meta_yml" : "META.yml",
   "file_pm_to_blib" : 0,
   "file_readme" : "README",
   "files_array" : [
      "Build.PL",
      "Changes",
      "MANIFEST",
      "META.json",
      "META.yml",
      "Makefile.PL",
      "README",
      "lib/Loop/Flow/Object.pm",
      "t/00-load.t",
      "t/manifest.t",
      "t/pod-coverage.t",
      "t/pod.t"
   ],
   "files_hash" : {
      "Build.PL" : {
         "mtime" : 1352261405,
         "size" : 687,
         "used" : [
            "5.006",
            "Module::Build",
            "strict",
            "warnings"
         ]
      },
      "Changes" : {
         "mtime" : 1352261405,
         "size" : 116
      },
      "MANIFEST" : {
         "mtime" : 1352261405,
         "size" : 159
      },
      "META.json" : {
         "mtime" : 1352261405,
         "size" : 1101
      },
      "META.yml" : {
         "mtime" : 1352261405,
         "size" : 663
      },
      "Makefile.PL" : {
         "mtime" : 1352261405,
         "required" : [
            "5.006"
         ],
         "size" : 433,
         "used" : [
            "ExtUtils::MakeMaker"
         ]
      },
      "README" : {
         "mtime" : 1352261405,
         "size" : 1206
      },
      "lib/Loop/Flow/Object.pm" : {
         "license" : "GPL_1,GPL_2,GPL_3",
         "module" : "Loop::Flow::Object",
         "mtime" : 1352261405,
         "size" : 6750,
         "used" : [
            "5.006",
            "POSIX",
            "strict",
            "warnings"
         ]
      },
      "t/00-load.t" : {
         "mtime" : 1352261405,
         "size" : 190,
         "used" : [
            "Test::More"
         ]
      },
      "t/manifest.t" : {
         "mtime" : 1352261405,
         "size" : 272,
         "used" : [
            "Test::More",
            "strict",
            "warnings"
         ],
         "used_in_eval" : [
            "Test::CheckManifest"
         ]
      },
      "t/pod-coverage.t" : {
         "mtime" : 1352261405,
         "size" : 551,
         "used" : [
            "Test::More",
            "strict",
            "warnings"
         ],
         "used_in_eval" : [
            "Pod::Coverage",
            "Test::Pod::Coverage"
         ]
      },
      "t/pod.t" : {
         "mtime" : 1352261405,
         "size" : 232,
         "used" : [
            "Test::More",
            "strict",
            "warnings"
         ],
         "used_in_eval" : [
            "Test::Pod"
         ]
      }
   },
   "got_prereq_from" : "META.yml",
   "kwalitee" : {
      "buildtool_not_executable" : 1,
      "consistent_version" : 1,
      "distname_matches_name_in_meta" : 1,
      "extractable" : 1,
      "extracts_nicely" : 1,
      "has_abstract_in_pod" : 1,
      "has_buildtool" : 1,
      "has_changelog" : 1,
      "has_human_readable_license" : 1,
      "has_known_license_in_source_file" : 1,
      "has_license_in_source_file" : 1,
      "has_manifest" : 1,
      "has_meta_yml" : 1,
      "has_proper_version" : 1,
      "has_readme" : 1,
      "has_separate_license_file" : 0,
      "has_tests" : 1,
      "has_tests_in_t_dir" : 1,
      "has_version" : 1,
      "kwalitee" : "97.73",
      "manifest_matches_dist" : 1,
      "meta_json_conforms_to_known_spec" : 1,
      "meta_json_is_parsable" : 1,
      "meta_yml_conforms_to_known_spec" : 1,
      "meta_yml_declares_perl_version" : 1,
      "meta_yml_has_license" : 1,
      "meta_yml_has_provides" : 1,
      "meta_yml_has_repository_resource" : 0,
      "meta_yml_is_parsable" : 1,
      "no_abstract_stub_in_pod" : 1,
      "no_broken_auto_install" : 1,
      "no_broken_module_install" : 1,
      "no_dot_dirs" : 1,
      "no_dot_underscore_files" : 1,
      "no_generated_files" : 1,
      "no_invalid_versions" : 1,
      "no_local_dirs" : 1,
      "no_mymeta_files" : 1,
      "no_pax_headers" : 1,
      "no_pod_errors" : 0,
      "no_stdin_for_prompting" : 1,
      "no_symlinks" : 1,
      "package_version_matches_dist_version" : 1,
      "portable_filenames" : 1,
      "proper_libs" : 1,
      "use_strict" : 1,
      "use_warnings" : 1,
      "valid_signature" : 1
   },
   "latest_mtime" : 1352261405,
   "license" : "perl defined in META.yml",
   "license_from_yaml" : "perl",
   "license_in_pod" : 1,
   "licenses" : {
      "GPL_1" : [
         "lib/Loop/Flow/Object.pm"
      ],
      "GPL_2" : [
         "lib/Loop/Flow/Object.pm"
      ],
      "GPL_3" : [
         "lib/Loop/Flow/Object.pm"
      ]
   },
   "manifest_matches_dist" : 1,
   "meta_json_is_parsable" : 1,
   "meta_json_spec_version" : "2",
   "meta_yml" : {
      "abstract" : "Looping code of one object with forking on/off. Executing code, control count and exit from loop by the object methods.",
      "author" : [
         "Mikhail Che <m.che@aukama.dyndns.org>"
      ],
      "build_requires" : {
         "Test::More" : "0"
      },
      "configure_requires" : {
         "Module::Build" : "0.38"
      },
      "dynamic_config" : "1",
      "generated_by" : "Module::Build version 0.38, CPAN::Meta::Converter version 2.112621",
      "license" : "perl",
      "meta-spec" : {
         "url" : "http://module-build.sourceforge.net/META-spec-v1.4.html",
         "version" : "1.4"
      },
      "name" : "Loop-Flow-Object",
      "provides" : {
         "Loop::Flow::Object" : {
            "file" : "lib/Loop/Flow/Object.pm",
            "version" : "0.03"
         }
      },
      "requires" : {
         "perl" : "5.006"
      },
      "resources" : {
         "license" : "http://dev.perl.org/licenses/"
      },
      "version" : "0.03"
   },
   "meta_yml_is_parsable" : 1,
   "meta_yml_spec_version" : "1.4",
   "modules" : [
      {
         "file" : "lib/Loop/Flow/Object.pm",
         "in_basedir" : 0,
         "in_lib" : 1,
         "module" : "Loop::Flow::Object"
      }
   ],
   "no_pax_headers" : 1,
   "package" : "Loop-Flow-Object-0.03.tar.gz",
   "prereq" : [
      {
         "is_build_prereq" : 1,
         "requires" : "Test::More",
         "type" : "build_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "perl",
         "type" : "runtime_requires",
         "version" : "5.006"
      },
      {
         "requires" : "Module::Build",
         "type" : "configure_requires",
         "version" : "0.38"
      }
   ],
   "released_epoch" : 1352261547,
   "size_packed" : 5437,
   "size_unpacked" : 12360,
   "uses" : {
      "required_in_config" : {
         "5.006" : 1
      },
      "used_in_code" : {
         "5.006" : 1,
         "POSIX" : 1,
         "strict" : 1,
         "warnings" : 1
      },
      "used_in_config" : {
         "5.006" : 1,
         "ExtUtils::MakeMaker" : 1,
         "Module::Build" : 1,
         "strict" : 1,
         "warnings" : 1
      },
      "used_in_eval_in_tests" : {
         "Pod::Coverage" : 1,
         "Test::CheckManifest" : 1,
         "Test::Pod" : 1,
         "Test::Pod::Coverage" : 1
      },
      "used_in_tests" : {
         "Test::More" : 4,
         "strict" : 3,
         "warnings" : 3
      }
   },
   "valid_signature" : -1,
   "version" : "0.03",
   "versions" : {
      "lib/Loop/Flow/Object.pm" : {
         "Loop::Flow::Object" : "0.03"
      }
   },
   "vname" : "Loop-Flow-Object-0.03"
}