Kwalitee Issues


Take a look at the META.yml Spec at (for version 1.4) or (for version 2), and change your META.yml accordingly.

Error: Expected a list structure (author) [Validation: 1.3]


Split the distribution, or fix the version numbers to make them consistent (use the highest version number to avoid version downgrade).

Error: 0.04,0.06


Add a META.json to the distribution. Your buildtool should be able to autogenerate it.


Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: Mediawiki::POD, Mediawiki::POD::HTML


Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.


Add a 'repository' resource to the META.yml via 'meta_add' accessor (for Module::Build) or META_ADD parameter (for ExtUtils::MakeMaker).


Name Abstract Version View
Mediawiki::POD convert POD to HTML suitable for a MediaWiki wiki 0.06 metacpan
Mediawiki::POD::HTML a subclass to catch X keywords and =head lines 0.04 metacpan

Other Files

Build.PL metacpan
MANIFEST metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan