Under maintenance.

Most probably CPANTS databases are being regenerated from scratch due to major changes in Kwalitee metrics or updates of relevant modules/perl. Usually this maintenance takes about a day or two, and some of the information may be old or missing tentatively. Sorry for the inconvenience.

Kwalitee Issues

buildtool_not_executable

Change the permissions of Build.PL/Makefile.PL to not-executable.

has_changelog

Add a Changelog (best named 'Changes') to the distribution. It should list at least major changes implemented in newer versions.

meta_yml_conforms_to_known_spec

Take a look at the META.yml Spec at http://module-build.sourceforge.net/META-spec-v1.4.html (for version 1.4) or http://search.cpan.org/perldoc?CPAN::Meta::Spec (for version 2), and change your META.yml accordingly.

Error: Missing mandatory field, 'abstract' (abstract) [Validation: 1.4];value is an undefined string (abstract) [Validation: 1.4]

package_version_matches_dist_version

Fix the version(s).

use_strict

Add 'use strict' (or its equivalents) to all modules, or convince us that your favorite module is well-known enough and people can easily see the modules are strictly written.

Error: MetasploitExpress::Parser, MetasploitExpress::Parser::Event, MetasploitExpress::Parser::Host, MetasploitExpress::Parser::Report, MetasploitExpress::Parser::ScanDetails, MetasploitExpress::Parser::Service, MetasploitExpress::Parser::Session, MetasploitExpress::Parser::Task

has_meta_json

Add a META.json to the distribution. Your buildtool should be able to autogenerate it.

meta_yml_declares_perl_version

If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.

meta_yml_has_license

Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.

use_warnings

Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: MetasploitExpress::Parser, MetasploitExpress::Parser::Event, MetasploitExpress::Parser::Host, MetasploitExpress::Parser::Report, MetasploitExpress::Parser::ScanDetails, MetasploitExpress::Parser::Service, MetasploitExpress::Parser::Session, MetasploitExpress::Parser::Task

has_separate_license_file

This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.

meta_yml_has_provides

Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.

meta_yml_has_repository_resource

Add a 'repository' resource to the META.yml via 'meta_add' accessor (for Module::Build) or META_ADD parameter (for ExtUtils::MakeMaker).

Modules

Name Abstract Version View
MetasploitExpress::Parser Parse metasploit express scan data with Perl metacpan
MetasploitExpress::Parser::Event metacpan
MetasploitExpress::Parser::Host metacpan
MetasploitExpress::Parser::Report metacpan
MetasploitExpress::Parser::ScanDetails metacpan
MetasploitExpress::Parser::Service metacpan
MetasploitExpress::Parser::Session metacpan
MetasploitExpress::Parser::Task metacpan

Other Files

MANIFEST metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan