The site is under maintenance.

Most probably the CPANTS databases are being regenerated from scratch behind the scenes due to the major change in Kwalitee metrics or the update of relevant modules/perl. Usually this maintenance takes about a day or two, and some of the information may be old or missing tentatively. Sorry for the inconvenience.

Module-Extract-Use

Metadata

Analyzed metadata and errors of Module-Extract-Use.

{
   "abstracts" : {
      "Module::Extract::Use" : "Pull out the modules a module explicitly uses"
   },
   "author" : "BDFOY",
   "buildfile_executable" : 0,
   "dir_lib" : "lib",
   "dir_t" : "t",
   "dirs_array" : [
      "lib",
      "lib/Module",
      "lib/Module/Extract",
      "t",
      "t/rt",
      "corpus",
      "examples"
   ],
   "dist" : "Module-Extract-Use",
   "dynamic_config" : 1,
   "error" : {},
   "extension" : "tar.gz",
   "external_license_file" : "LICENSE",
   "extractable" : 1,
   "extracts_nicely" : 1,
   "file__build" : 0,
   "file_blib" : 0,
   "file_build" : 0,
   "file_changelog" : "Changes",
   "file_license" : "LICENSE",
   "file_makefile" : 0,
   "file_makefile_pl" : "Makefile.PL",
   "file_manifest" : "MANIFEST",
   "file_meta_json" : "META.json",
   "file_meta_yml" : "META.yml",
   "file_pm_to_blib" : 0,
   "file_readme" : "README",
   "files_array" : [
      "README",
      "META.json",
      "Changes",
      "Makefile.PL",
      "META.yml",
      "MANIFEST",
      "LICENSE",
      "MANIFEST.SKIP",
      "lib/Module/Extract/Use.pm",
      "t/imports.t",
      "t/versions.t",
      "t/load.t",
      "t/get_modules.t",
      "t/test_manifest",
      "t/pod_coverage.t",
      "t/pod.t",
      "t/rt/79273.t",
      "examples/extract_modules"
   ],
   "files_hash" : {
      "Changes" : {
         "mtime" : 1388834364,
         "size" : 1329
      },
      "LICENSE" : {
         "mtime" : 1388834364,
         "size" : 69
      },
      "MANIFEST" : {
         "mtime" : 1388834365,
         "size" : 489
      },
      "MANIFEST.SKIP" : {
         "mtime" : 1388834364,
         "size" : 1033
      },
      "META.json" : {
         "mtime" : 1388834365,
         "size" : 1043
      },
      "META.yml" : {
         "mtime" : 1388834365,
         "size" : 599
      },
      "Makefile.PL" : {
         "mtime" : 1388834364,
         "required" : [
            "5.008"
         ],
         "size" : 858,
         "used" : [
            "ExtUtils::MakeMaker"
         ],
         "used_in_eval" : [
            "Test::Manifest"
         ]
      },
      "README" : {
         "mtime" : 1388834364,
         "size" : 477
      },
      "corpus/PackageImports.pm" : {
         "mtime" : 1388834364,
         "no_index" : 1,
         "size" : 291
      },
      "corpus/PackageVersion.pm" : {
         "mtime" : 1388834364,
         "no_index" : 1,
         "size" : 126
      },
      "corpus/RT79273.pm" : {
         "mtime" : 1388834364,
         "no_index" : 1,
         "size" : 132
      },
      "corpus/Repeated.pm" : {
         "mtime" : 1388834364,
         "no_index" : 1,
         "size" : 171
      },
      "examples/extract_modules" : {
         "mtime" : 1388834364,
         "size" : 2234
      },
      "lib/Module/Extract/Use.pm" : {
         "license" : "Perl_5",
         "module" : "Module::Extract::Use",
         "mtime" : 1388834364,
         "noed" : [
            "warnings"
         ],
         "required" : [
            "PPI"
         ],
         "size" : 4847,
         "used" : [
            "strict",
            "subs",
            "vars",
            "warnings"
         ]
      },
      "t/get_modules.t" : {
         "mtime" : 1388834364,
         "size" : 1490,
         "used" : [
            "File::Basename",
            "File::Spec::Functions",
            "Test::More",
            "strict"
         ]
      },
      "t/imports.t" : {
         "mtime" : 1388834364,
         "size" : 3513,
         "used" : [
            "Buster",
            "CGI",
            "File::Basename",
            "File::Spec::Functions",
            "LWP::Simple",
            "Mimi",
            "Test::More",
            "URI",
            "strict",
            "warnings"
         ]
      },
      "t/load.t" : {
         "mtime" : 1388834364,
         "size" : 198
      },
      "t/pod.t" : {
         "mtime" : 1388834364,
         "size" : 129,
         "used" : [
            "Test::More"
         ],
         "used_in_eval" : [
            "Test::Pod"
         ]
      },
      "t/pod_coverage.t" : {
         "mtime" : 1388834364,
         "size" : 185,
         "used" : [
            "Test::More"
         ],
         "used_in_eval" : [
            "Test::Pod::Coverage"
         ]
      },
      "t/rt/79273.t" : {
         "mtime" : 1388834364,
         "size" : 1183,
         "used" : [
            "File::Basename",
            "File::Spec::Functions",
            "Test::More",
            "strict"
         ]
      },
      "t/test_manifest" : {
         "mtime" : 1388834364,
         "size" : 74
      },
      "t/versions.t" : {
         "mtime" : 1388834364,
         "size" : 1445,
         "used" : [
            "Data::Dumper",
            "File::Basename",
            "File::Spec::Functions",
            "HTTP::Size",
            "LWP::Simple",
            "Test::More",
            "YAML::Syck",
            "strict"
         ]
      }
   },
   "got_prereq_from" : "META.yml",
   "kwalitee" : {
      "buildtool_not_executable" : 1,
      "consistent_version" : 1,
      "easily_repackageable_by_debian" : 1,
      "easily_repackageable_by_fedora" : 1,
      "extractable" : 1,
      "extracts_nicely" : 1,
      "fits_fedora_license" : 1,
      "has_abstract_in_pod" : 1,
      "has_buildtool" : 1,
      "has_changelog" : 1,
      "has_human_readable_license" : 1,
      "has_known_license_in_source_file" : 1,
      "has_license_in_source_file" : 1,
      "has_manifest" : 1,
      "has_meta_yml" : 1,
      "has_proper_version" : 1,
      "has_readme" : 1,
      "has_separate_license_file" : 1,
      "has_tests" : 1,
      "has_tests_in_t_dir" : 1,
      "has_version" : 1,
      "kwalitee" : "97.56",
      "manifest_matches_dist" : 1,
      "metayml_conforms_to_known_spec" : 1,
      "metayml_declares_perl_version" : 0,
      "metayml_has_license" : 1,
      "metayml_has_provides" : 0,
      "metayml_is_parsable" : 1,
      "no_abstract_stub_in_pod" : 1,
      "no_broken_auto_install" : 1,
      "no_broken_module_install" : 1,
      "no_dot_dirs" : 1,
      "no_dot_underscore_files" : 1,
      "no_generated_files" : 1,
      "no_invalid_versions" : 1,
      "no_local_dirs" : 1,
      "no_mymeta_files" : 1,
      "no_pax_headers" : 1,
      "no_pod_errors" : 1,
      "no_stdin_for_prompting" : 1,
      "no_symlinks" : 1,
      "package_version_matches_dist_version" : 1,
      "portable_filenames" : 1,
      "proper_libs" : 1,
      "use_strict" : 1,
      "use_warnings" : 1,
      "valid_signature" : 1
   },
   "latest_mtime" : 1388834365,
   "license" : "perl defined in META.yml defined in LICENSE",
   "license_file" : "lib/Module/Extract/Use.pm",
   "license_from_yaml" : "perl",
   "license_in_pod" : 1,
   "license_type" : "Perl_5",
   "licenses" : {
      "Perl_5" : [
         "lib/Module/Extract/Use.pm"
      ]
   },
   "manifest_matches_dist" : 1,
   "meta_yml" : {
      "abstract" : "Extract the modules that a modules uses",
      "author" : [
         "brian d foy <bdfoy@cpan.org>"
      ],
      "build_requires" : {
         "ExtUtils::MakeMaker" : "0"
      },
      "configure_requires" : {
         "ExtUtils::MakeMaker" : "0"
      },
      "dynamic_config" : "1",
      "generated_by" : "ExtUtils::MakeMaker version 6.62, CPAN::Meta::Converter version 2.112150",
      "keywords" : [
         "ppi",
         "parsing",
         "static-analysis",
         "modules"
      ],
      "license" : "perl",
      "meta-spec" : {
         "url" : "http://module-build.sourceforge.net/META-spec-v1.4.html",
         "version" : "1.4"
      },
      "name" : "Module-Extract-Use",
      "no_index" : {
         "directory" : [
            "corpus"
         ]
      },
      "requires" : {
         "PPI" : "0",
         "Test::More" : "0",
         "Test::Output" : "0"
      },
      "resources" : {},
      "version" : "1.04"
   },
   "metayml_is_parsable" : 1,
   "modules" : [
      {
         "file" : "lib/Module/Extract/Use.pm",
         "in_basedir" : 0,
         "in_lib" : 1,
         "module" : "Module::Extract::Use"
      }
   ],
   "no_index" : "^corpus/",
   "no_pax_headers" : 1,
   "package" : "Module-Extract-Use-1.04.tar.gz",
   "prereq" : [
      {
         "is_build_prereq" : 1,
         "requires" : "ExtUtils::MakeMaker",
         "type" : "build_requires",
         "version" : "0"
      },
      {
         "requires" : "ExtUtils::MakeMaker",
         "type" : "configure_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "Test::More",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "Test::Output",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "PPI",
         "type" : "runtime_requires",
         "version" : "0"
      }
   ],
   "released_epoch" : 1388834415,
   "size_packed" : 7460,
   "size_unpacked" : 21915,
   "uses" : {
      "noed_in_code" : {
         "warnings" : 1
      },
      "required_in_code" : {
         "PPI" : 1
      },
      "required_in_config" : {
         "5.008" : 1
      },
      "used_in_code" : {
         "strict" : 1,
         "subs" : 1,
         "vars" : 1,
         "warnings" : 1
      },
      "used_in_config" : {
         "ExtUtils::MakeMaker" : 1
      },
      "used_in_eval_in_config" : {
         "Test::Manifest" : 1
      },
      "used_in_eval_in_tests" : {
         "Test::Pod" : 1,
         "Test::Pod::Coverage" : 1
      },
      "used_in_tests" : {
         "Buster" : 1,
         "CGI" : 1,
         "Data::Dumper" : 1,
         "File::Basename" : 4,
         "File::Spec::Functions" : 5,
         "HTTP::Size" : 1,
         "LWP::Simple" : 2,
         "Mimi" : 1,
         "Test::More" : 6,
         "URI" : 1,
         "YAML::Syck" : 1,
         "strict" : 4,
         "warnings" : 1
      }
   },
   "valid_signature" : -1,
   "version" : "1.04",
   "versions" : {
      "lib/Module/Extract/Use.pm" : {
         "Module::Extract::Use" : "1.04",
         "Module::Extract::Use::Item" : "1.04"
      }
   },
   "vname" : "Module-Extract-Use-1.04"
}