Under maintenance.

Most probably CPANTS databases are being regenerated from scratch due to major changes in Kwalitee metrics or updates of relevant modules/perl. Usually this maintenance takes about a day or two, and some of the information may be old or missing tentatively. Sorry for the inconvenience.

MongoDB

Prerequisites

MongoDB declares the following 35 modules as prerequisites.

Listed PrerequisitesRequired VersionLatest DistKwalitee
List::Util0Scalar-List-Utils-1.45134.29
Type::Utils0Type-Tiny-1.000005134.29
Socket0Socket-2.021122.86
boolean0.25boolean-0.45134.29
Authen::SCRAM::Client0.003Authen-SCRAM-0.005134.29
Type::Library0Type-Tiny-1.000005134.29
IO::Socket0IO-1.25125.71
constant0constant-1.33128.57
version0version-0.9916128.57
Time::HiRes0Time-HiRes-1.9732131.43
Sub::Quote0Moo-2.001001134.29
Encode0Encode-2.83125.71
IO::File0IO-1.25125.71
overload0perl0.00
Tie::IxHash0Tie-IxHash-1.23122.86
Carp0Carp-1.38125.71
strict0perl0.00
Exporter5.57Exporter-5.72122.86
Moo::Role0Moo-2.001001134.29
Types::Standard0Type-Tiny-1.000005134.29
MIME::Base6400.00
Moo2Moo-2.001001134.29
DateTime0.78DateTime-1.26134.29
Class::XSAccessor0Class-XSAccessor-1.19134.29
XSLoader0XSLoader-0.16125.71
Try::Tiny0Try-Tiny-0.24134.29
perlv5.8.0perl0.00
warnings0perl0.00
if0if-0.0605111.43
re0perl0.00
Type::Tiny::XS0Type-Tiny-XS-0.012134.29
Digest::MD50Digest-MD5-2.55131.43
Safe::Isa0Safe-Isa-1.000005134.29
namespace::clean0namespace-clean-0.26128.57
Scalar::Util0Scalar-List-Utils-1.45134.29

MongoDB declares the following 15 modules as build prerequisites.

Listed Build PrerequisitesRequired VersionLatest DistKwalitee
threads::shared0threads-shared-1.48131.43
utf80perl0.00
JSON::MaybeXS0JSON-MaybeXS-1.003005134.29
Path::Tiny0.054Path-Tiny-0.084134.29
Test::Deep0.111Test-Deep-1.120131.43
Data::Dumper0Data-Dumper-2.154108.57
Test::More0.96Test-Simple-1.001014122.86
FileHandle0perl0.00
File::Temp00.00
File::Spec0PathTools-3.62125.71
Math::BigInt0Math-BigInt-1.999715134.29
bigint0bignum-0.42131.43
ExtUtils::MakeMaker0ExtUtils-MakeMaker-7.10131.43
Test::Fatal0Test-Fatal-0.014131.43
lib0lib-0.63120.00

MongoDB declares the following 7 modules as optional prerequisites.

Listed Optional PrerequisitesRequired VersionLatest DistKwalitee
Path::Tiny0.052Path-Tiny-0.084134.285714285714
IO::Socket::IP0.25IO-Socket-IP-0.37125.714285714286
Mozilla::CA20130114Mozilla-CA-20160104125.714285714286
ExtUtils::MakeMaker0ExtUtils-MakeMaker-7.10131.428571428571
IO::Socket::SSL1.42IO-Socket-SSL-2.024122.857142857143
Net::SSLeay1.49Net-SSLeay-1.72128.571428571429
Config::AutoConf0.22Config-AutoConf-0.311131.428571428571