Kwalitee Issues

No Core Issues.

meta_yml_declares_perl_version

If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.

use_warnings

Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: MooX::Struct::Util

build_prereq_matches_use

List all modules used in the test suite in META.yml build_requires

Error:

  • Data::Printer

Modules

Name Abstract Version View
MooX::Struct make simple lightweight record-like structures that make sounds like cows 0.013 metacpan
MooX::Struct::Processor 0.013 metacpan
MooX::Struct::Util extensions for MooX::Struct that would have been overkill to include 0.013 metacpan

Other Files

Changes metacpan
MANIFEST metacpan
META.json metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan
dist.ini metacpan