Kwalitee Issues

has_manifest

Add a MANIFEST to the distribution. Your buildtool should be able to autogenerate it (eg "make manifest" or "./Build manifest")

has_meta_yml

Add a META.yml to the distribution. Your buildtool should be able to autogenerate it.

manifest_matches_dist

Run a proper command ("make manifest" or "./Build manifest", maybe with a force option), or use a distribution builder to generate the MANIFEST. Or update MANIFEST manually.

Error: Cannot find MANIFEST in dist.

no_pod_errors

Remove the POD errors. You can check for POD errors automatically by including Test::Pod to your test suite.

Error: Net-PSYC-0.21/PSYC/Circuit.pm -- Around line 664: Unknown directive: =onion Net-PSYC-0.21/PSYC/Event.pm -- Around line 210: Unknown directive: =stateAround line 278: Unknown directive: =stateAround line 290: Unknown directive: =stateAround line 298: Unknown directive: =stateAround line 311: =cut found outside a pod block. Skipping to next block.Around line 313: =cut found outside a pod block. Skipping to next block.Around line 316: Unknown directive: =state Net-PSYC-0.21/PSYC/MMP/State.pm -- Around line 53: Unknown directive: =old Net-PSYC-0.21/PSYC.pm -- Around line 735: Unknown directive: =stateAround line 802: Unknown directive: =stateAround line 870: Unknown directive: =stateAround line 875: Unknown directive: =stateAround line 910: Unknown directive: =stateAround line 916: Unknown directive: =state

prereq_matches_use

List all used modules in META.yml requires

Error:

  • Compress::Zlib
  • Event
  • Glib

use_strict

Add 'use strict' (or its equivalents) to all modules, or convince us that your favorite module is well-known enough and people can easily see the modules are strictly written.

Error: Net::PSYC::Hook

consistent_version

Split the distribution, or fix the version numbers to make them consistent (use the highest version number to avoid version downgrade).

Error: 0.1,0.2,0.21,0.4,0.5

has_meta_json

Add a META.json to the distribution. Your buildtool should be able to autogenerate it.

meta_yml_has_license

Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.

use_warnings

Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: Net::PSYC, Net::PSYC::Circuit, Net::PSYC::Client, Net::PSYC::Datagram, Net::PSYC::Event, Net::PSYC::Event::Event, Net::PSYC::Event::Glib, Net::PSYC::Event::IO_Select, Net::PSYC::FileShare, Net::PSYC::Hook, Net::PSYC::MMP::Compress, Net::PSYC::MMP::State, Net::PSYC::State, Net::PSYC::Storage, Net::PSYC::Tie::AbbrevHash, Net::PSYC::Tie::File

build_prereq_matches_use

List all modules used in the test suite in META.yml build_requires

Error:

  • Storable
  • Test::Simple
  • strict

has_separate_license_file

This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.

Modules

Name Abstract Version View
Net::PSYC Implementation of the Protocol for SYnchronous Conferencing. 0.21 metacpan
Net::PSYC::Circuit 0.4 metacpan
Net::PSYC::Client 0.4 metacpan
Net::PSYC::Datagram 0.5 metacpan
Net::PSYC::Event Event wrapper for various event systems. 0.4 metacpan
Net::PSYC::Event::Event 0.1 metacpan
Net::PSYC::Event::Glib 0.1 metacpan
Net::PSYC::Event::IO_Select 0.4 metacpan
Net::PSYC::FileShare metacpan
Net::PSYC::Hook metacpan
Net::PSYC::MMP::Compress metacpan
Net::PSYC::MMP::State metacpan
Net::PSYC::State 0.1 metacpan
Net::PSYC::Storage 0.1 metacpan
Net::PSYC::Tie::AbbrevHash 0.2 metacpan
Net::PSYC::Tie::File 0.1 metacpan

Provides

Name File View
Net::PSYC::Circuit::C PSYC/Circuit.pm metacpan
Net::PSYC::Circuit::L PSYC/Circuit.pm metacpan
Net::PSYC::Event::Wrapper PSYC/Event.pm metacpan

Other Files

Changes metacpan
Makefile.PL metacpan
README metacpan