Kwalitee Issues


Change the permissions of Build.PL/Makefile.PL to not-executable.


Add a README to the distribution. It should contain a quick description of your module and how to install it.


Remove the POD errors. You can check for POD errors automatically by including Test::Pod to your test suite.

Error: Net-Social-0.4/lib/Net/Social/ -- Around line 100: You forgot a '=back' before '=head2'Around line 134: Unknown directive: =over4Around line 136: '=item' outside of any '=over'


Add a META.json to the distribution. Your buildtool should be able to autogenerate it.


If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.


Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.


Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: Net::Social, Net::Social::Service


This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.


Add a 'repository' resource to the META.yml via 'meta_add' accessor (for Module::Build) or META_ADD parameter (for ExtUtils::MakeMaker).


Name Abstract Version View
Net::Social abstracted interface for social networks 0.4 metacpan
Net::Social::Service the base package for all the Net::Social plugins metacpan

Other Files

Build.PL metacpan
Changes metacpan
MANIFEST metacpan
META.yml metacpan
Makefile.PL metacpan