Kwalitee Issues

meta_yml_conforms_to_known_spec

Take a look at the META.yml Spec at http://module-build.sourceforge.net/META-spec-v1.4.html (for version 1.4) or http://search.cpan.org/perldoc?CPAN::Meta::Spec (for version 2), and change your META.yml accordingly.

Error: Expected a list structure (author) [Validation: 1.3];License '<undef>' is invalid (license) [Validation: 1.3];Missing mandatory field, 'abstract' (abstract) [Validation: 1.3];Missing mandatory field, 'author' (author) [Validation: 1.3];Missing mandatory field, 'license' (license) [Validation: 1.3];value is an undefined string (abstract) [Validation: 1.3]

use_strict

Add 'use strict' (or its equivalents) to all modules, or convince us that your favorite module is well-known enough and people can easily see the modules are strictly written.

Error: Net::YahooMessenger::ChangeState, Net::YahooMessenger::NewFriendAlert, Net::YahooMessenger::ReceiveMessage, Net::YahooMessenger::SendMessage

consistent_version

Split the distribution, or fix the version numbers to make them consistent (use the highest version number to avoid version downgrade).

Error: 0.02,0.19

has_meta_json

Add a META.json to the distribution. Your buildtool should be able to autogenerate it.

meta_yml_declares_perl_version

If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.

meta_yml_has_license

Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.

use_warnings

Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: Net::YahooMessenger, Net::YahooMessenger::Buddy, Net::YahooMessenger::CRAM, Net::YahooMessenger::ChallengeStart, Net::YahooMessenger::ChangeState, Net::YahooMessenger::Event, Net::YahooMessenger::EventFactory, Net::YahooMessenger::EventHandler, Net::YahooMessenger::GoesOffline, Net::YahooMessenger::GoesOnline, Net::YahooMessenger::InvalidLogin, Net::YahooMessenger::Login, Net::YahooMessenger::NewFriendAlert, Net::YahooMessenger::NullEvent, Net::YahooMessenger::ReceiveBuddyList, Net::YahooMessenger::ReceiveMessage, Net::YahooMessenger::SendMessage, Net::YahooMessenger::ServerIsAlive, Net::YahooMessenger::UnImplementEvent

has_separate_license_file

This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.

meta_yml_has_provides

Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.

meta_yml_has_repository_resource

Add a 'repository' resource to the META.yml via 'meta_add' accessor (for Module::Build) or META_ADD parameter (for ExtUtils::MakeMaker).

Modules

Name Abstract Version View
Net::YahooMessenger Interface to the Yahoo!Messenger IM protocol 0.19 metacpan
Net::YahooMessenger::Buddy metacpan
Net::YahooMessenger::CRAM Yahoo Messenger Challenge-Response Authentication Mechanism. 0.02 metacpan
Net::YahooMessenger::ChallengeStart metacpan
Net::YahooMessenger::ChangeState metacpan
Net::YahooMessenger::Event metacpan
Net::YahooMessenger::EventFactory metacpan
Net::YahooMessenger::EventHandler metacpan
Net::YahooMessenger::GoesOffline metacpan
Net::YahooMessenger::GoesOnline metacpan
Net::YahooMessenger::HTTPS metacpan
Net::YahooMessenger::InvalidLogin metacpan
Net::YahooMessenger::Login metacpan
Net::YahooMessenger::NewFriendAlert metacpan
Net::YahooMessenger::NullEvent metacpan
Net::YahooMessenger::ReceiveBuddyList metacpan
Net::YahooMessenger::ReceiveMessage metacpan
Net::YahooMessenger::SendMessage metacpan
Net::YahooMessenger::ServerIsAlive metacpan
Net::YahooMessenger::UnImplementEvent metacpan

Other Files

Changes metacpan
MANIFEST metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan