NetSDS-Message

Metadata

Analyzed metadata and errors of NetSDS-Message.

{
   "abstracts_in_pod" : {
      "NetSDS::Const::Message" : "common constants for messaging",
      "NetSDS::Message" : "common mobile message (SMS, MMS, IM)",
      "NetSDS::Message::SMS" : "short message according to ETSI GSM 03.40",
      "NetSDS::Util::SMS" : "routines for SMS data processing"
   },
   "author" : "RATTLER",
   "buildfile_executable" : 0,
   "dir_lib" : "lib",
   "dir_t" : "t",
   "dirs_array" : [
      "samples",
      "lib",
      "lib/NetSDS",
      "lib/NetSDS/Const",
      "lib/NetSDS/Message",
      "lib/NetSDS/Util",
      "t"
   ],
   "dist" : "NetSDS-Message",
   "dynamic_config" : 0,
   "error" : {
      "no_pod_errors" : "NetSDS-Message-0.021/lib/NetSDS/Const/Message.pm -- Around line 172:  Non-ASCII character seen before =encoding in 'основные'. Assuming UTF-8"
   },
   "extension" : "tar.gz",
   "extractable" : 1,
   "extracts_nicely" : 1,
   "file__build" : 0,
   "file_blib" : 0,
   "file_build" : 0,
   "file_build_pl" : "Build.PL",
   "file_changelog" : "Changes",
   "file_makefile" : 0,
   "file_makefile_pl" : "Makefile.PL",
   "file_manifest" : "MANIFEST",
   "file_meta_yml" : "META.yml",
   "file_pm_to_blib" : 0,
   "file_readme" : "README",
   "files_array" : [
      "README",
      "Build.PL",
      "NetSDS-Message-0.01.tar.gz",
      "Changes",
      "Makefile.PL",
      "META.yml",
      "MANIFEST",
      "samples/simple.pl",
      "lib/NetSDS/Message.pm",
      "lib/NetSDS/Const/Message.pm",
      "lib/NetSDS/Message/SMS.pm",
      "lib/NetSDS/Util/SMS.pm",
      "t/03_pod_coverage.t",
      "t/02_pod.t",
      "t/01_load.t"
   ],
   "files_hash" : {
      "Build.PL" : {
         "mtime" : 1251309423,
         "size" : 1870,
         "used" : [
            "Module::Build",
            "strict",
            "warnings"
         ]
      },
      "Changes" : {
         "mtime" : 1251743232,
         "size" : 230
      },
      "MANIFEST" : {
         "mtime" : 1251743178,
         "size" : 262
      },
      "META.yml" : {
         "mtime" : 1251743260,
         "size" : 954
      },
      "Makefile.PL" : {
         "mtime" : 1251743260,
         "size" : 868,
         "used" : [
            "ExtUtils::MakeMaker"
         ]
      },
      "NetSDS-Message-0.01.tar.gz" : {
         "mtime" : 1251309474,
         "size" : 39243
      },
      "README" : {
         "mtime" : 1251743260,
         "size" : 4166
      },
      "lib/NetSDS/Const/Message.pm" : {
         "license" : "GPL_1,GPL_2,GPL_3",
         "module" : "NetSDS::Const::Message",
         "mtime" : 1251741729,
         "size" : 7391,
         "used" : [
            "5.8.0",
            "Exporter",
            "constant",
            "strict",
            "version",
            "warnings"
         ]
      },
      "lib/NetSDS/Message.pm" : {
         "license" : "GPL_1,GPL_2,GPL_3",
         "module" : "NetSDS::Message",
         "mtime" : 1251741748,
         "size" : 8236,
         "used" : [
            "5.8.0",
            "NetSDS::Class::Abstract",
            "NetSDS::Util::Misc",
            "strict",
            "version",
            "warnings"
         ]
      },
      "lib/NetSDS/Message/SMS.pm" : {
         "license" : "GPL_1,GPL_2,GPL_3",
         "module" : "NetSDS::Message::SMS",
         "mtime" : 1251741861,
         "size" : 9225,
         "used" : [
            "5.8.0",
            "Exporter",
            "NetSDS::Const::Message",
            "NetSDS::Message",
            "NetSDS::Util::Convert",
            "NetSDS::Util::SMS",
            "NetSDS::Util::String",
            "strict",
            "version",
            "warnings"
         ]
      },
      "lib/NetSDS/Util/SMS.pm" : {
         "license" : "GPL_1,GPL_2,GPL_3",
         "module" : "NetSDS::Util::SMS",
         "mtime" : 1251741769,
         "size" : 19604,
         "used" : [
            "5.8.0",
            "Exporter",
            "NetSDS::Class::Abstract",
            "NetSDS::Const",
            "NetSDS::Const::Message",
            "NetSDS::Util::Convert",
            "NetSDS::Util::String",
            "POSIX",
            "strict",
            "version",
            "warnings"
         ]
      },
      "samples/simple.pl" : {
         "mtime" : 1251741145,
         "size" : 1219
      },
      "t/01_load.t" : {
         "mtime" : 1251200695,
         "size" : 740,
         "used" : [
            "Test::More",
            "strict",
            "warnings"
         ]
      },
      "t/02_pod.t" : {
         "mtime" : 1251200590,
         "size" : 707,
         "used" : [
            "Test::More",
            "strict",
            "warnings"
         ],
         "used_in_eval" : [
            "Test::Pod"
         ]
      },
      "t/03_pod_coverage.t" : {
         "mtime" : 1251200590,
         "size" : 682,
         "used" : [
            "Test::More",
            "strict",
            "warnings"
         ],
         "used_in_eval" : [
            "Test::Pod::Coverage"
         ]
      }
   },
   "got_prereq_from" : "META.yml",
   "kwalitee" : {
      "buildtool_not_executable" : 1,
      "consistent_version" : 1,
      "easily_repackageable_by_debian" : 1,
      "easily_repackageable_by_fedora" : 1,
      "extractable" : 1,
      "extracts_nicely" : 1,
      "fits_fedora_license" : 1,
      "has_abstract_in_pod" : 1,
      "has_buildtool" : 1,
      "has_changelog" : 1,
      "has_human_readable_license" : 1,
      "has_known_license_in_source_file" : 1,
      "has_license_in_source_file" : 1,
      "has_manifest" : 1,
      "has_meta_yml" : 1,
      "has_proper_version" : 1,
      "has_readme" : 1,
      "has_separate_license_file" : 0,
      "has_tests" : 1,
      "has_tests_in_t_dir" : 1,
      "has_version" : 1,
      "kwalitee" : "97.56",
      "manifest_matches_dist" : 1,
      "metayml_conforms_to_known_spec" : 1,
      "metayml_declares_perl_version" : 1,
      "metayml_has_license" : 1,
      "metayml_has_provides" : 1,
      "metayml_has_repository_resource" : 0,
      "metayml_is_parsable" : 1,
      "no_abstract_stub_in_pod" : 1,
      "no_broken_auto_install" : 1,
      "no_broken_module_install" : 1,
      "no_dot_dirs" : 1,
      "no_dot_underscore_files" : 1,
      "no_generated_files" : 1,
      "no_invalid_versions" : 1,
      "no_local_dirs" : 1,
      "no_mymeta_files" : 1,
      "no_pax_headers" : 1,
      "no_pod_errors" : 0,
      "no_stdin_for_prompting" : 1,
      "no_symlinks" : 1,
      "package_version_matches_dist_version" : 1,
      "portable_filenames" : 1,
      "proper_libs" : 1,
      "use_strict" : 1,
      "use_warnings" : 1,
      "valid_signature" : 1
   },
   "latest_mtime" : 1251743260,
   "license" : "gpl defined in META.yml",
   "license_from_yaml" : "gpl",
   "license_in_pod" : 1,
   "licenses" : {
      "GPL_1" : [
         "lib/NetSDS/Const/Message.pm",
         "lib/NetSDS/Message.pm",
         "lib/NetSDS/Message/SMS.pm",
         "lib/NetSDS/Util/SMS.pm"
      ],
      "GPL_2" : [
         "lib/NetSDS/Const/Message.pm",
         "lib/NetSDS/Message.pm",
         "lib/NetSDS/Message/SMS.pm",
         "lib/NetSDS/Util/SMS.pm"
      ],
      "GPL_3" : [
         "lib/NetSDS/Const/Message.pm",
         "lib/NetSDS/Message.pm",
         "lib/NetSDS/Message/SMS.pm",
         "lib/NetSDS/Util/SMS.pm"
      ]
   },
   "manifest_matches_dist" : 1,
   "meta_yml" : {
      "abstract" : "Messages (SMS, MMS, etc) processing libraries for NetSDS",
      "author" : [
         "Michael Bochkaryov <misha@rattler.kiev.ua>"
      ],
      "build_requires" : {
         "Module::Build" : "0.2805",
         "Test::More" : "0.62",
         "Test::Pod" : "1.26",
         "Test::Pod::Coverage" : "1.08"
      },
      "generated_by" : "Module::Build version 0.2808",
      "license" : "gpl",
      "meta-spec" : {
         "url" : "http://module-build.sourceforge.net/META-spec-v1.2.html",
         "version" : "1.2"
      },
      "name" : "NetSDS-Message",
      "provides" : {
         "NetSDS::Const::Message" : {
            "file" : "lib/NetSDS/Const/Message.pm",
            "version" : "0.021"
         },
         "NetSDS::Message" : {
            "file" : "lib/NetSDS/Message.pm",
            "version" : "0.021"
         },
         "NetSDS::Message::SMS" : {
            "file" : "lib/NetSDS/Message/SMS.pm",
            "version" : "0.021"
         },
         "NetSDS::Util::SMS" : {
            "file" : "lib/NetSDS/Util/SMS.pm",
            "version" : "0.021"
         }
      },
      "requires" : {
         "NetSDS" : "1.000",
         "NetSDS::Class::Abstract" : "1.000",
         "NetSDS::Util::Convert" : "1.000",
         "NetSDS::Util::String" : "1.000",
         "perl" : "5.008",
         "version" : "0.50"
      },
      "resources" : {
         "license" : "http://www.opensource.org/licenses/gpl-license.php"
      },
      "version" : "0.021"
   },
   "metayml_is_parsable" : 1,
   "modules" : [
      {
         "file" : "lib/NetSDS/Const/Message.pm",
         "in_basedir" : 0,
         "in_lib" : 1,
         "module" : "NetSDS::Const::Message"
      },
      {
         "file" : "lib/NetSDS/Message/SMS.pm",
         "in_basedir" : 0,
         "in_lib" : 1,
         "module" : "NetSDS::Message::SMS"
      },
      {
         "file" : "lib/NetSDS/Util/SMS.pm",
         "in_basedir" : 0,
         "in_lib" : 1,
         "module" : "NetSDS::Util::SMS"
      },
      {
         "file" : "lib/NetSDS/Message.pm",
         "in_basedir" : 0,
         "in_lib" : 1,
         "module" : "NetSDS::Message"
      }
   ],
   "no_pax_headers" : 1,
   "package" : "NetSDS-Message-0.021.tar.gz",
   "prereq" : [
      {
         "is_prereq" : 1,
         "requires" : "version",
         "type" : "runtime_requires",
         "version" : "0.50"
      },
      {
         "is_build_prereq" : 1,
         "requires" : "Test::Pod::Coverage",
         "type" : "build_requires",
         "version" : "1.08"
      },
      {
         "is_prereq" : 1,
         "requires" : "NetSDS::Util::Convert",
         "type" : "runtime_requires",
         "version" : "1.000"
      },
      {
         "is_build_prereq" : 1,
         "requires" : "Test::More",
         "type" : "build_requires",
         "version" : "0.62"
      },
      {
         "is_build_prereq" : 1,
         "requires" : "Module::Build",
         "type" : "build_requires",
         "version" : "0.2805"
      },
      {
         "is_prereq" : 1,
         "requires" : "NetSDS::Class::Abstract",
         "type" : "runtime_requires",
         "version" : "1.000"
      },
      {
         "is_prereq" : 1,
         "requires" : "perl",
         "type" : "runtime_requires",
         "version" : "5.008"
      },
      {
         "is_build_prereq" : 1,
         "requires" : "Test::Pod",
         "type" : "build_requires",
         "version" : "1.26"
      },
      {
         "is_prereq" : 1,
         "requires" : "NetSDS::Util::String",
         "type" : "runtime_requires",
         "version" : "1.000"
      },
      {
         "is_prereq" : 1,
         "requires" : "NetSDS",
         "type" : "runtime_requires",
         "version" : "1.000"
      }
   ],
   "released_epoch" : 1251743381,
   "size_packed" : 55617,
   "size_unpacked" : 95397,
   "uses" : {
      "used_in_code" : {
         "5.8.0" : 4,
         "Exporter" : 3,
         "NetSDS::Class::Abstract" : 2,
         "NetSDS::Const" : 1,
         "NetSDS::Util::Convert" : 2,
         "NetSDS::Util::Misc" : 1,
         "NetSDS::Util::String" : 2,
         "POSIX" : 1,
         "constant" : 43,
         "strict" : 4,
         "version" : 4,
         "warnings" : 4
      },
      "used_in_config" : {
         "ExtUtils::MakeMaker" : 1,
         "Module::Build" : 1,
         "strict" : 1,
         "warnings" : 1
      },
      "used_in_eval_in_tests" : {
         "Test::Pod" : 1,
         "Test::Pod::Coverage" : 1
      },
      "used_in_tests" : {
         "Test::More" : 3,
         "strict" : 3,
         "warnings" : 3
      }
   },
   "valid_signature" : -1,
   "version" : "0.021",
   "versions" : {
      "lib/NetSDS/Const/Message.pm" : {
         "NetSDS::Const::Message" : "0.021"
      },
      "lib/NetSDS/Message.pm" : {
         "NetSDS::Message" : "0.021"
      },
      "lib/NetSDS/Message/SMS.pm" : {
         "NetSDS::Message::SMS" : "0.021"
      },
      "lib/NetSDS/Util/SMS.pm" : {
         "NetSDS::Util::SMS" : "0.021"
      }
   },
   "vname" : "NetSDS-Message-0.021"
}