NetworkInfo-Discovery-NetBIOS

Kwalitee Fails

Core metrics

These fails do affect your Kwalitee scores. This distribution may not be installed cleanly, or may have some issues in license or documentation. Please consider fixing them, or tell us if they are false.

metricremedy
meta yml is parsable

The META.yml file of this distribution could not be parsed by the version of CPAN::Meta::YAML.pm CPANTS is using.

If you don't have one, add a META.yml file. Else, upgrade your YAML generator so it produces valid YAML.

meta yml conforms to known spec

META.yml does not conform to any recognised META.yml Spec.

Take a look at the META.yml Spec at http://module-build.sourceforge.net/META-spec-v1.4.html (for version 1.4) or http://search.cpan.org/perldoc?CPAN::Meta::Spec (for version 2), and change your META.yml accordingly.

no pod errors

The documentation for this distribution contains syntactic errors in its POD. Note that this metric tests all .pl, .pm and .pod files, even if they are in t/. See 'pod_message' in the dist error view for more info.

Remove the POD errors. You can check for POD errors automatically by including Test::Pod to your test suite.

Extra metrics

These fails affect your total Kwalitee score, but don't affect the one for the Game. Some of them should be fixed by all means. Others are just matters of taste.

metricremedy
meta yml declares perl version

This distribution does not declare the minimum perl version in META.yml.

If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.

meta yml has license

This distribution does not have a license defined in META.yml.

Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.

use warnings

This distribution does not 'use warnings;' (or its equivalents) in all of its modules. Note that this is not about that your modules actually warn when something bad happens. It's bad if nobody can tell if a module warns or not, without reading the source code of your favorite module that actually enforces warnings. In other words, it's bad if someone feels the need to add 'use warnings' to your modules.

Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

is prereq

This distribution is not required by another distribution by another author.

Convince / force / bribe another CPAN author to use this distribution.

Experimental metrics

These fails are not serious and don't affect your Kwalitee scores at all.

metricremedy
meta yml has provides

This distribution does not have a list of provided modules defined in META.yml.

Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.

meta yml has repository resource

This distribution does not have a link to a repository in META.yml.

Add a 'repository' resource to the META.yml via 'meta_add' accessor (for Module::Build) or META_ADD parameter (for ExtUtils::MakeMaker).

build prereq matches use

This distribution uses a module or a dist in its test suite that's not listed as a build prerequisite.

List all modules used in the test suite in META.yml build_requires

fits fedora license

Fits the licensing requirements of Fedora (Acceptable licenses: (perl, apache, artistic_2, gpl, lgpl, mit, mozilla)).

Replace the license or convince Fedora to accept this license as well.

easily repackageable by fedora

It is easy to repackage this module by Fedora.

Fix each one of the metrics this depends on.

History