PAR-Dist-InstallPPD-GUI

Metadata

Analyzed metadata and errors of PAR-Dist-InstallPPD-GUI.

{
   "abstracts" : {
      "PAR::Dist::InstallPPD::GUI" : "GUI frontend for PAR::Dist::InstallPPD",
      "PAR::Dist::InstallPPD::GUI::Config" : "Implements the Config tab",
      "PAR::Dist::InstallPPD::GUI::Install" : "Implements the Install tab",
      "PAR::Dist::InstallPPD::GUI::Installed" : "Implements the Installed tab"
   },
   "author" : "SMUELLER",
   "buildfile_executable" : 0,
   "dir_lib" : "lib",
   "dir_t" : "t",
   "dirs_array" : [
      "lib",
      "lib/PAR",
      "lib/PAR/Dist",
      "lib/PAR/Dist/InstallPPD",
      "lib/PAR/Dist/InstallPPD/GUI",
      "t",
      "inc",
      "inc/Module",
      "inc/Module/Install",
      "config",
      "bin"
   ],
   "dist" : "PAR-Dist-InstallPPD-GUI",
   "dynamic_config" : 0,
   "error" : {
      "metayml_conforms_to_known_spec" : "Expected a list structure (author) [Validation: 1.3]"
   },
   "extension" : "tar.gz",
   "extractable" : 1,
   "extracts_nicely" : 1,
   "file__build" : 0,
   "file_blib" : 0,
   "file_build" : 0,
   "file_changelog" : "Changes",
   "file_makefile" : 0,
   "file_makefile_pl" : "Makefile.PL",
   "file_manifest" : "MANIFEST",
   "file_meta_yml" : "META.yml",
   "file_pm_to_blib" : 0,
   "file_readme" : "README",
   "files_array" : [
      "README",
      "Changes",
      "Makefile.PL",
      "META.yml",
      "MANIFEST",
      "lib/PAR/Dist/InstallPPD/GUI.pm",
      "lib/PAR/Dist/InstallPPD/GUI/Config.pm",
      "lib/PAR/Dist/InstallPPD/GUI/Installed.pm",
      "lib/PAR/Dist/InstallPPD/GUI/Install.pm",
      "config/config.ini",
      "bin/parinstallppdgui"
   ],
   "files_hash" : {
      "Changes" : {
         "mtime" : 1168867937,
         "size" : 778
      },
      "MANIFEST" : {
         "mtime" : 1168868173,
         "size" : 558
      },
      "META.yml" : {
         "mtime" : 1168868149,
         "size" : 622
      },
      "Makefile.PL" : {
         "mtime" : 1168868105,
         "size" : 1145,
         "used" : [
            "File::Spec",
            "inc::Module::Install"
         ]
      },
      "README" : {
         "mtime" : 1168868131,
         "size" : 1408
      },
      "bin/parinstallppdgui" : {
         "mtime" : 1168868147,
         "size" : 1123
      },
      "config/config.ini" : {
         "mtime" : 1168868148,
         "size" : 109
      },
      "inc/Module/Install.pm" : {
         "mtime" : 1168868148,
         "no_index" : 1,
         "size" : 8073
      },
      "inc/Module/Install/Base.pm" : {
         "mtime" : 1168868148,
         "no_index" : 1,
         "size" : 1053
      },
      "inc/Module/Install/Can.pm" : {
         "mtime" : 1168868149,
         "no_index" : 1,
         "size" : 1788
      },
      "inc/Module/Install/Fetch.pm" : {
         "mtime" : 1168868149,
         "no_index" : 1,
         "size" : 2456
      },
      "inc/Module/Install/Makefile.pm" : {
         "mtime" : 1168868148,
         "no_index" : 1,
         "size" : 5946
      },
      "inc/Module/Install/Metadata.pm" : {
         "mtime" : 1168868148,
         "no_index" : 1,
         "size" : 8100
      },
      "inc/Module/Install/Scripts.pm" : {
         "mtime" : 1168868148,
         "no_index" : 1,
         "size" : 1304
      },
      "inc/Module/Install/Share.pm" : {
         "mtime" : 1168868148,
         "no_index" : 1,
         "size" : 824
      },
      "inc/Module/Install/Win32.pm" : {
         "mtime" : 1168868149,
         "no_index" : 1,
         "size" : 1806
      },
      "inc/Module/Install/WriteAll.pm" : {
         "mtime" : 1168868148,
         "no_index" : 1,
         "size" : 916
      },
      "lib/PAR/Dist/InstallPPD/GUI.pm" : {
         "license" : "Perl_5",
         "module" : "PAR::Dist::InstallPPD::GUI",
         "mtime" : 1168867964,
         "required" : [
            "File::Path"
         ],
         "size" : 4342,
         "used" : [
            "Config::IniFiles",
            "File::Spec",
            "File::UserConfig",
            "IPC::Run",
            "PAR::Dist::FromPPD",
            "PAR::Dist::InstallPPD::GUI::Config",
            "PAR::Dist::InstallPPD::GUI::Install",
            "PAR::Dist::InstallPPD::GUI::Installed",
            "Tk",
            "Tk::NoteBook",
            "Tk::ROText",
            "strict",
            "warnings"
         ]
      },
      "lib/PAR/Dist/InstallPPD/GUI/Config.pm" : {
         "license" : "Perl_5",
         "module" : "PAR::Dist::InstallPPD::GUI::Config",
         "mtime" : 1168867985,
         "size" : 2373,
         "used" : [
            "strict",
            "warnings"
         ]
      },
      "lib/PAR/Dist/InstallPPD/GUI/Install.pm" : {
         "license" : "Perl_5",
         "module" : "PAR::Dist::InstallPPD::GUI::Install",
         "mtime" : 1168868013,
         "size" : 4923,
         "used" : [
            "strict",
            "warnings"
         ]
      },
      "lib/PAR/Dist/InstallPPD/GUI/Installed.pm" : {
         "license" : "Perl_5",
         "module" : "PAR::Dist::InstallPPD::GUI::Installed",
         "mtime" : 1168868022,
         "size" : 7118,
         "used" : [
            "ExtUtils::Installed",
            "IO::Dir",
            "Tk::Dialog",
            "Tk::HList",
            "strict",
            "warnings"
         ]
      },
      "t/00pod.t" : {
         "mtime" : 1166713946,
         "no_index" : 1,
         "size" : 130,
         "used" : [
            "Test::More"
         ],
         "used_in_eval" : [
            "Test::Pod"
         ]
      },
      "t/01basic.t" : {
         "mtime" : 1166714037,
         "no_index" : 1,
         "size" : 179,
         "used" : [
            "Test::More"
         ]
      }
   },
   "got_prereq_from" : "META.yml",
   "kwalitee" : {
      "buildtool_not_executable" : 1,
      "consistent_version" : 1,
      "easily_repackageable_by_debian" : 1,
      "easily_repackageable_by_fedora" : 1,
      "extractable" : 1,
      "extracts_nicely" : 1,
      "fits_fedora_license" : 1,
      "has_abstract_in_pod" : 1,
      "has_buildtool" : 1,
      "has_changelog" : 1,
      "has_human_readable_license" : 1,
      "has_known_license_in_source_file" : 1,
      "has_license_in_source_file" : 1,
      "has_manifest" : 1,
      "has_meta_yml" : 1,
      "has_proper_version" : 1,
      "has_readme" : 1,
      "has_separate_license_file" : 0,
      "has_tests" : 1,
      "has_tests_in_t_dir" : 1,
      "has_version" : 1,
      "kwalitee" : "97.56",
      "manifest_matches_dist" : 1,
      "metayml_conforms_to_known_spec" : 0,
      "metayml_declares_perl_version" : 1,
      "metayml_has_license" : 1,
      "metayml_has_provides" : 0,
      "metayml_is_parsable" : 1,
      "no_abstract_stub_in_pod" : 1,
      "no_broken_auto_install" : 1,
      "no_broken_module_install" : 1,
      "no_dot_dirs" : 1,
      "no_dot_underscore_files" : 1,
      "no_generated_files" : 1,
      "no_invalid_versions" : 1,
      "no_local_dirs" : 1,
      "no_mymeta_files" : 1,
      "no_pax_headers" : 1,
      "no_pod_errors" : 1,
      "no_stdin_for_prompting" : 1,
      "no_symlinks" : 1,
      "package_version_matches_dist_version" : 1,
      "portable_filenames" : 1,
      "proper_libs" : 1,
      "use_strict" : 1,
      "use_warnings" : 1,
      "valid_signature" : 1
   },
   "latest_mtime" : 1168868173,
   "license" : "perl defined in META.yml",
   "license_file" : "lib/PAR/Dist/InstallPPD/GUI.pm,lib/PAR/Dist/InstallPPD/GUI/Config.pm,lib/PAR/Dist/InstallPPD/GUI/Install.pm,lib/PAR/Dist/InstallPPD/GUI/Installed.pm",
   "license_from_yaml" : "perl",
   "license_in_pod" : 1,
   "license_type" : "Perl_5",
   "licenses" : {
      "Perl_5" : [
         "lib/PAR/Dist/InstallPPD/GUI.pm",
         "lib/PAR/Dist/InstallPPD/GUI/Config.pm",
         "lib/PAR/Dist/InstallPPD/GUI/Install.pm",
         "lib/PAR/Dist/InstallPPD/GUI/Installed.pm"
      ]
   },
   "manifest_matches_dist" : 1,
   "meta_yml" : {
      "abstract" : "GUI frontend for PAR::Dist::InstallPPD",
      "author" : "Steffen Mueller (smueller@cpan.org)",
      "build_requires" : {
         "ExtUtils::MakeMaker" : "6.11"
      },
      "distribution_type" : "module",
      "generated_by" : "Module::Install version 0.64",
      "license" : "perl",
      "meta-spec" : {
         "url" : "http://module-build.sourceforge.net/META-spec-v1.3.html",
         "version" : "1.3"
      },
      "name" : "PAR-Dist-InstallPPD-GUI",
      "no_index" : {
         "directory" : [
            "inc",
            "t"
         ]
      },
      "requires" : {
         "Config::IniFiles" : "0",
         "ExtUtils::Install" : "0",
         "File::UserConfig" : "0",
         "IO::Dir" : "0",
         "IPC::Run" : "0.80",
         "PAR::Dist::FromPPD" : "0.02",
         "PAR::Dist::InstallPPD" : "0.01",
         "Tk" : "0",
         "Tk::Dialog" : "0",
         "Tk::ROText" : "0",
         "perl" : "5.6.0"
      },
      "version" : "0.05"
   },
   "metayml_is_parsable" : 1,
   "module_install" : {
      "version" : "0.64"
   },
   "modules" : [
      {
         "file" : "lib/PAR/Dist/InstallPPD/GUI.pm",
         "in_basedir" : 0,
         "in_lib" : 1,
         "module" : "PAR::Dist::InstallPPD::GUI"
      },
      {
         "file" : "lib/PAR/Dist/InstallPPD/GUI/Config.pm",
         "in_basedir" : 0,
         "in_lib" : 1,
         "module" : "PAR::Dist::InstallPPD::GUI::Config"
      },
      {
         "file" : "lib/PAR/Dist/InstallPPD/GUI/Installed.pm",
         "in_basedir" : 0,
         "in_lib" : 1,
         "module" : "PAR::Dist::InstallPPD::GUI::Installed"
      },
      {
         "file" : "lib/PAR/Dist/InstallPPD/GUI/Install.pm",
         "in_basedir" : 0,
         "in_lib" : 1,
         "module" : "PAR::Dist::InstallPPD::GUI::Install"
      }
   ],
   "no_index" : "^inc/;^t/",
   "no_pax_headers" : 1,
   "package" : "PAR-Dist-InstallPPD-GUI-0.05.tar.gz",
   "prereq" : [
      {
         "is_prereq" : 1,
         "requires" : "IO::Dir",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "Tk",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "PAR::Dist::InstallPPD",
         "type" : "runtime_requires",
         "version" : "0.01"
      },
      {
         "is_prereq" : 1,
         "requires" : "IPC::Run",
         "type" : "runtime_requires",
         "version" : "0.80"
      },
      {
         "is_prereq" : 1,
         "requires" : "perl",
         "type" : "runtime_requires",
         "version" : "5.6.0"
      },
      {
         "is_prereq" : 1,
         "requires" : "Tk::ROText",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "ExtUtils::Install",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "Tk::Dialog",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_build_prereq" : 1,
         "requires" : "ExtUtils::MakeMaker",
         "type" : "build_requires",
         "version" : "6.11"
      },
      {
         "is_prereq" : 1,
         "requires" : "Config::IniFiles",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "File::UserConfig",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "PAR::Dist::FromPPD",
         "type" : "runtime_requires",
         "version" : "0.02"
      }
   ],
   "released_epoch" : 1168868400,
   "size_packed" : 16966,
   "size_unpacked" : 57074,
   "uses" : {
      "required_in_code" : {
         "File::Path" : 1
      },
      "used_in_code" : {
         "Config::IniFiles" : 1,
         "ExtUtils::Installed" : 1,
         "File::Spec" : 1,
         "File::UserConfig" : 1,
         "IO::Dir" : 1,
         "IPC::Run" : 1,
         "PAR::Dist::FromPPD" : 1,
         "Tk" : 1,
         "Tk::Dialog" : 1,
         "Tk::HList" : 1,
         "Tk::NoteBook" : 1,
         "Tk::ROText" : 1,
         "strict" : 4,
         "warnings" : 4
      },
      "used_in_config" : {
         "File::Spec" : 1,
         "inc::Module::Install" : 1
      },
      "used_in_eval_in_tests" : {
         "Test::Pod" : 1
      },
      "used_in_tests" : {
         "Test::More" : 2
      }
   },
   "valid_signature" : -1,
   "version" : "0.05",
   "versions" : {
      "lib/PAR/Dist/InstallPPD/GUI.pm" : {
         "PAR::Dist::InstallPPD::GUI" : "0.05"
      },
      "lib/PAR/Dist/InstallPPD/GUI/Config.pm" : {
         "PAR::Dist::InstallPPD::GUI::Config" : "0.05"
      },
      "lib/PAR/Dist/InstallPPD/GUI/Install.pm" : {
         "PAR::Dist::InstallPPD::GUI::Install" : "0.05"
      },
      "lib/PAR/Dist/InstallPPD/GUI/Installed.pm" : {
         "PAR::Dist::InstallPPD::GUI::Installed" : "0.05"
      }
   },
   "vname" : "PAR-Dist-InstallPPD-GUI-0.05"
}