Kwalitee Issues


Provide a short description in the NAME section of the pod (after the module name followed by a hyphen) at least for the main module of this distribution.


Add a section called "LICENSE" to the documentation, or add a file named LICENSE to the distribution.


Add =head1 LICENSE and the text of the license to the main module in your code.


Add a README to the distribution. It should contain a quick description of your module and how to install it.


Remove the POD errors. You can check for POD errors automatically by including Test::Pod to your test suite.

Error: PDF-ReportWriter-1.5/lib/PDF/ReportWriter/ -- Around line 201: =over should be: '=over' or '=over positive_number' PDF-ReportWriter-1.5/lib/PDF/ReportWriter/ -- Around line 464: =over should be: '=over' or '=over positive_number'Around line 486: =over should be: '=over' or '=over positive_number' PDF-ReportWriter-1.5/lib/PDF/ -- Around line 2792: You forgot a '=back' before '=head3'Around line 2830: =back without =overAround line 2838: You forgot a '=back' before '=head3'Around line 3068: You forgot a '=back' before '=head2' You forgot a '=back' before '=head2'Around line 3083: =back without =overAround line 3085: =back without =overAround line 3444: =back without =over


Split the distribution, or fix the version numbers to make them consistent (use the highest version number to avoid version downgrade).

Error: 1.0,1.00,1.5


Add =head1 LICENSE and/or the proper text of the well-known license to the main module in your code.


Add a META.json to the distribution. Your buildtool should be able to autogenerate it.


If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.


Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.


Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: PDF::ReportWriter, PDF::ReportWriter::Datasource, PDF::ReportWriter::Datasource::DBI, PDF::ReportWriter::Report


This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.


Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.


Add a 'repository' resource to the META.yml via 'meta_add' accessor (for Module::Build) or META_ADD parameter (for ExtUtils::MakeMaker).


Name Abstract Version View
PDF::ReportWriter 1.5 metacpan
PDF::ReportWriter::Datasource 1.00 metacpan
PDF::ReportWriter::Datasource::DBI 1.0 metacpan
PDF::ReportWriter::Report 1.0 metacpan

Other Files

Changes metacpan
MANIFEST metacpan
META.yml metacpan
Makefile.PL metacpan