Kwalitee Issues

no_broken_auto_install

Upgrade the bundled version of Module::Install to at least 0.89, but preferably to the most current release. Alternatively, you can switch to another build system / installer that does not suffer from this problem. (ExtUtils::MakeMaker, Module::Build both of which have their own set of problems.)

no_broken_module_install

Upgrade the bundled version of Module::Install to the most current release. Alternatively, you can switch to another build system / installer that does not suffer from this problem. (ExtUtils::MakeMaker, Module::Build both of which have their own set of problems.)

no_pod_errors

Remove the POD errors. You can check for POD errors automatically by including Test::Pod to your test suite.

Error: PHP-Strings-0.28/Strings.pm -- Around line 2929: Non-ASCII character seen before =encoding in 'façade'. Assuming UTF-8

prereq_matches_use

List all used modules in META.yml requires

Error:

  • Carp
  • Digest::MD5
  • bytes
  • constant
  • locale
  • strict
  • vars
  • warnings

valid_signature

Sign the dist as the last step before creating the archive. Take care not to modify/regenerate dist meta files or the manifest.

Error: gpgkeys: key FBA1B3B0AA655CD6 not found on keyserver gpg: Signature made Thu Jan 29 05:21:04 2004 JST using DSA key ID AA655CD6 gpg: requesting key AA655CD6 from hkp server pool.sks-keyservers.net gpg: no valid OpenPGP data found. gpg: Can't check signature: public key not found ==> BAD/TAMPERED signature detected! <==

has_meta_json

Add a META.json to the distribution. Your buildtool should be able to autogenerate it.

meta_yml_declares_perl_version

If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.

meta_yml_has_license

Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.

build_prereq_matches_use

List all modules used in the test suite in META.yml build_requires

Error:

  • POSIX
  • lib
  • strict
  • warnings

meta_yml_has_provides

Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.

meta_yml_has_repository_resource

Add a 'repository' resource to the META.yml via 'meta_add' accessor (for Module::Build) or META_ADD parameter (for ExtUtils::MakeMaker).

Modules

Name Abstract Version View
PHP::Strings Implement some of PHP's string functions. 0.28 metacpan

Other Files

Changes metacpan
MANIFEST metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan