Kwalitee Issues

buildtool_not_executable

Change the permissions of Build.PL/Makefile.PL to not-executable.

has_human_readable_license

Add a section called "LICENSE" to the documentation, or add a file named LICENSE to the distribution.

has_license_in_source_file

Add =head1 LICENSE and the text of the license to the main module in your code.

meta_yml_conforms_to_known_spec

Take a look at the META.yml Spec at http://module-build.sourceforge.net/META-spec-v1.4.html (for version 1.4) or http://search.cpan.org/perldoc?CPAN::Meta::Spec (for version 2), and change your META.yml accordingly.

Error: '<undef>' for 'IO::Scalar' is not a valid version. (requires -> IO::Scalar) [Validation: 1.0];'<undef>' for 'IO::Socket::INET' is not a valid version. (requires -> IO::Socket::INET) [Validation: 1.0];'<undef>' for 'POE' is not a valid version. (requires -> POE) [Validation: 1.0];'<undef>' for 'Socket' is not a valid version. (requires -> Socket) [Validation: 1.0]

prereq_matches_use

List all used modules in META.yml requires

Error:

  • Carp
  • Data::Dumper
  • Time::HiRes
  • strict
  • warnings

has_known_license_in_source_file

Add =head1 LICENSE and/or the proper text of the well-known license to the main module in your code.

has_meta_json

Add a META.json to the distribution. Your buildtool should be able to autogenerate it.

meta_yml_declares_perl_version

If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.

meta_yml_has_license

Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.

use_warnings

Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: POE::Component::Server::FTP::ControlFilter, POE::Component::Server::FTP::ControlSession, POE::Component::Server::FTP::DataSession

build_prereq_matches_use

List all modules used in the test suite in META.yml build_requires

Error:

  • Test::More
  • strict

has_separate_license_file

This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.

meta_yml_has_provides

Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.

meta_yml_has_repository_resource

Add a 'repository' resource to the META.yml via 'meta_add' accessor (for Module::Build) or META_ADD parameter (for ExtUtils::MakeMaker).

Modules

Name Abstract Version View
POE::Component::Server::FTP Event-based FTP server on a virtual filesystem 0.08 metacpan
POE::Component::Server::FTP::ControlFilter metacpan
POE::Component::Server::FTP::ControlSession metacpan
POE::Component::Server::FTP::DataSession metacpan

Other Files

Changes metacpan
MANIFEST metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan
README_TOO metacpan