Pod-Wrap

Metadata

Analyzed metadata and errors of Pod-Wrap.

{
   "abstracts_in_pod" : {
      "Pod::Wrap" : "Wrap pod paragraphs, leaving verbatim text and code alone."
   },
   "author" : "NUFFIN",
   "buildfile_executable" : 0,
   "dir_lib" : "lib",
   "dir_t" : "t",
   "dirs_array" : [
      "lib",
      "lib/Pod",
      "t",
      "scripts"
   ],
   "dist" : "Pod-Wrap",
   "dynamic_config" : 0,
   "error" : {
      "valid_signature" : "WARNING: This key is not certified with a trusted signature!\nPrimary key fingerprint: C56E 126B C277 6DB7 237C  4A7C 542C 11C0 EBD2 7418\n"
   },
   "extension" : "tar.gz",
   "external_license_file" : "COPYING",
   "extractable" : 1,
   "extracts_nicely" : 1,
   "file__build" : 0,
   "file_blib" : 0,
   "file_build" : 0,
   "file_build_pl" : "Build.PL",
   "file_makefile" : 0,
   "file_makefile_pl" : "Makefile.PL",
   "file_manifest" : "MANIFEST",
   "file_meta_yml" : "META.yml",
   "file_pm_to_blib" : 0,
   "file_readme" : "README",
   "file_signature" : "SIGNATURE",
   "files_array" : [
      "README",
      "Build.PL",
      "Artistic",
      "Makefile.PL",
      "META.yml",
      "SIGNATURE",
      "MANIFEST",
      "COPYING",
      "lib/Pod/Wrap.pm",
      "t/deparse_cmp.t",
      "scripts/podwrap"
   ],
   "files_hash" : {
      "Artistic" : {
         "mtime" : 1073565659,
         "size" : 6201
      },
      "Build.PL" : {
         "mtime" : 1073565659,
         "size" : 465,
         "used" : [
            "Module::Build",
            "strict",
            "warnings"
         ]
      },
      "COPYING" : {
         "mtime" : 1073565659,
         "size" : 12560
      },
      "MANIFEST" : {
         "mtime" : 1073565662,
         "size" : 153
      },
      "META.yml" : {
         "mtime" : 1073565662,
         "size" : 301
      },
      "Makefile.PL" : {
         "mtime" : 1073565662,
         "size" : 287,
         "used" : [
            "ExtUtils::MakeMaker"
         ]
      },
      "README" : {
         "mtime" : 1073565659,
         "size" : 259
      },
      "SIGNATURE" : {
         "mtime" : 1073565665,
         "size" : 1292
      },
      "lib/Pod/Wrap.pm" : {
         "license" : "Perl_5",
         "module" : "Pod::Wrap",
         "mtime" : 1073565660,
         "size" : 4436,
         "used" : [
            "Pod::Parser",
            "Text::Wrap",
            "strict",
            "warnings"
         ]
      },
      "scripts/podwrap" : {
         "mtime" : 1073565660,
         "size" : 1445
      },
      "t/deparse_cmp.t" : {
         "mtime" : 1073565659,
         "required_in_eval" : [
            "CGI",
            "CPAN",
            "CPANPLUS",
            "Class::DBI",
            "Crypt::OpenPGP",
            "File::Temp",
            "IO::Handle",
            "IPC::Open3",
            "LWP::Simple",
            "Mail::Box",
            "Mail::Box::Manager",
            "Mail::SpamAssassin",
            "Memoize",
            "Net::LDAP",
            "Net::SSH::Perl",
            "Petal",
            "Pod::Stripper",
            "Scalar::Util",
            "Test",
            "Test::Simple",
            "Text::Diff",
            "WWW::Mechanize::Shell",
            "diagnostics"
         ],
         "size" : 4575,
         "used" : [
            "B::Deparse",
            "Fcntl",
            "IO::Select",
            "Pod::Wrap",
            "Test::More",
            "strict",
            "warnings"
         ]
      }
   },
   "got_prereq_from" : "META.yml",
   "kwalitee" : {
      "buildtool_not_executable" : 1,
      "consistent_version" : 1,
      "distname_matches_name_in_meta" : 1,
      "extractable" : 1,
      "extracts_nicely" : 1,
      "has_abstract_in_pod" : 1,
      "has_buildtool" : 1,
      "has_changelog" : 0,
      "has_human_readable_license" : 1,
      "has_known_license_in_source_file" : 1,
      "has_license_in_source_file" : 1,
      "has_manifest" : 1,
      "has_meta_yml" : 1,
      "has_proper_version" : 1,
      "has_readme" : 1,
      "has_separate_license_file" : 1,
      "has_tests" : 1,
      "has_tests_in_t_dir" : 1,
      "has_version" : 1,
      "kwalitee" : "97.73",
      "manifest_matches_dist" : 1,
      "meta_json_conforms_to_known_spec" : 1,
      "meta_json_is_parsable" : 1,
      "meta_yml_conforms_to_known_spec" : 1,
      "meta_yml_declares_perl_version" : 1,
      "meta_yml_has_license" : 1,
      "meta_yml_has_provides" : 1,
      "meta_yml_has_repository_resource" : 0,
      "meta_yml_is_parsable" : 1,
      "no_abstract_stub_in_pod" : 1,
      "no_broken_auto_install" : 1,
      "no_broken_module_install" : 1,
      "no_dot_dirs" : 1,
      "no_dot_underscore_files" : 1,
      "no_generated_files" : 1,
      "no_invalid_versions" : 1,
      "no_local_dirs" : 1,
      "no_mymeta_files" : 1,
      "no_pax_headers" : 1,
      "no_pod_errors" : 1,
      "no_stdin_for_prompting" : 1,
      "no_symlinks" : 1,
      "package_version_matches_dist_version" : 1,
      "portable_filenames" : 1,
      "proper_libs" : 1,
      "use_strict" : 1,
      "use_warnings" : 1,
      "valid_signature" : 1
   },
   "latest_mtime" : 1073565665,
   "license" : "perl defined in META.yml defined in COPYING",
   "license_file" : "lib/Pod/Wrap.pm",
   "license_from_yaml" : "perl",
   "license_in_pod" : 1,
   "license_type" : "Perl_5",
   "licenses" : {
      "Perl_5" : [
         "lib/Pod/Wrap.pm"
      ]
   },
   "manifest_matches_dist" : 1,
   "meta_yml" : {
      "build_requires" : {},
      "conflicts" : {},
      "distribution_type" : "module",
      "generated_by" : "Module::Build version 0.21",
      "license" : "perl",
      "meta-spec" : {},
      "name" : "Pod-Wrap",
      "provides" : {
         "Pod::Wrap" : {
            "file" : "lib/Pod/Wrap.pm",
            "version" : "0.01"
         }
      },
      "recommends" : {},
      "requires" : {
         "Pod::Parser" : "0",
         "Text::Wrap" : "0",
         "perl" : ">= 5.6.0"
      },
      "version" : "0.01"
   },
   "meta_yml_is_parsable" : 1,
   "meta_yml_spec_version" : "1.0",
   "modules" : [
      {
         "file" : "lib/Pod/Wrap.pm",
         "in_basedir" : 0,
         "in_lib" : 1,
         "module" : "Pod::Wrap"
      }
   ],
   "no_pax_headers" : 1,
   "package" : "Pod-Wrap-0.01.tar.gz",
   "prereq" : [
      {
         "is_prereq" : 1,
         "requires" : "Text::Wrap",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "Pod::Parser",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "perl",
         "type" : "runtime_requires",
         "version" : ">= 5.6.0"
      }
   ],
   "released_epoch" : 1073566319,
   "size_packed" : 12556,
   "size_unpacked" : 31974,
   "uses" : {
      "required_in_eval_in_tests" : {
         "CGI" : 1,
         "CPAN" : 1,
         "CPANPLUS" : 1,
         "Class::DBI" : 1,
         "Crypt::OpenPGP" : 1,
         "File::Temp" : 1,
         "IO::Handle" : 1,
         "IPC::Open3" : 1,
         "LWP::Simple" : 1,
         "Mail::Box" : 1,
         "Mail::Box::Manager" : 1,
         "Mail::SpamAssassin" : 1,
         "Memoize" : 1,
         "Net::LDAP" : 1,
         "Net::SSH::Perl" : 1,
         "Petal" : 1,
         "Pod::Stripper" : 1,
         "Scalar::Util" : 1,
         "Test" : 1,
         "Test::Simple" : 1,
         "Text::Diff" : 1,
         "WWW::Mechanize::Shell" : 1,
         "diagnostics" : 1
      },
      "used_in_code" : {
         "Pod::Parser" : 1,
         "Text::Wrap" : 1,
         "strict" : 1,
         "warnings" : 1
      },
      "used_in_config" : {
         "ExtUtils::MakeMaker" : 1,
         "Module::Build" : 1,
         "strict" : 1,
         "warnings" : 1
      },
      "used_in_tests" : {
         "B::Deparse" : 1,
         "Fcntl" : 1,
         "IO::Select" : 1,
         "Test::More" : 1,
         "strict" : 1,
         "warnings" : 1
      }
   },
   "valid_signature" : 0,
   "version" : "0.01",
   "versions" : {
      "lib/Pod/Wrap.pm" : {
         "Pod::Wrap" : "0.01"
      }
   },
   "vname" : "Pod-Wrap-0.01"
}