Kwalitee Issues

manifest_matches_dist

Run a proper command ("make manifest" or "./Build manifest", maybe with a force option), or use a distribution builder to generate the MANIFEST. Or update MANIFEST manually.

Error:

  • MANIFEST (36) does not match dist (37):
  • Missing in MANIFEST: META.json

no_pod_errors

Remove the POD errors. You can check for POD errors automatically by including Test::Pod to your test suite.

Error: PostScript-Font-1.10.03/lib/PostScript/Font/TTtoType42.pm -- Around line 670: You forgot a '=back' before '=head1' PostScript-Font-1.10.03/lib/PostScript/Font.pm -- Around line 718: You forgot a '=back' before '=head1' PostScript-Font-1.10.03/lib/PostScript/ISOLatin1Encoding.pm -- Around line 99: You forgot a '=back' before '=head1' PostScript-Font-1.10.03/lib/PostScript/ISOLatin9Encoding.pm -- Around line 117: You forgot a '=back' before '=head1' PostScript-Font-1.10.03/lib/PostScript/StandardEncoding.pm -- Around line 97: You forgot a '=back' before '=head1' PostScript-Font-1.10.03/lib/PostScript/WinANSIEncoding.pm -- Around line 105: You forgot a '=back' before '=head1'

package_version_matches_dist_version

Fix the version(s).

consistent_version

Split the distribution, or fix the version numbers to make them consistent (use the highest version number to avoid version downgrade).

Error: 0.04,0.08,1.00,1.01,1.03,1.05,1.06

meta_yml_declares_perl_version

If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.

meta_yml_has_license

Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.

use_warnings

Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: PostScript::BasicTypesetter, PostScript::Font, PostScript::FontInfo, PostScript::FontMetrics, PostScript::ISOLatin1Encoding, PostScript::ISOLatin9Encoding, PostScript::PrinterFontMetrics, PostScript::PseudoISO, PostScript::Resources, PostScript::StandardEncoding, PostScript::WinANSIEncoding

has_separate_license_file

This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.

meta_yml_has_provides

Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.

meta_yml_has_repository_resource

Add a 'repository' resource to the META.yml via 'meta_add' accessor (for Module::Build) or META_ADD parameter (for ExtUtils::MakeMaker).

Modules

Name Abstract Version View
PostScript::BasicTypesetter Module for basic typesetting 0.04 metacpan
PostScript::Font module to fetch data from PostScript fonts 1.05 metacpan
PostScript::Font::TTtoType42 Wrap a TrueType font into PostScript Type42 0.04 metacpan
PostScript::FontInfo module to fetch data from PostScript font C<.inf> files 1.05 metacpan
PostScript::FontMetrics module to fetch data from Adobe Font Metrics file 1.06 metacpan
PostScript::ISOLatin1Encoding ISOLatin1Encoding for PostScript fonts 1.01 metacpan
PostScript::ISOLatin9Encoding ISOLatin9Encoding for PostScript fonts 1.01 metacpan
PostScript::PrinterFontMetrics module to fetch data from Printer Font Metrics files 0.08 metacpan
PostScript::PseudoISO Module with handy ISO enhancements 1.00 metacpan
PostScript::Resources module to fetch data from Unix PostScript Resource 'C<.upr>' files 1.03 metacpan
PostScript::StandardEncoding Adobe StandardEncoding for PostScript fonts 1.01 metacpan
PostScript::WinANSIEncoding WinANSIEncoding for PostScript fonts 1.01 metacpan

Other Files

MANIFEST metacpan
META.json metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan