Kwalitee Issues

has_license_in_source_file

Add =head1 LICENSE and the text of the license to the main module in your code.

has_manifest

Add a MANIFEST to the distribution. Your buildtool should be able to autogenerate it (eg "make manifest" or "./Build manifest")

has_meta_yml

Add a META.yml to the distribution. Your buildtool should be able to autogenerate it.

manifest_matches_dist

Run a proper command ("make manifest" or "./Build manifest", maybe with a force option), or use a distribution builder to generate the MANIFEST. Or update MANIFEST manually.

Error: Cannot find MANIFEST in dist.

no_pod_errors

Remove the POD errors. You can check for POD errors automatically by including Test::Pod to your test suite.

Error: RDFStore-0.51/lib/DBMS.pm-- Around line 17: Unknown directive: =NAME RDFStore-0.51/lib/RDFStore/Literal.pm -- Around line 121: You forgot a '=back' before '=head1' RDFStore-0.51/lib/RDFStore/Model.pm -- Around line 1468: '=item' outside of any '=over'Around line 1488: You forgot a '=back' before '=head1' You forgot a '=back' before '=head1' RDFStore-0.51/lib/RDFStore/NodeFactory.pm -- Around line 296: You forgot a '=back' before '=head1' RDFStore-0.51/lib/RDFStore/Parser/Styles/RDFStore/Model.pm -- Around line 327: You forgot a '=back' before '=head1' You forgot a '=back' before '=head1' RDFStore-0.51/lib/RDFStore/Parser/Styles/RDFStore/Statement.pm -- Around line 187: You forgot a '=back' before '=head1' RDFStore-0.51/lib/RDFStore/RDFNode.pm -- Around line 118: You forgot a '=back' before '=head1' RDFStore-0.51/lib/RDFStore/Resource.pm -- Around line 183: You forgot a '=back' before '=head1' RDFStore-0.51/lib/RDFStore/Serializer/NTriples.pm -- Around line 87: '=item' outside of any '=over'Around line 91: You forgot a '=back' before '=head1'Around line 93: '=item' outside of any '=over'Around line 101: You forgot a '=back' before '=head1' RDFStore-0.51/lib/RDFStore/Serializer/RDFXML.pm -- Around line 243: '=item' outside of any '=over'Around line 247: You forgot a '=back' before '=head1'Around line 249: '=item' outside of any '=over'Around line 257: You forgot a '=back' before '=head1' RDFStore-0.51/lib/RDFStore/Serializer/RSS.pm -- Around line 248: '=item' outside of any '=over'Around line 252: You forgot a '=back' before '=head1'Around line 254: '=item' outside of any '=over'Around line 262: You forgot a '=back' before '=head1' RDFStore-0.51/lib/RDFStore/Serializer.pm -- Around line 187: '=item' outside of any '=over'Around line 191: You forgot a '=back' before '=head1'Around line 193: '=item' outside of any '=over'Around line 201: You forgot a '=back' before '=head1' RDFStore-0.51/lib/RDFStore/Statement.pm -- Around line 162: You forgot a '=back' before '=head1' RDFStore-0.51/lib/RDFStore/Util/Digest.pm -- Around line 59: You forgot a '=back' before '=head1' RDFStore-0.51/lib/RDFStore/Util/UTF8.pm -- Around line 82: You forgot a '=back' before '=head1' RDFStore-0.51/lib/RDQL/Parser.pm -- Around line 1141: '=item' outside of any '=over'Around line 1143: You forgot a '=back' before '=head1'Around line 1145: '=item' outside of any '=over'Around line 1202: You forgot a '=back' before '=head1'Around line 1222: '=item' outside of any '=over'Around line 1238: Expected text after =item, not a bulletAround line 1240: Expected text after =item, not a bulletAround line 1242: You forgot a '=back' before '=head1' RDFStore-0.51/lib/Util/BLOB.pm -- Around line 115: You forgot a '=back' before '=head1'

prereq_matches_use

List all used modules in META.yml requires

Error:

  • DBI
  • URI
  • URI::Escape

consistent_version

Split the distribution, or fix the version numbers to make them consistent (use the highest version number to avoid version downgrade).

Error: 0.1,0.2,0.4,0.41,0.42,0.44,0.51,1.7

has_known_license_in_source_file

Add =head1 LICENSE and/or the proper text of the well-known license to the main module in your code.

has_meta_json

Add a META.json to the distribution. Your buildtool should be able to autogenerate it.

meta_yml_has_license

Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.

use_warnings

Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: DBD::RDFStore, DBMS, RDFStore, RDFStore::Digest::Digestable, RDFStore::Literal, RDFStore::Model, RDFStore::NodeFactory, RDFStore::Object, RDFStore::Parser, RDFStore::Parser::NTriples, RDFStore::Parser::SiRPAC, RDFStore::Parser::Styles::RDFStore::Model, RDFStore::Parser::Styles::RDFStore::Statement, RDFStore::RDFNode, RDFStore::Resource, RDFStore::SchemaModel, RDFStore::Serializer, RDFStore::Serializer::NTriples, RDFStore::Serializer::RDFXML, RDFStore::Serializer::RSS, RDFStore::Statement, RDFStore::Util::Digest, RDFStore::Util::UTF8, RDFStore::VirtualModel, RDFStore::Vocabulary::DAML, RDFStore::Vocabulary::DC, RDFStore::Vocabulary::DCQ, RDFStore::Vocabulary::DCT, RDFStore::Vocabulary::FOAF, RDFStore::Vocabulary::Generator, RDFStore::Vocabulary::OWL, RDFStore::Vocabulary::RDF, RDFStore::Vocabulary::RDFS, RDFStore::Vocabulary::RDFStoreContext, RDFStore::Vocabulary::RSS, RDQL::Parser, Util::BLOB

build_prereq_matches_use

List all modules used in the test suite in META.yml build_requires

Error:

  • DBI
  • URI

Modules

Name Abstract Version View
DBD::RDFStore Simple DBI driver for RDFStore using RDQL:Parser 0.2 metacpan
DBMS Perl5 access to a dbms server. 1.7 metacpan
RDFStore Perl extesion to store and query RDF graphs 0.51 metacpan
RDFStore::Digest::Digestable implementation of the Digestable RDF API 0.1 metacpan
RDFStore::Literal An RDF Literal Node implementation 0.42 metacpan
RDFStore::Model An implementation of the Model RDF API using tied hashes and implementing free-text search on literals 0.44 metacpan
RDFStore::NodeFactory An RDF node factory implementation 0.42 metacpan
RDFStore::Object A very useful abstration over an RDFStore::Model 0.1 metacpan
RDFStore::Parser Interface to an RDF parser 0.2 metacpan
RDFStore::Parser::NTriples This module implements a streaming N-Triples parser 0.1 metacpan
RDFStore::Parser::SiRPAC This module implements a streaming RDF Parser as a direct implementation of XML::Parser::Expat(3) 0.44 metacpan
RDFStore::Parser::Styles::RDFStore::Model This module is a RDFStore::Parser::SiRPAC(3) filter to ingest records into an RDFStore::Model(3). 0.41 metacpan
RDFStore::Parser::Styles::RDFStore::Statement This module is a RDFStore::Parser::SiRPAC(3) filter to generate RDFStore::Statements 0.1 metacpan
RDFStore::RDFNode An RDF graph node 0.41 metacpan
RDFStore::Resource An RDF Resource Node implementation 0.41 metacpan
RDFStore::SchemaModel implementation of the SchemaModel RDF API 0.4 metacpan
RDFStore::Serializer Interface to an RDF model/graph serializer 0.1 metacpan
RDFStore::Serializer::NTriples 0.1 metacpan
RDFStore::Serializer::RDFXML 0.2 metacpan
RDFStore::Serializer::RSS 0.2 metacpan
RDFStore::Statement An RDF Statement implementation 0.42 metacpan
RDFStore::Util::Digest Utility library to manage SHA-1 cryptographic digests 0.1 metacpan
RDFStore::Util::UTF8 Utility library to manage UTF8 strings 0.1 metacpan
RDFStore::VirtualModel implementation of the VirtualModel RDF API 0.4 metacpan
RDFStore::Vocabulary::DAML 0.41 metacpan
RDFStore::Vocabulary::DC 0.41 metacpan
RDFStore::Vocabulary::DCQ 0.41 metacpan
RDFStore::Vocabulary::DCT 0.41 metacpan
RDFStore::Vocabulary::FOAF 0.41 metacpan
RDFStore::Vocabulary::Generator implementation of the Vocabulary Generator RDF API 0.41 metacpan
RDFStore::Vocabulary::OWL 0.41 metacpan
RDFStore::Vocabulary::RDF 0.41 metacpan
RDFStore::Vocabulary::RDFS 0.41 metacpan
RDFStore::Vocabulary::RDFStoreContext 0.41 metacpan
RDFStore::Vocabulary::RSS 0.41 metacpan
RDQL::Parser A simple top-down LL(1) RDQL and SPARQL parser 0.2 metacpan
Util::BLOB Simple interface to de/serialise perl references with Storable 0.1 metacpan

Provides

Name File View
DBD::RDFStore::db lib/DBD/RDFStore.pm metacpan
DBD::RDFStore::db::constraints lib/DBD/RDFStore.pm metacpan
DBD::RDFStore::dr lib/DBD/RDFStore.pm metacpan
DBD::RDFStore::st lib/DBD/RDFStore.pm metacpan
RDFStore::Model::Iterator lib/RDFStore/Model.pm metacpan
RDFStore::Parser::SiRPAC::DataElement lib/RDFStore/Parser/SiRPAC.pm metacpan
RDFStore::Parser::SiRPAC::Element lib/RDFStore/Parser/SiRPAC.pm metacpan
RDFStore::SchemaModel::Iterator lib/RDFStore/SchemaModel.pm metacpan

Other Files

Makefile.PL metacpan
README metacpan
dbms/client/Makefile.PL metacpan