Kwalitee Issues

has_changelog

Add a Changelog (best named 'Changes') to the distribution. It should list at least major changes implemented in newer versions.

meta_yml_conforms_to_known_spec

Take a look at the META.yml Spec at http://module-build.sourceforge.net/META-spec-v1.4.html (for version 1.4) or http://search.cpan.org/perldoc?CPAN::Meta::Spec (for version 2), and change your META.yml accordingly.

Error: '<undef>' for 'IO::Socket::INET' is not a valid version. (requires -> IO::Socket::INET) [Validation: 1.4];'<undef>' for 'Moose' is not a valid version. (requires -> Moose) [Validation: 1.4];'<undef>' for 'Net::RTP::Packet' is not a valid version. (requires -> Net::RTP::Packet) [Validation: 1.4];'<undef>' for 'Net::Server::PreFork' is not a valid version. (requires -> Net::Server::PreFork) [Validation: 1.4]

no_pod_errors

Remove the POD errors. You can check for POD errors automatically by including Test::Pod to your test suite.

Error: RTSP-Proxy-0.07/lib/RTSP/Proxy.pm -- Around line 436: You forgot a '=back' before '=head1'

prereq_matches_use

List all used modules in META.yml requires

Error:

  • Carp

consistent_version

Split the distribution, or fix the version numbers to make them consistent (use the highest version number to avoid version downgrade).

Error: 0.02,0.07

has_meta_json

Add a META.json to the distribution. Your buildtool should be able to autogenerate it.

meta_yml_declares_perl_version

If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.

meta_yml_has_license

Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.

build_prereq_matches_use

List all modules used in the test suite in META.yml build_requires

Error:

  • Test::More

has_separate_license_file

This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.

meta_yml_has_provides

Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.

Modules

Name Abstract Version View
RTSP::Proxy Simple RTSP proxy server 0.07 metacpan
RTSP::Proxy::Session 0.02 metacpan
RTSP::Proxy::StreamBuffer metacpan
RTSP::Proxy::Transport metacpan
RTSP::Proxy::Transport::RTP metacpan

Other Files

MANIFEST metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan