Kwalitee Issues

meta_yml_is_parsable

Upgrade your YAML generator so it produces valid YAML.

Error: CPAN::Meta::YAML does not support a feature in line '''

no_pod_errors

Remove the POD errors. You can check for POD errors automatically by including Test::Pod to your test suite.

Error: Ruby-0.07/exp/tie.pl -- Around line 3: Non-ASCII character seen before =encoding in 'tieインターフェイスはうまく動かせない。'. Assuming UTF-8

prereq_matches_use

List all used modules in META.yml requires

Error:

  • autobox

has_meta_json

Add a META.json to the distribution. Your buildtool should be able to autogenerate it.

meta_yml_has_license

Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.

has_separate_license_file

This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.

Modules

Name Abstract Version View
Ruby Perl interface to Ruby interpreter 0.07 metacpan
Ruby::Inspect metacpan
Ruby::Run Run Ruby script metacpan
Ruby::autobox metacpan
Ruby::literal metacpan

Provides

Name File View
Ruby::Object lib/Ruby.pm metacpan

Other Files

Changes metacpan
MANIFEST metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan