Kwalitee Issues

prereq_matches_use

List all used modules in META.yml requires

Error:

  • YAML

has_meta_json

Add a META.json to the distribution. Your buildtool should be able to autogenerate it.

meta_yml_declares_perl_version

If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.

build_prereq_matches_use

List all modules used in the test suite in META.yml build_requires

Error:

  • File::Temp
  • strict
  • warnings

has_separate_license_file

This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.

meta_yml_has_repository_resource

Add a 'repository' resource to the META.yml via 'meta_add' accessor (for Module::Build) or META_ADD parameter (for ExtUtils::MakeMaker).

Modules

Name Abstract Version View
SIAM Service Inventory Abstraction Model 1.01 metacpan
SIAM::AccessScope access scope object class metacpan
SIAM::Attribute Attribute object class metacpan
SIAM::Contract Contract object class metacpan
SIAM::Device device object class metacpan
SIAM::DeviceComponent Device Component object class metacpan
SIAM::Driver::Simple a reference implementation of SIAM Driver metacpan
SIAM::Object the base class for all SIAM object (including the root). metacpan
SIAM::Privilege Privilege object class metacpan
SIAM::Report Report object class metacpan
SIAM::ScopeMember Scope Member object class metacpan
SIAM::Service Service object class metacpan
SIAM::ServiceComponent Service Component object class metacpan
SIAM::ServiceUnit Service Unit object class metacpan
SIAM::User User object class metacpan

Other Files

Build.PL metacpan
Changes metacpan
MANIFEST metacpan
META.yml metacpan
README metacpan