Kwalitee Issues

prereq_matches_use

List all used modules in META.yml requires

Error:

  • Carp
  • Exporter
  • Scalar::Util
  • constant
  • strict
  • warnings

meta_yml_declares_perl_version

If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.

build_prereq_matches_use

List all modules used in the test suite in META.yml build_requires

Error:

  • File::Find
  • File::Temp
  • Test::More
  • strict
  • warnings

meta_yml_has_provides

Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.

Modules

Name Abstract Version View
Syntax::Feature::EachOnArray Emulate each(@array) on Perl < 5.12 0.04 metacpan
Syntax::Feature::KeysOnArray Emulate keys(@array) on Perl < 5.12 0.04 metacpan
Syntax::Feature::ValuesOnArray Emulate values(@array) on Perl < 5.12 0.04 metacpan

Provides

Name File View
Tie::ArrayAsHash lib/Syntax/Feature/EachOnArray.pm metacpan

Other Files

Build.PL metacpan
Changes metacpan
MANIFEST metacpan
META.json metacpan
META.yml metacpan
README metacpan
dist.ini metacpan