Kwalitee Issues

prereq_matches_use

List all used modules in META.yml requires

Error:

  • Win32

meta_yml_declares_perl_version

If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.

build_prereq_matches_use

List all modules used in the test suite in META.yml build_requires

Error:

  • Data::Dumper
  • constant
  • strict
  • warnings

Modules

Name Abstract Version View
Sys::Info::Driver::Windows Windows driver for Sys::Info 0.78 metacpan
Sys::Info::Driver::Windows::Constants Constants 0.78 metacpan
Sys::Info::Driver::Windows::Device Base class for Windows device drivers 0.78 metacpan
Sys::Info::Driver::Windows::Device::CPU Windows CPU Device Driver 0.78 metacpan
Sys::Info::Driver::Windows::Device::CPU::WMI Fetch CPU metadata through WMI 0.78 metacpan
Sys::Info::Driver::Windows::Device::CPU::WMI::Conf Distro configuration 0.78 metacpan
Sys::Info::Driver::Windows::OS Windows backend for Sys::Info::OS 0.78 metacpan
Sys::Info::Driver::Windows::OS::Editions Interface to identify Windows editions 0.78 metacpan
Sys::Info::Driver::Windows::OS::Net A minimal interface to Win32API::Net 0.78 metacpan

Other Files

Build.PL metacpan
Changes metacpan
MANIFEST metacpan
META.json metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan