Kwalitee Issues

meta_yml_conforms_to_known_spec

Take a look at the META.yml Spec at http://module-build.sourceforge.net/META-spec-v1.4.html (for version 1.4) or http://search.cpan.org/perldoc?CPAN::Meta::Spec (for version 2), and change your META.yml accordingly.

Error: '<undef>' for 'DBI' is not a valid version. (requires -> DBI) [Validation: 1.4];'<undef>' for 'Expect' is not a valid version. (requires -> Expect) [Validation: 1.4];'<undef>' for 'IO::File' is not a valid version. (requires -> IO::File) [Validation: 1.4];'<undef>' for 'MIME::Lite' is not a valid version. (requires -> MIME::Lite) [Validation: 1.4];'<undef>' for 'Net::SMTP' is not a valid version. (requires -> Net::SMTP) [Validation: 1.4];'<undef>' for 'Net::SNMP' is not a valid version. (requires -> Net::SNMP) [Validation: 1.4]

prereq_matches_use

List all used modules in META.yml requires

Error:

  • Moose
  • Moose::Util::TypeConstraints

use_strict

Add 'use strict' (or its equivalents) to all modules, or convince us that your favorite module is well-known enough and people can easily see the modules are strictly written.

Error: SysAdmin

consistent_version

Split the distribution, or fix the version numbers to make them consistent (use the highest version number to avoid version downgrade).

Error: 0.03,0.05,0.09,0.11

has_meta_json

Add a META.json to the distribution. Your buildtool should be able to autogenerate it.

meta_yml_declares_perl_version

If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.

meta_yml_has_license

Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.

use_warnings

Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: SysAdmin

has_separate_license_file

This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.

meta_yml_has_provides

Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.

meta_yml_has_repository_resource

Add a 'repository' resource to the META.yml via 'meta_add' accessor (for Module::Build) or META_ADD parameter (for ExtUtils::MakeMaker).

Modules

Name Abstract Version View
SysAdmin Parent class for SysAdmin wrapper modules. 0.11 metacpan
SysAdmin::DB Perl DBI/DBD wrapper module.. 0.09 metacpan
SysAdmin::Date 0.03 metacpan
SysAdmin::File Perl IO::File wrapper module.. 0.03 metacpan
SysAdmin::SMTP Perl Net::SMTP class wrapper module. 0.05 metacpan
SysAdmin::SNMP Perl SNMP class wrapper module 0.09 metacpan

Other Files

Changes metacpan
MANIFEST metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan