Kwalitee Issues


Add a MANIFEST to the distribution. Your buildtool should be able to autogenerate it (eg "make manifest" or "./Build manifest")


Run a proper command ("make manifest" or "./Build manifest", maybe with a force option), or use a distribution builder to generate the MANIFEST. Or update MANIFEST manually.

Error: Cannot find MANIFEST in dist.


Take a look at the META.json Spec at (for version 1.4) or (for version 2), and change your META.json accordingly.


Upgrade your META.json generator so it produces valid JSON.

Error: , or } expected while parsing object/hash, at character offset 500 (before ""File::Slurp" : "0",...")


Take a look at the META.yml Spec at (for version 1.4) or (for version 2), and change your META.yml accordingly.

Error: Missing mandatory field, 'author' (author) [Validation: 1.4]


If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.


Add a 'repository' resource to the META.yml via 'meta_add' accessor (for Module::Build) or META_ADD parameter (for ExtUtils::MakeMaker).


Name Abstract Version View
TAP::Formatter::BambooExtended Harness output delegate for Atlassian's Bamboo CI server 1.01 metacpan
TAP::Formatter::BambooExtended::Session 1.01 metacpan

Other Files

Changes metacpan
META.json metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan