Kwalitee Issues

has_meta_yml

Add a META.yml to the distribution. Your buildtool should be able to autogenerate it.

manifest_matches_dist

Run a proper command ("make manifest" or "./Build manifest", maybe with a force option), or use a distribution builder to generate the MANIFEST. Or update MANIFEST manually.

Error:

  • MANIFEST (38) does not match dist (37):
  • Missing in Dist: META.yml

no_pax_headers

If you use Mac OS X >= 10.6, use gnu tar (/usr/bin/gnutar) to avoid PAX headers. It's also important to rename (shorten) long file names (>= 100 characters) in the distribution.

Error: ./PaxHeaders.23112/TAP3-Tap3edit-0.33,./PaxHeaders.23112/TAP3-Tap3edit-0.33,TAP3-Tap3edit-0.33/PaxHeaders.23112/t,TAP3-Tap3edit-0.33/PaxHeaders.23112/t,TAP3-Tap3edit-0.33/t/PaxHeaders.23112/TAP3-Tap3edit.t,TAP3-Tap3edit-0.33/t/PaxHeaders.23112/TAP3-Tap3edit.t,TAP3-Tap3edit-0.33/PaxHeaders.23112/Makefile.PL,TAP3-Tap3edit-0.33/PaxHeaders.23112/Makefile.PL,TAP3-Tap3edit-0.33/PaxHeaders.23112/MANIFEST,TAP3-Tap3edit-0.33/PaxHeaders.23112/MANIFEST,TAP3-Tap3edit-0.33/PaxHeaders.23112/README,TAP3-Tap3edit-0.33/PaxHeaders.23112/README,TAP3-Tap3edit-0.33/PaxHeaders.23112/ChangeLog,TAP3-Tap3edit-0.33/PaxHeaders.23112/ChangeLog,TAP3-Tap3edit-0.33/PaxHeaders.23112/inc,TAP3-Tap3edit-0.33/PaxHeaders.23112/inc,TAP3-Tap3edit-0.33/inc/PaxHeaders.23112/parent.pm,TAP3-Tap3edit-0.33/inc/PaxHeaders.23112/parent.pm,TAP3-Tap3edit-0.33/inc/PaxHeaders.23112/Module,TAP3-Tap3edit-0.33/inc/PaxHeaders.23112/Module,TAP3-Tap3edit-0.33/inc/Module/PaxHeaders.23112/Install.pm,TAP3-Tap3edit-0.33/inc/Module/PaxHeaders.23112/Install.pm,TAP3-Tap3edit-0.33/inc/Module/PaxHeaders.23112/Install,TAP3-Tap3edit-0.33/inc/Module/PaxHeaders.23112/Install,TAP3-Tap3edit-0.33/inc/Module/Install/PaxHeaders.23112/Base.pm,TAP3-Tap3edit-0.33/inc/Module/Install/PaxHeaders.23112/Base.pm,TAP3-Tap3edit-0.33/inc/Module/Install/PaxHeaders.23112/Can.pm,TAP3-Tap3edit-0.33/inc/Module/Install/PaxHeaders.23112/Can.pm,TAP3-Tap3edit-0.33/inc/Module/Install/PaxHeaders.23112/Makefile.pm,TAP3-Tap3edit-0.33/inc/Module/Install/PaxHeaders.23112/Makefile.pm,TAP3-Tap3edit-0.33/inc/Module/Install/PaxHeaders.23112/Fetch.pm,TAP3-Tap3edit-0.33/inc/Module/Install/PaxHeaders.23112/Fetch.pm,TAP3-Tap3edit-0.33/inc/Module/Install/PaxHeaders.23112/Include.pm,TAP3-Tap3edit-0.33/inc/Module/Install/PaxHeaders.23112/Include.pm,TAP3-Tap3edit-0.33/inc/Module/Install/PaxHeaders.23112/Metadata.pm,TAP3-Tap3edit-0.33/inc/Module/Install/PaxHeaders.23112/Metadata.pm,TAP3-Tap3edit-0.33/inc/Module/Install/PaxHeaders.23112/Win32.pm,TAP3-Tap3edit-0.33/inc/Module/Install/PaxHeaders.23112/Win32.pm,TAP3-Tap3edit-0.33/inc/PaxHeaders.23112/PerlIO.pm,TAP3-Tap3edit-0.33/inc/PaxHeaders.23112/PerlIO.pm,TAP3-Tap3edit-0.33/inc/PaxHeaders.23112/Test,TAP3-Tap3edit-0.33/inc/PaxHeaders.23112/Test,TAP3-Tap3edit-0.33/inc/Test/PaxHeaders.23112/Builder,TAP3-Tap3edit-0.33/inc/Test/PaxHeaders.23112/Builder,TAP3-Tap3edit-0.33/inc/Test/Builder/PaxHeaders.23112/Module.pm,TAP3-Tap3edit-0.33/inc/Test/Builder/PaxHeaders.23112/Module.pm,TAP3-Tap3edit-0.33/inc/Test/PaxHeaders.23112/Builder.pm,TAP3-Tap3edit-0.33/inc/Test/PaxHeaders.23112/Builder.pm,TAP3-Tap3edit-0.33/inc/Test/PaxHeaders.23112/More.pm,TAP3-Tap3edit-0.33/inc/Test/PaxHeaders.23112/More.pm,TAP3-Tap3edit-0.33/PaxHeaders.23112/lib,TAP3-Tap3edit-0.33/PaxHeaders.23112/lib,TAP3-Tap3edit-0.33/lib/PaxHeaders.23112/TAP3,TAP3-Tap3edit-0.33/lib/PaxHeaders.23112/TAP3,TAP3-Tap3edit-0.33/lib/TAP3/PaxHeaders.23112/Tap3edit.pod,TAP3-Tap3edit-0.33/lib/TAP3/PaxHeaders.23112/Tap3edit.pod,TAP3-Tap3edit-0.33/lib/TAP3/PaxHeaders.23112/Spec,TAP3-Tap3edit-0.33/lib/TAP3/PaxHeaders.23112/Spec,TAP3-Tap3edit-0.33/lib/TAP3/Spec/PaxHeaders.23112/TAP0312.asn,TAP3-Tap3edit-0.33/lib/TAP3/Spec/PaxHeaders.23112/TAP0312.asn,TAP3-Tap3edit-0.33/lib/TAP3/Spec/PaxHeaders.23112/TAP0310.asn,TAP3-Tap3edit-0.33/lib/TAP3/Spec/PaxHeaders.23112/TAP0310.asn,TAP3-Tap3edit-0.33/lib/TAP3/Spec/PaxHeaders.23112/TAP0301.asn,TAP3-Tap3edit-0.33/lib/TAP3/Spec/PaxHeaders.23112/TAP0301.asn,TAP3-Tap3edit-0.33/lib/TAP3/Spec/PaxHeaders.23112/TAP0302.asn,TAP3-Tap3edit-0.33/lib/TAP3/Spec/PaxHeaders.23112/TAP0302.asn,TAP3-Tap3edit-0.33/lib/TAP3/Spec/PaxHeaders.23112/NRT0201.asn,TAP3-Tap3edit-0.33/lib/TAP3/Spec/PaxHeaders.23112/NRT0201.asn,TAP3-Tap3edit-0.33/lib/TAP3/Spec/PaxHeaders.23112/TAP0304.asn,TAP3-Tap3edit-0.33/lib/TAP3/Spec/PaxHeaders.23112/TAP0304.asn,TAP3-Tap3edit-0.33/lib/TAP3/Spec/PaxHeaders.23112/TAP0311.asn,TAP3-Tap3edit-0.33/lib/TAP3/Spec/PaxHeaders.23112/TAP0311.asn,TAP3-Tap3edit-0.33/lib/TAP3/Spec/PaxHeaders.23112/RAP0102.asn,TAP3-Tap3edit-0.33/lib/TAP3/Spec/PaxHeaders.23112/RAP0102.asn,TAP3-Tap3edit-0.33/lib/TAP3/Spec/PaxHeaders.23112/RAP0103.asn,TAP3-Tap3edit-0.33/lib/TAP3/Spec/PaxHeaders.23112/RAP0103.asn,TAP3-Tap3edit-0.33/lib/TAP3/Spec/PaxHeaders.23112/RAP0105.asn,TAP3-Tap3edit-0.33/lib/TAP3/Spec/PaxHeaders.23112/RAP0105.asn,TAP3-Tap3edit-0.33/lib/TAP3/Spec/PaxHeaders.23112/RAP0104.asn,TAP3-Tap3edit-0.33/lib/TAP3/Spec/PaxHeaders.23112/RAP0104.asn,TAP3-Tap3edit-0.33/lib/TAP3/Spec/PaxHeaders.23112/RAP0101.asn,TAP3-Tap3edit-0.33/lib/TAP3/Spec/PaxHeaders.23112/RAP0101.asn,TAP3-Tap3edit-0.33/lib/TAP3/Spec/PaxHeaders.23112/TAP0309.asn,TAP3-Tap3edit-0.33/lib/TAP3/Spec/PaxHeaders.23112/TAP0309.asn,TAP3-Tap3edit-0.33/lib/TAP3/Spec/PaxHeaders.23112/TAP0303.asn,TAP3-Tap3edit-0.33/lib/TAP3/Spec/PaxHeaders.23112/TAP0303.asn,TAP3-Tap3edit-0.33/lib/TAP3/PaxHeaders.23112/Tap3edit.pm,TAP3-Tap3edit-0.33/lib/TAP3/PaxHeaders.23112/Tap3edit.pm,TAP3-Tap3edit-0.33/PaxHeaders.23112/examples,TAP3-Tap3edit-0.33/PaxHeaders.23112/examples,TAP3-Tap3edit-0.33/examples/PaxHeaders.23112/tap3edit_camel_remover,TAP3-Tap3edit-0.33/examples/PaxHeaders.23112/tap3edit_camel_remover,TAP3-Tap3edit-0.33/examples/PaxHeaders.23112/tap3edit_display,TAP3-Tap3edit-0.33/examples/PaxHeaders.23112/tap3edit_display,TAP3-Tap3edit-0.33/examples/PaxHeaders.23112/tap3edit_get_info,TAP3-Tap3edit-0.33/examples/PaxHeaders.23112/tap3edit_get_info

no_pod_errors

Remove the POD errors. You can check for POD errors automatically by including Test::Pod to your test suite.

Error: TAP3-Tap3edit-0.33/lib/TAP3/Tap3edit.pod -- Around line 218: Non-ASCII character seen before =encoding in '(“Association”)'. Assuming UTF-8

has_meta_json

Add a META.json to the distribution. Your buildtool should be able to autogenerate it.

meta_yml_has_license

Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.

use_warnings

Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: TAP3::Tap3edit

has_separate_license_file

This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.

Modules

Name Abstract Version View
TAP3::Tap3edit TAP3, RAP and NRTRDE files Encode/Decode library http://www.tap3edit.com 0.33 metacpan

Other Files

ChangeLog metacpan
MANIFEST metacpan
Makefile.PL metacpan
README metacpan