Task-DWIM-CPAN

Metadata

Analyzed metadata and errors of Task-DWIM-CPAN.

{
   "abstracts_in_pod" : {
      "Task::DWIM::CPAN" : "A Task module for DWIM Perl L<http://dwimperl.com/>"
   },
   "author" : "SZABGAB",
   "buildfile_executable" : 0,
   "dir_lib" : "lib",
   "dir_t" : "t",
   "dirs_array" : [
      "inc/Module/Install",
      "inc/Module",
      "inc",
      "lib/Task/DWIM",
      "lib/Task",
      "lib",
      "lists",
      "t",
      "t"
   ],
   "dist" : "Task-DWIM-CPAN",
   "dynamic_config" : 1,
   "error" : {},
   "extension" : "tar.gz",
   "extractable" : 1,
   "extracts_nicely" : 1,
   "file__build" : 0,
   "file_blib" : 0,
   "file_build" : 0,
   "file_makefile" : 0,
   "file_makefile_pl" : "Makefile.PL",
   "file_manifest" : "MANIFEST",
   "file_meta_yml" : "META.yml",
   "file_pm_to_blib" : 0,
   "file_readme" : "README",
   "files_array" : [
      "MANIFEST",
      "META.yml",
      "Makefile.PL",
      "README",
      "lib/Task/DWIM/CPAN.pm",
      "lists/CPAN.txt"
   ],
   "files_hash" : {
      "MANIFEST" : {
         "mtime" : 1356342912,
         "size" : 331
      },
      "META.yml" : {
         "mtime" : 1356342911,
         "size" : 2264
      },
      "Makefile.PL" : {
         "mtime" : 1356342911,
         "size" : 463,
         "used" : [
            "Task::DWIM::CPAN",
            "inc::Module::Install",
            "lib"
         ]
      },
      "README" : {
         "mtime" : 1356342911,
         "size" : 912
      },
      "inc/Module/Install.pm" : {
         "mtime" : 1356342911,
         "no_index" : 1,
         "size" : 12381
      },
      "inc/Module/Install/Base.pm" : {
         "mtime" : 1356342911,
         "no_index" : 1,
         "size" : 1127
      },
      "inc/Module/Install/Can.pm" : {
         "mtime" : 1356342911,
         "no_index" : 1,
         "size" : 3183
      },
      "inc/Module/Install/Fetch.pm" : {
         "mtime" : 1356342911,
         "no_index" : 1,
         "size" : 2455
      },
      "inc/Module/Install/Makefile.pm" : {
         "mtime" : 1356342911,
         "no_index" : 1,
         "size" : 12063
      },
      "inc/Module/Install/Metadata.pm" : {
         "mtime" : 1356342911,
         "no_index" : 1,
         "size" : 18111
      },
      "inc/Module/Install/Win32.pm" : {
         "mtime" : 1356342911,
         "no_index" : 1,
         "size" : 1795
      },
      "inc/Module/Install/WriteAll.pm" : {
         "mtime" : 1356342911,
         "no_index" : 1,
         "size" : 1278
      },
      "lib/Task/DWIM/CPAN.pm" : {
         "license" : "Perl_5",
         "module" : "Task::DWIM::CPAN",
         "mtime" : 1356342911,
         "size" : 3418,
         "used" : [
            "5.008",
            "strict",
            "warnings"
         ]
      },
      "lists/CPAN.txt" : {
         "mtime" : 1356342911,
         "size" : 4144
      },
      "t/00-load.t" : {
         "mtime" : 1356342911,
         "no_index" : 1,
         "noed" : [
            "warnings"
         ],
         "size" : 1671,
         "used" : [
            "Perl::Version",
            "Task::DWIM::CPAN",
            "Test::More",
            "strict",
            "warnings"
         ]
      }
   },
   "got_prereq_from" : "META.yml",
   "included_modules" : [
      "Module::Install",
      "Module::Install::WriteAll",
      "Module::Install::Metadata",
      "Module::Install::Win32",
      "Module::Install::Fetch",
      "Module::Install::Can",
      "Module::Install::Base",
      "Module::Install::Makefile"
   ],
   "kwalitee" : {
      "buildtool_not_executable" : 1,
      "consistent_version" : 1,
      "distname_matches_name_in_meta" : 1,
      "extractable" : 1,
      "extracts_nicely" : 1,
      "has_abstract_in_pod" : 1,
      "has_buildtool" : 1,
      "has_changelog" : 0,
      "has_human_readable_license" : 1,
      "has_known_license_in_source_file" : 1,
      "has_license_in_source_file" : 1,
      "has_manifest" : 1,
      "has_meta_yml" : 1,
      "has_proper_version" : 1,
      "has_readme" : 1,
      "has_separate_license_file" : 0,
      "has_tests" : 1,
      "has_tests_in_t_dir" : 1,
      "has_version" : 1,
      "kwalitee" : "97.73",
      "manifest_matches_dist" : 1,
      "meta_json_conforms_to_known_spec" : 1,
      "meta_json_is_parsable" : 1,
      "meta_yml_conforms_to_known_spec" : 1,
      "meta_yml_declares_perl_version" : 1,
      "meta_yml_has_license" : 1,
      "meta_yml_has_provides" : 0,
      "meta_yml_has_repository_resource" : 1,
      "meta_yml_is_parsable" : 1,
      "no_abstract_stub_in_pod" : 1,
      "no_broken_auto_install" : 1,
      "no_broken_module_install" : 1,
      "no_dot_dirs" : 1,
      "no_dot_underscore_files" : 1,
      "no_generated_files" : 1,
      "no_invalid_versions" : 1,
      "no_local_dirs" : 1,
      "no_mymeta_files" : 1,
      "no_pax_headers" : 1,
      "no_pod_errors" : 1,
      "no_stdin_for_prompting" : 1,
      "no_symlinks" : 1,
      "package_version_matches_dist_version" : 1,
      "portable_filenames" : 1,
      "proper_libs" : 1,
      "use_strict" : 1,
      "use_warnings" : 1,
      "valid_signature" : 1
   },
   "latest_mtime" : 1356342912,
   "license" : "perl defined in META.yml",
   "license_file" : "lib/Task/DWIM/CPAN.pm",
   "license_from_yaml" : "perl",
   "license_in_pod" : 1,
   "license_type" : "Perl_5",
   "licenses" : {
      "Perl_5" : [
         "lib/Task/DWIM/CPAN.pm"
      ]
   },
   "manifest_matches_dist" : 1,
   "meta_yml" : {
      "abstract" : "A Task module for DWIM Perl L<http://dwimperl.com/>",
      "author" : [
         "Gabor Szabo <szabgab@cpan.org>"
      ],
      "build_requires" : {
         "ExtUtils::MakeMaker" : "6.59",
         "Perl::Version" : "1.011",
         "Test::More" : "0.42"
      },
      "configure_requires" : {
         "ExtUtils::MakeMaker" : "6.59"
      },
      "distribution_type" : "module",
      "dynamic_config" : "1",
      "generated_by" : "Module::Install version 1.06",
      "license" : "perl",
      "meta-spec" : {
         "url" : "http://module-build.sourceforge.net/META-spec-v1.4.html",
         "version" : "1.4"
      },
      "name" : "Task-DWIM-CPAN",
      "no_index" : {
         "directory" : [
            "inc",
            "t"
         ]
      },
      "requires" : {
         "CPAN" : "1.9800",
         "CPAN::DistnameInfo" : "0.12",
         "CPAN::Inject" : "1.13",
         "CPAN::Meta" : "2.120921",
         "CPAN::Meta::Requirements" : "2.120351",
         "CPAN::Meta::YAML" : "0.004",
         "CPAN::Reporter" : "1.2003",
         "CPAN::SQLite" : "0.202",
         "CPAN::Testers::Report" : "1.999001",
         "CPAN::Uploader" : "0.103000",
         "CPANPLUS" : "0.9112",
         "CPANPLUS::Dist::Build" : "0.60",
         "Carp::Always" : "0.12",
         "Carp::Assert" : "0.20",
         "Carp::Assert::More" : "1.14",
         "Carp::Clan" : "6.04",
         "Devel::NYTProf" : "4.09",
         "Exporter" : "5.65",
         "Exporter::Declare" : "0.105",
         "ExtUtils::Depends" : "0.304",
         "ExtUtils::MakeMaker" : "6.62",
         "ExtUtils::Manifest" : "1.60",
         "ExtUtils::ParseXS" : "3.05",
         "ExtUtils::XSpp" : "0.1602",
         "File::ShareDir" : "1.03",
         "File::ShareDir::Install" : "0.04",
         "MetaCPAN::API" : "0.43",
         "Modern::Perl" : "1.20120130",
         "Module::Build" : "0.3800",
         "Module::CoreList" : "2.57",
         "Module::Find" : "0.11",
         "Module::Implementation" : "0.04",
         "Module::Install" : "1.04",
         "Module::Install::ReadmeFromPod" : "0.16",
         "Module::Load" : "0.22",
         "Module::Load::Conditional" : "0.46",
         "Module::Manifest" : "1.08",
         "Module::Metadata" : "1.000007",
         "Module::Refresh" : "0.17",
         "Module::Runtime" : "0.011",
         "Module::ScanDeps" : "1.07",
         "PAR" : "1.002",
         "PAR::Dist" : "0.48",
         "PAR::Dist::FromPPD" : "0.03",
         "PAR::Dist::InstallPPD" : "0.02",
         "PAR::Repository::Client" : "0.25",
         "PAR::Repository::Query" : "0.14",
         "PPI" : "1.215",
         "PPI::HTML" : "1.08",
         "PPIx::EditorTools" : "0.15",
         "PPIx::Regexp" : "0.025",
         "PPIx::Utilities::Node" : "1.001000",
         "Perl::Critic" : "1.117",
         "Perl::Tidy" : "20101217",
         "Perl::Version" : "1.011",
         "Pod::Abstract" : "0.20",
         "Pod::Coverage" : "0.22",
         "Pod::Eventual" : "0.093330",
         "Pod::Functions" : "0",
         "Pod::POM" : "0.27",
         "Pod::Perldoc" : "3.15",
         "Pod::Readme" : "0",
         "Pod::Simple" : "3.23",
         "Pod::Simple::XHTML" : "3.04",
         "Software::License" : "0.103004",
         "Sort::Versions" : "1.5",
         "perl" : "5.008"
      },
      "resources" : {
         "license" : "http://dev.perl.org/licenses/",
         "repository" : "https://github.com/dwimperl/Task-DWIM"
      },
      "version" : "0.07"
   },
   "meta_yml_is_parsable" : 1,
   "meta_yml_spec_version" : "1.4",
   "module_install" : {
      "version" : "1.06"
   },
   "modules" : [
      {
         "file" : "lib/Task/DWIM/CPAN.pm",
         "in_basedir" : 0,
         "in_lib" : 1,
         "module" : "Task::DWIM::CPAN"
      }
   ],
   "needs_compiler" : 1,
   "no_index" : "^inc/;^t/",
   "no_pax_headers" : 1,
   "package" : "Task-DWIM-CPAN-0.07.tar.gz",
   "prereq" : [
      {
         "is_prereq" : 1,
         "requires" : "Devel::NYTProf",
         "type" : "runtime_requires",
         "version" : "4.09"
      },
      {
         "is_prereq" : 1,
         "requires" : "PAR::Dist::FromPPD",
         "type" : "runtime_requires",
         "version" : "0.03"
      },
      {
         "is_prereq" : 1,
         "requires" : "PAR::Dist",
         "type" : "runtime_requires",
         "version" : "0.48"
      },
      {
         "is_prereq" : 1,
         "requires" : "Module::Find",
         "type" : "runtime_requires",
         "version" : "0.11"
      },
      {
         "is_build_prereq" : 1,
         "requires" : "Test::More",
         "type" : "build_requires",
         "version" : "0.42"
      },
      {
         "is_prereq" : 1,
         "requires" : "CPAN::Uploader",
         "type" : "runtime_requires",
         "version" : "0.103000"
      },
      {
         "is_prereq" : 1,
         "requires" : "ExtUtils::Manifest",
         "type" : "runtime_requires",
         "version" : "1.60"
      },
      {
         "is_prereq" : 1,
         "requires" : "PAR::Repository::Client",
         "type" : "runtime_requires",
         "version" : "0.25"
      },
      {
         "is_prereq" : 1,
         "requires" : "Module::Metadata",
         "type" : "runtime_requires",
         "version" : "1.000007"
      },
      {
         "is_prereq" : 1,
         "requires" : "PPI::HTML",
         "type" : "runtime_requires",
         "version" : "1.08"
      },
      {
         "is_prereq" : 1,
         "requires" : "Module::Load::Conditional",
         "type" : "runtime_requires",
         "version" : "0.46"
      },
      {
         "is_prereq" : 1,
         "requires" : "Module::Build",
         "type" : "runtime_requires",
         "version" : "0.3800"
      },
      {
         "is_prereq" : 1,
         "requires" : "PAR",
         "type" : "runtime_requires",
         "version" : "1.002"
      },
      {
         "is_prereq" : 1,
         "requires" : "CPAN::Meta",
         "type" : "runtime_requires",
         "version" : "2.120921"
      },
      {
         "is_prereq" : 1,
         "requires" : "Pod::POM",
         "type" : "runtime_requires",
         "version" : "0.27"
      },
      {
         "is_prereq" : 1,
         "requires" : "CPAN::SQLite",
         "type" : "runtime_requires",
         "version" : "0.202"
      },
      {
         "is_prereq" : 1,
         "requires" : "CPAN::Testers::Report",
         "type" : "runtime_requires",
         "version" : "1.999001"
      },
      {
         "is_prereq" : 1,
         "requires" : "Module::Load",
         "type" : "runtime_requires",
         "version" : "0.22"
      },
      {
         "is_prereq" : 1,
         "requires" : "CPAN::Meta::Requirements",
         "type" : "runtime_requires",
         "version" : "2.120351"
      },
      {
         "is_prereq" : 1,
         "requires" : "Pod::Abstract",
         "type" : "runtime_requires",
         "version" : "0.20"
      },
      {
         "is_prereq" : 1,
         "requires" : "Carp::Clan",
         "type" : "runtime_requires",
         "version" : "6.04"
      },
      {
         "is_prereq" : 1,
         "requires" : "Pod::Eventual",
         "type" : "runtime_requires",
         "version" : "0.093330"
      },
      {
         "is_prereq" : 1,
         "requires" : "File::ShareDir",
         "type" : "runtime_requires",
         "version" : "1.03"
      },
      {
         "is_prereq" : 1,
         "requires" : "Carp::Always",
         "type" : "runtime_requires",
         "version" : "0.12"
      },
      {
         "is_prereq" : 1,
         "requires" : "CPAN::Inject",
         "type" : "runtime_requires",
         "version" : "1.13"
      },
      {
         "is_prereq" : 1,
         "requires" : "PPIx::EditorTools",
         "type" : "runtime_requires",
         "version" : "0.15"
      },
      {
         "is_prereq" : 1,
         "requires" : "Module::Manifest",
         "type" : "runtime_requires",
         "version" : "1.08"
      },
      {
         "is_prereq" : 1,
         "requires" : "Pod::Readme",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "Pod::Simple::XHTML",
         "type" : "runtime_requires",
         "version" : "3.04"
      },
      {
         "is_prereq" : 1,
         "requires" : "Module::Refresh",
         "type" : "runtime_requires",
         "version" : "0.17"
      },
      {
         "is_prereq" : 1,
         "requires" : "perl",
         "type" : "runtime_requires",
         "version" : "5.008"
      },
      {
         "is_prereq" : 1,
         "requires" : "MetaCPAN::API",
         "type" : "runtime_requires",
         "version" : "0.43"
      },
      {
         "is_prereq" : 1,
         "requires" : "Pod::Perldoc",
         "type" : "runtime_requires",
         "version" : "3.15"
      },
      {
         "is_prereq" : 1,
         "requires" : "Carp::Assert",
         "type" : "runtime_requires",
         "version" : "0.20"
      },
      {
         "is_prereq" : 1,
         "requires" : "PPIx::Utilities::Node",
         "type" : "runtime_requires",
         "version" : "1.001000"
      },
      {
         "is_prereq" : 1,
         "requires" : "Perl::Version",
         "type" : "runtime_requires",
         "version" : "1.011"
      },
      {
         "is_build_prereq" : 1,
         "requires" : "Perl::Version",
         "type" : "build_requires",
         "version" : "1.011"
      },
      {
         "is_prereq" : 1,
         "requires" : "CPAN",
         "type" : "runtime_requires",
         "version" : "1.9800"
      },
      {
         "is_prereq" : 1,
         "requires" : "CPANPLUS::Dist::Build",
         "type" : "runtime_requires",
         "version" : "0.60"
      },
      {
         "is_prereq" : 1,
         "requires" : "Software::License",
         "type" : "runtime_requires",
         "version" : "0.103004"
      },
      {
         "is_prereq" : 1,
         "requires" : "CPAN::Meta::YAML",
         "type" : "runtime_requires",
         "version" : "0.004"
      },
      {
         "is_prereq" : 1,
         "requires" : "PPIx::Regexp",
         "type" : "runtime_requires",
         "version" : "0.025"
      },
      {
         "is_prereq" : 1,
         "requires" : "Pod::Functions",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "ExtUtils::ParseXS",
         "type" : "runtime_requires",
         "version" : "3.05"
      },
      {
         "is_prereq" : 1,
         "requires" : "PPI",
         "type" : "runtime_requires",
         "version" : "1.215"
      },
      {
         "is_prereq" : 1,
         "requires" : "Perl::Critic",
         "type" : "runtime_requires",
         "version" : "1.117"
      },
      {
         "is_prereq" : 1,
         "requires" : "CPAN::Reporter",
         "type" : "runtime_requires",
         "version" : "1.2003"
      },
      {
         "is_prereq" : 1,
         "requires" : "File::ShareDir::Install",
         "type" : "runtime_requires",
         "version" : "0.04"
      },
      {
         "is_prereq" : 1,
         "requires" : "PAR::Repository::Query",
         "type" : "runtime_requires",
         "version" : "0.14"
      },
      {
         "is_prereq" : 1,
         "requires" : "Module::Runtime",
         "type" : "runtime_requires",
         "version" : "0.011"
      },
      {
         "is_prereq" : 1,
         "requires" : "Modern::Perl",
         "type" : "runtime_requires",
         "version" : "1.20120130"
      },
      {
         "is_prereq" : 1,
         "requires" : "Module::Implementation",
         "type" : "runtime_requires",
         "version" : "0.04"
      },
      {
         "is_prereq" : 1,
         "requires" : "ExtUtils::Depends",
         "type" : "runtime_requires",
         "version" : "0.304"
      },
      {
         "is_prereq" : 1,
         "requires" : "ExtUtils::MakeMaker",
         "type" : "runtime_requires",
         "version" : "6.62"
      },
      {
         "is_build_prereq" : 1,
         "requires" : "ExtUtils::MakeMaker",
         "type" : "build_requires",
         "version" : "6.59"
      },
      {
         "requires" : "ExtUtils::MakeMaker",
         "type" : "configure_requires",
         "version" : "6.59"
      },
      {
         "is_prereq" : 1,
         "requires" : "Exporter",
         "type" : "runtime_requires",
         "version" : "5.65"
      },
      {
         "is_prereq" : 1,
         "requires" : "PAR::Dist::InstallPPD",
         "type" : "runtime_requires",
         "version" : "0.02"
      },
      {
         "is_prereq" : 1,
         "requires" : "ExtUtils::XSpp",
         "type" : "runtime_requires",
         "version" : "0.1602"
      },
      {
         "is_prereq" : 1,
         "requires" : "CPANPLUS",
         "type" : "runtime_requires",
         "version" : "0.9112"
      },
      {
         "is_prereq" : 1,
         "requires" : "Pod::Simple",
         "type" : "runtime_requires",
         "version" : "3.23"
      },
      {
         "is_prereq" : 1,
         "requires" : "Module::ScanDeps",
         "type" : "runtime_requires",
         "version" : "1.07"
      },
      {
         "is_prereq" : 1,
         "requires" : "Carp::Assert::More",
         "type" : "runtime_requires",
         "version" : "1.14"
      },
      {
         "is_prereq" : 1,
         "requires" : "Sort::Versions",
         "type" : "runtime_requires",
         "version" : "1.5"
      },
      {
         "is_prereq" : 1,
         "requires" : "Module::Install::ReadmeFromPod",
         "type" : "runtime_requires",
         "version" : "0.16"
      },
      {
         "is_prereq" : 1,
         "requires" : "Exporter::Declare",
         "type" : "runtime_requires",
         "version" : "0.105"
      },
      {
         "is_prereq" : 1,
         "requires" : "Pod::Coverage",
         "type" : "runtime_requires",
         "version" : "0.22"
      },
      {
         "is_prereq" : 1,
         "requires" : "Perl::Tidy",
         "type" : "runtime_requires",
         "version" : "20101217"
      },
      {
         "is_prereq" : 1,
         "requires" : "Module::CoreList",
         "type" : "runtime_requires",
         "version" : "2.57"
      },
      {
         "is_prereq" : 1,
         "requires" : "CPAN::DistnameInfo",
         "type" : "runtime_requires",
         "version" : "0.12"
      },
      {
         "is_prereq" : 1,
         "requires" : "Module::Install",
         "type" : "runtime_requires",
         "version" : "1.04"
      }
   ],
   "released_epoch" : 1356343263,
   "size_packed" : 21531,
   "size_unpacked" : 65596,
   "uses" : {
      "noed_in_tests" : {
         "warnings" : 1
      },
      "used_in_code" : {
         "5.008" : 1,
         "strict" : 1,
         "warnings" : 1
      },
      "used_in_config" : {
         "inc::Module::Install" : 1,
         "lib" : 1
      },
      "used_in_tests" : {
         "Perl::Version" : 1,
         "Test::More" : 1,
         "strict" : 1,
         "warnings" : 1
      }
   },
   "valid_signature" : -1,
   "version" : "0.07",
   "versions" : {
      "lib/Task/DWIM/CPAN.pm" : {
         "Task::DWIM::CPAN" : "0.07"
      }
   },
   "vname" : "Task-DWIM-CPAN-0.07"
}