Kwalitee Issues

has_changelog

Add a Changelog (best named 'Changes') to the distribution. It should list at least major changes implemented in newer versions.

prereq_matches_use

List all used modules in META.yml requires

Error:

  • XML::LibXML

consistent_version

Split the distribution, or fix the version numbers to make them consistent (use the highest version number to avoid version downgrade).

Error: 2,2.04,2.15,2.17,2.36,2.66,2.7,2.71

has_meta_json

Add a META.json to the distribution. Your buildtool should be able to autogenerate it.

meta_yml_declares_perl_version

If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.

meta_yml_has_license

Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.

no_unauthorized_packages

Ask the owner of the distribution (the one who released it first, or the one who is designated in x_authority) to give you a (co-)maintainer's permission.

Error:

  • Template::Plugin::XML::LibXML
  • XML::DOM::Element
  • XML::DOM::Node
  • XML::LibXML::Document
  • XML::LibXML::Node
  • XML::LibXML::NodeList
  • XML::LibXML::Text
  • XML::XPath::Node::Comment
  • XML::XPath::Node::Element
  • XML::XPath::Node::Text

use_warnings

Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: Template::Plugin::XML::View

build_prereq_matches_use

List all modules used in the test suite in META.yml build_requires

Error:

  • Cwd
  • lib
  • strict
  • warnings

has_separate_license_file

This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.

meta_yml_has_provides

Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.

meta_yml_has_repository_resource

Add a 'repository' resource to the META.yml via 'meta_add' accessor (for Module::Build) or META_ADD parameter (for ExtUtils::MakeMaker).

Modules

Name Abstract Version View
Template::Plugin::XML XML plugin for the Template Toolkit 2.17 metacpan
Template::Plugin::XML::DOM Plugin interface to XML::DOM 2.7 metacpan
Template::Plugin::XML::File TT plugin for XML files 2.15 metacpan
Template::Plugin::XML::LibXML XML::LibXML Template Toolkit Plugin 2 metacpan
Template::Plugin::XML::RSS Plugin interface to XML::RSS 2.66 metacpan
Template::Plugin::XML::Simple Plugin interface to XML::Simple 2.66 metacpan
Template::Plugin::XML::Style Simple XML stylesheet transfomations 2.36 metacpan
Template::Plugin::XML::View 2.04 metacpan
Template::Plugin::XML::XPath Plugin interface to XML::XPath 2.71 metacpan

Provides

Name File View
Template::Plugin::XML::View::Element lib/Template/Plugin/XML/View.pm metacpan
Template::Plugin::XML::View::Parser lib/Template/Plugin/XML/View.pm metacpan
XML::DOM::Element lib/Template/Plugin/XML/DOM.pm metacpan
XML::DOM::Node lib/Template/Plugin/XML/DOM.pm metacpan
XML::LibXML::Document lib/Template/Plugin/XML/LibXML.pm metacpan
XML::LibXML::Node lib/Template/Plugin/XML/LibXML.pm metacpan
XML::LibXML::NodeList lib/Template/Plugin/XML/LibXML.pm metacpan
XML::LibXML::Text lib/Template/Plugin/XML/LibXML.pm metacpan
XML::XPath::Node::Comment lib/Template/Plugin/XML/XPath.pm metacpan
XML::XPath::Node::Element lib/Template/Plugin/XML/XPath.pm metacpan
XML::XPath::Node::Text lib/Template/Plugin/XML/XPath.pm metacpan

Other Files

MANIFEST metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan