Under maintenance.

Most probably CPANTS databases are being regenerated from scratch due to major changes in Kwalitee metrics or updates of relevant modules/perl. Usually this maintenance takes about a day or two, and some of the information may be old or missing tentatively. Sorry for the inconvenience.

Test-Legal

Prerequisites

Test-Legal declares the following 13 modules as prerequisites.

Listed PrerequisitesRequired VersionLatest DistKwalitee
Getopt::Compact0.04Getopt-Compact-0.04117.14
Sub::Exporter0.982Sub-Exporter-0.987134.29
perl5.10.0perl0.00
Software::License0.103002Software-License-0.103011134.29
List::Compare0.37List-Compare-0.53128.57
File::Slurp9999.18File-Slurp-9999.19120.00
Test::Builder::Module0.98Test-Simple-1.001014122.86
Log::Log4perl1.33Log-Log4perl-1.47117.14
File::Find::Rule0.33File-Find-Rule-0.34120.00
List::Util1.23Scalar-List-Utils-1.45134.29
List::MoreUtils0.32List-MoreUtils-0.413131.43
IO::Prompter0.0010010.00
CPAN::Meta2.112621CPAN-Meta-2.150005134.29

Test-Legal declares the following 15 modules as build prerequisites.

Listed Build PrerequisitesRequired VersionLatest DistKwalitee
Test::Strict0.14Test-Strict-0.36134.29
Test::CPAN::Meta0.18Test-CPAN-Meta-0.25134.29
ExtUtils::MakeMaker6.42ExtUtils-MakeMaker-7.10131.43
namespace::clean0.21namespace-clean-0.26128.57
Test::Script1.07Test-Script-1.10134.29
Test::HasVersion0.012Test-HasVersion-0.014131.43
Test::Spelling0.15Test-Spelling-0.20134.29
Test::Pod::Coverage1.08Test-Pod-Coverage-1.10134.29
Test::t0.0031Test-t-0.0031131.43
Test::Exception0.31Test-Exception-0.43131.43
Expect1.21Expect-1.3297.14
File::Copy2.18perl0.00
Test::Dependencies0.12Test-Dependencies-0.12125.71
Test::MinimumVersion0.101080Test-MinimumVersion-0.101082134.29
Test::Pod1.45Test-Pod-1.51131.43

Test-Legal declares the following 1 modules as optional prerequisites.

Listed Optional PrerequisitesRequired VersionLatest DistKwalitee
ExtUtils::MakeMaker6.42ExtUtils-MakeMaker-7.10131.428571428571