Kwalitee Issues

no_pax_headers

If you use Mac OS X >= 10.6, use gnu tar (/usr/bin/gnutar) to avoid PAX headers. It's also important to rename (shorten) long file names (>= 100 characters) in the distribution.

Error: ./PaxHeaders.2182/Test-PDL-0.13,./PaxHeaders.2182/Test-PDL-0.13,Test-PDL-0.13/PaxHeaders.2182/t,Test-PDL-0.13/PaxHeaders.2182/t,Test-PDL-0.13/t/PaxHeaders.2182/eq_pdl_diag.t,Test-PDL-0.13/t/PaxHeaders.2182/eq_pdl_diag.t,Test-PDL-0.13/t/PaxHeaders.2182/is_pdl.t,Test-PDL-0.13/t/PaxHeaders.2182/is_pdl.t,Test-PDL-0.13/t/PaxHeaders.2182/release-cpan-changes.t,Test-PDL-0.13/t/PaxHeaders.2182/release-cpan-changes.t,Test-PDL-0.13/t/PaxHeaders.2182/release-pod-coverage.t,Test-PDL-0.13/t/PaxHeaders.2182/release-pod-coverage.t,Test-PDL-0.13/t/PaxHeaders.2182/00-report-prereqs.t,Test-PDL-0.13/t/PaxHeaders.2182/00-report-prereqs.t,Test-PDL-0.13/t/PaxHeaders.2182/00-compile.t,Test-PDL-0.13/t/PaxHeaders.2182/00-compile.t,Test-PDL-0.13/t/PaxHeaders.2182/import_options.t,Test-PDL-0.13/t/PaxHeaders.2182/import_options.t,Test-PDL-0.13/t/PaxHeaders.2182/00-report-prereqs.dd,Test-PDL-0.13/t/PaxHeaders.2182/00-report-prereqs.dd,Test-PDL-0.13/t/PaxHeaders.2182/eq_pdl.t,Test-PDL-0.13/t/PaxHeaders.2182/eq_pdl.t,Test-PDL-0.13/t/PaxHeaders.2182/release-pod-syntax.t,Test-PDL-0.13/t/PaxHeaders.2182/release-pod-syntax.t,Test-PDL-0.13/t/PaxHeaders.2182/author-test-version.t,Test-PDL-0.13/t/PaxHeaders.2182/author-test-version.t,Test-PDL-0.13/t/PaxHeaders.2182/deep.t,Test-PDL-0.13/t/PaxHeaders.2182/deep.t,Test-PDL-0.13/t/PaxHeaders.2182/eq_pdl_clean.t,Test-PDL-0.13/t/PaxHeaders.2182/eq_pdl_clean.t,Test-PDL-0.13/t/PaxHeaders.2182/release-changes_has_content.t,Test-PDL-0.13/t/PaxHeaders.2182/release-changes_has_content.t,Test-PDL-0.13/PaxHeaders.2182/Changes,Test-PDL-0.13/PaxHeaders.2182/Changes,Test-PDL-0.13/PaxHeaders.2182/Makefile.PL,Test-PDL-0.13/PaxHeaders.2182/Makefile.PL,Test-PDL-0.13/PaxHeaders.2182/README,Test-PDL-0.13/PaxHeaders.2182/README,Test-PDL-0.13/PaxHeaders.2182/lib,Test-PDL-0.13/PaxHeaders.2182/lib,Test-PDL-0.13/lib/PaxHeaders.2182/Test,Test-PDL-0.13/lib/PaxHeaders.2182/Test,Test-PDL-0.13/lib/Test/PaxHeaders.2182/Deep,Test-PDL-0.13/lib/Test/PaxHeaders.2182/Deep,Test-PDL-0.13/lib/Test/Deep/PaxHeaders.2182/PDL.pm,Test-PDL-0.13/lib/Test/Deep/PaxHeaders.2182/PDL.pm,Test-PDL-0.13/lib/Test/PaxHeaders.2182/PDL.pm,Test-PDL-0.13/lib/Test/PaxHeaders.2182/PDL.pm,Test-PDL-0.13/PaxHeaders.2182/MANIFEST,Test-PDL-0.13/PaxHeaders.2182/MANIFEST,Test-PDL-0.13/PaxHeaders.2182/LICENSE,Test-PDL-0.13/PaxHeaders.2182/LICENSE,Test-PDL-0.13/PaxHeaders.2182/MANIFEST.SKIP,Test-PDL-0.13/PaxHeaders.2182/MANIFEST.SKIP,Test-PDL-0.13/PaxHeaders.2182/dist.ini,Test-PDL-0.13/PaxHeaders.2182/dist.ini,Test-PDL-0.13/PaxHeaders.2182/META.yml,Test-PDL-0.13/PaxHeaders.2182/META.yml

has_meta_json

Add a META.json to the distribution. Your buildtool should be able to autogenerate it.

meta_yml_declares_perl_version

If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.

build_prereq_matches_use

List all modules used in the test suite in META.yml build_requires

Error:

  • Pod::Coverage::TrustPod
  • Test::Pod
  • Test::Pod::Coverage
  • Test::Version

meta_yml_has_provides

Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.

Modules

Name Abstract Version View
Test::Deep::PDL Test piddles inside data structures with Test::Deep 0.13 metacpan
Test::PDL Test Perl Data Language arrays (a.k.a. piddles) for equality 0.13 metacpan

Other Files

Changes metacpan
MANIFEST metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan
dist.ini metacpan