Kwalitee Issues

prereq_matches_use

List all used modules in META.yml requires

Error:

  • strict
  • warnings

consistent_version

Split the distribution, or fix the version numbers to make them consistent (use the highest version number to avoid version downgrade).

Error: 0.01,0.03,0.05,0.16

has_meta_json

Add a META.json to the distribution. Your buildtool should be able to autogenerate it.

meta_yml_declares_perl_version

If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.

build_prereq_matches_use

List all modules used in the test suite in META.yml build_requires

Error:

  • Test::More
  • strict
  • warnings

meta_yml_has_provides

Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.

meta_yml_has_repository_resource

Add a 'repository' resource to the META.yml via 'meta_add' accessor (for Module::Build) or META_ADD parameter (for ExtUtils::MakeMaker).

Modules

Name Abstract Version View
Tropo Use the TropoAPI via Perl 0.16 metacpan
Tropo::RestAPI::Base Base class for REST-API part of Tropo 0.03 metacpan
Tropo::RestAPI::Session Tropo session handling 0.05 metacpan
Tropo::WebAPI::Ask "Ask" something with Tropo 0.01 metacpan
Tropo::WebAPI::Base Base class for Web-API part of Tropo API metacpan
Tropo::WebAPI::Call "Call" someone via Tropo API 0.01 metacpan
Tropo::WebAPI::On "On" something with Tropo 0.01 metacpan
Tropo::WebAPI::Say "Say" something with Tropo 0.01 metacpan
Tropo::WebAPI::Wait "Wait" with Tropo 0.01 metacpan

Other Files

Changes metacpan
MANIFEST metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan
dist.ini metacpan