UNIVERSAL-require

Metadata

Analyzed metadata and errors of UNIVERSAL-require.

{
   "abstracts_in_pod" : {
      "UNIVERSAL::require" : "require() modules from a variable"
   },
   "author" : "NEILB",
   "buildfile_executable" : 0,
   "dir_lib" : "lib",
   "dir_t" : "t",
   "dirs_array" : [
      "lib",
      "lib/UNIVERSAL",
      "t"
   ],
   "dist" : "UNIVERSAL-require",
   "dynamic_config" : 1,
   "error" : {},
   "extension" : "tar.gz",
   "extractable" : 1,
   "extracts_nicely" : 1,
   "file__build" : 0,
   "file_blib" : 0,
   "file_build" : 0,
   "file_changelog" : "Changes",
   "file_makefile" : 0,
   "file_makefile_pl" : "Makefile.PL",
   "file_manifest" : "MANIFEST",
   "file_meta_json" : "META.json",
   "file_meta_yml" : "META.yml",
   "file_pm_to_blib" : 0,
   "file_readme" : "README",
   "files_array" : [
      "README",
      "META.json",
      "Changes",
      "Makefile.PL",
      "META.yml",
      "MANIFEST",
      "lib/UNIVERSAL/require.pm"
   ],
   "files_hash" : {
      "Changes" : {
         "mtime" : 1397864248,
         "size" : 1865
      },
      "MANIFEST" : {
         "mtime" : 1397866284,
         "size" : 291
      },
      "META.json" : {
         "mtime" : 1397866284,
         "size" : 1288
      },
      "META.yml" : {
         "mtime" : 1397866284,
         "size" : 673
      },
      "Makefile.PL" : {
         "mtime" : 1397860362,
         "size" : 1301,
         "used" : [
            "ExtUtils::MakeMaker"
         ]
      },
      "README" : {
         "mtime" : 1395697873,
         "size" : 618
      },
      "lib/UNIVERSAL/require.pm" : {
         "license" : "Perl_5",
         "module" : "UNIVERSAL::require",
         "mtime" : 1397861523,
         "required" : [
            "UNIVERSAL"
         ],
         "size" : 4841,
         "used" : [
            "5.006",
            "Carp",
            "strict",
            "vars",
            "warnings"
         ]
      },
      "t/Dummy.pm" : {
         "mtime" : 1362776277,
         "no_index" : 1,
         "size" : 198
      },
      "t/require.t" : {
         "mtime" : 1397861951,
         "no_index" : 1,
         "required_in_eval" : [
            "UNIVERSAL"
         ],
         "size" : 1660,
         "used" : [
            "Test::More",
            "lib"
         ]
      },
      "t/taint.t" : {
         "mtime" : 1397864155,
         "no_index" : 1,
         "size" : 225,
         "used" : [
            "Test::More",
            "UNIVERSAL::require",
            "strict"
         ]
      },
      "t/use.t" : {
         "mtime" : 1362776277,
         "no_index" : 1,
         "size" : 428,
         "used" : [
            "Test::More",
            "lib"
         ]
      }
   },
   "got_prereq_from" : "META.yml",
   "kwalitee" : {
      "buildtool_not_executable" : 1,
      "consistent_version" : 1,
      "easily_repackageable_by_debian" : 1,
      "easily_repackageable_by_fedora" : 1,
      "extractable" : 1,
      "extracts_nicely" : 1,
      "fits_fedora_license" : 1,
      "has_abstract_in_pod" : 1,
      "has_buildtool" : 1,
      "has_changelog" : 1,
      "has_human_readable_license" : 1,
      "has_known_license_in_source_file" : 1,
      "has_license_in_source_file" : 1,
      "has_manifest" : 1,
      "has_meta_yml" : 1,
      "has_proper_version" : 1,
      "has_readme" : 1,
      "has_separate_license_file" : 0,
      "has_tests" : 1,
      "has_tests_in_t_dir" : 1,
      "has_version" : 1,
      "kwalitee" : "100.00",
      "manifest_matches_dist" : 1,
      "metayml_conforms_to_known_spec" : 1,
      "metayml_declares_perl_version" : 1,
      "metayml_has_license" : 1,
      "metayml_has_provides" : 0,
      "metayml_has_repository_resource" : 1,
      "metayml_is_parsable" : 1,
      "no_abstract_stub_in_pod" : 1,
      "no_broken_auto_install" : 1,
      "no_broken_module_install" : 1,
      "no_dot_dirs" : 1,
      "no_dot_underscore_files" : 1,
      "no_generated_files" : 1,
      "no_invalid_versions" : 1,
      "no_local_dirs" : 1,
      "no_mymeta_files" : 1,
      "no_pax_headers" : 1,
      "no_pod_errors" : 1,
      "no_stdin_for_prompting" : 1,
      "no_symlinks" : 1,
      "package_version_matches_dist_version" : 1,
      "portable_filenames" : 1,
      "proper_libs" : 1,
      "use_strict" : 1,
      "use_warnings" : 1,
      "valid_signature" : 1
   },
   "latest_mtime" : 1397866284,
   "license" : "perl defined in META.yml",
   "license_file" : "lib/UNIVERSAL/require.pm",
   "license_from_yaml" : "perl",
   "license_in_pod" : 1,
   "license_type" : "Perl_5",
   "licenses" : {
      "Perl_5" : [
         "lib/UNIVERSAL/require.pm"
      ]
   },
   "manifest_matches_dist" : 1,
   "meta_yml" : {
      "abstract" : "require() modules from a variable",
      "author" : [
         "Michael G Schwern <schwern@pobox.com>"
      ],
      "build_requires" : {
         "ExtUtils::MakeMaker" : "0"
      },
      "configure_requires" : {
         "ExtUtils::MakeMaker" : "0"
      },
      "dynamic_config" : "1",
      "generated_by" : "ExtUtils::MakeMaker version 6.94, CPAN::Meta::Converter version 2.133380",
      "license" : "perl",
      "meta-spec" : {
         "url" : "http://module-build.sourceforge.net/META-spec-v1.4.html",
         "version" : "1.4"
      },
      "name" : "UNIVERSAL-require",
      "no_index" : {
         "directory" : [
            "t",
            "inc"
         ],
         "package" : [
            "UNIVERSAL"
         ]
      },
      "requires" : {
         "Carp" : "0",
         "Test::More" : "0.47",
         "perl" : "5.006"
      },
      "resources" : {
         "license" : "http://dev.perl.org/licenses/",
         "repository" : "git://github.com/neilbowers/UNIVERSAL-require.git"
      },
      "version" : "0.17"
   },
   "metayml_is_parsable" : 1,
   "modules" : [
      {
         "file" : "lib/UNIVERSAL/require.pm",
         "in_basedir" : 0,
         "in_lib" : 1,
         "module" : "UNIVERSAL::require"
      }
   ],
   "no_index" : "^inc/;^t/",
   "no_pax_headers" : 1,
   "package" : "UNIVERSAL-require-0.17.tar.gz",
   "prereq" : [
      {
         "is_prereq" : 1,
         "requires" : "Carp",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_build_prereq" : 1,
         "requires" : "ExtUtils::MakeMaker",
         "type" : "build_requires",
         "version" : "0"
      },
      {
         "requires" : "ExtUtils::MakeMaker",
         "type" : "configure_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "perl",
         "type" : "runtime_requires",
         "version" : "5.006"
      },
      {
         "is_prereq" : 1,
         "requires" : "Test::More",
         "type" : "runtime_requires",
         "version" : "0.47"
      }
   ],
   "released_epoch" : 1397866298,
   "size_packed" : 5699,
   "size_unpacked" : 13388,
   "uses" : {
      "required_in_code" : {
         "UNIVERSAL" : 1
      },
      "required_in_eval_in_tests" : {
         "UNIVERSAL" : 1
      },
      "used_in_code" : {
         "5.006" : 1,
         "Carp" : 1,
         "strict" : 1,
         "vars" : 1,
         "warnings" : 1
      },
      "used_in_config" : {
         "ExtUtils::MakeMaker" : 1
      },
      "used_in_tests" : {
         "Test::More" : 3,
         "lib" : 2,
         "strict" : 1
      }
   },
   "valid_signature" : -1,
   "version" : "0.17",
   "versions" : {
      "lib/UNIVERSAL/require.pm" : {
         "UNIVERSAL::require" : "0.17"
      }
   },
   "vname" : "UNIVERSAL-require-0.17"
}