UR

Errors

UR-0.38.1 has the following 6 errors.

CategoryError
consistent_version0.02,0.31,0.38,1.05,2
meta_yml_conforms_to_known_spec'' for 'CGI::Application' is not a valid version. (requires -> CGI::Application) [Validation: 1.4];'' for 'Carp' is not a valid version. (requires -> Carp) [Validation: 1.4];'' for 'Class::Inspector' is not a valid version. (requires -> Class::Inspector) [Validation: 1.4];'' for 'Date::Format' is not a valid version. (requires -> Date::Format) [Validation: 1.4];'' for 'JSON' is not a valid version. (requires -> JSON) [Validation: 1.4];'' for 'Net::HTTPServer' is not a valid version. (requires -> Net::HTTPServer) [Validation: 1.4];'' for 'Path::Class' is not a valid version. (requires -> Path::Class) [Validation: 1.4];'' for 'Test::Fork' is not a valid version. (requires -> Test::Fork) [Validation: 1.4];'' for 'URI::Escape' is not a valid version. (requires -> URI::Escape) [Validation: 1.4];'' for 'XML::Dumper' is not a valid version. (requires -> XML::Dumper) [Validation: 1.4];'' for 'XML::Generator' is not a valid version. (requires -> XML::Generator) [Validation: 1.4];'' for 'XML::Simple' is not a valid version. (requires -> XML::Simple) [Validation: 1.4];'' for 'YAML' is not a valid version. (requires -> YAML) [Validation: 1.4];'' for 'version' is not a valid version. (requires -> version) [Validation: 1.4];Expected a list structure (author) [Validation: 1.4];Missing mandatory field, 'author' (author) [Validation: 1.4]
missing_prereqsGtk-Perl,Test-MockObject,Tk,XML-LibXML,XML-LibXSLT
no_pod_errorsUR-0.38/lib/UR/ObjectDeprecated.pm -- Around line 342: '=item' outside of any '=over' =over without closing =back UR-0.38/lib/UR/ModuleConfig.pm -- Around line 90: =over without closing =back UR-0.38/lib/UR/ModuleBase.pm -- Around line 37: You can't have =items (as at line 54) unless the first thing after the =over is an =itemAround line 771: =back without =over UR-0.38/lib/UR/Context.pm -- Around line 3702: Expected text after =item, not a number UR-0.38/lib/UR/Util.pm -- Around line 530: You forgot a '=back' before '=head1' You forgot a '=back' before '=head1' UR-0.38/lib/UR/DataSource.pod -- Around line 242: You forgot a '=back' before '=head1' UR-0.38/lib/UR/Namespace/Command/Test/Run.pm -- Around line 1022: You forgot a '=back' before '=head1'Around line 1024: '=item' outside of any '=over' =over without closing =back UR-0.38/lib/UR/Namespace/Command/Update/ClassesFromDb.pm -- Around line 587: =cut found outside a pod block. Skipping to next block.Around line 629: =cut found outside a pod block. Skipping to next block. UR-0.38/lib/UR/Context/Process.pm -- Around line 75: You can't have =items (as at line 79) unless the first thing after the =over is an =item UR-0.38/lib/UR/Object/Type.pm -- Around line 588: You forgot a '=back' before '=head1'Around line 590: '=item' outside of any '=over' UR-0.38/lib/UR/Object/Type.pod -- Around line 417: You forgot a '=back' before '=head1'Around line 419: '=item' outside of any '=over' UR-0.38/lib/UR/Object/Type/Initializer.pod -- Around line 269: You forgot a '=back' before '=head2'Around line 338: You forgot a '=back' before '=head3'Around line 340: '=item' outside of any '=over'
use_strictUR::Object::Command::List::Style
use_warningsUR::Object::Command::List::Style