Kwalitee Issues

prereq_matches_use

List all used modules in META.yml requires

Error:

  • Carp
  • Class::Load

use_strict

Add 'use strict' (or its equivalents) to all modules, or convince us that your favorite module is well-known enough and people can easily see the modules are strictly written.

Error: WWW::Asana, WWW::Asana::Error, WWW::Asana::Project, WWW::Asana::Request, WWW::Asana::Response, WWW::Asana::Role::CanCreate, WWW::Asana::Role::CanReload, WWW::Asana::Role::CanUpdate, WWW::Asana::Role::HasClient, WWW::Asana::Role::HasFollowers, WWW::Asana::Role::HasResponse, WWW::Asana::Role::HasStories, WWW::Asana::Role::NewFromResponse, WWW::Asana::Story, WWW::Asana::Tag, WWW::Asana::Task, WWW::Asana::User, WWW::Asana::Workspace

meta_yml_declares_perl_version

If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.

use_warnings

Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: WWW::Asana, WWW::Asana::Error, WWW::Asana::Project, WWW::Asana::Request, WWW::Asana::Response, WWW::Asana::Role::CanCreate, WWW::Asana::Role::CanReload, WWW::Asana::Role::CanUpdate, WWW::Asana::Role::HasClient, WWW::Asana::Role::HasFollowers, WWW::Asana::Role::HasResponse, WWW::Asana::Role::HasStories, WWW::Asana::Role::NewFromResponse, WWW::Asana::Story, WWW::Asana::Tag, WWW::Asana::Task, WWW::Asana::User, WWW::Asana::Workspace

build_prereq_matches_use

List all modules used in the test suite in META.yml build_requires

Error:

  • DateTime
  • DateTime::Duration
  • strict
  • warnings

meta_yml_has_provides

Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.

Modules

Name Abstract Version View
WWW::Asana Client Class for accessing Asana API 0.003 metacpan
WWW::Asana::Error Asana Error Class 0.003 metacpan
WWW::Asana::Project Asana Project Class 0.003 metacpan
WWW::Asana::Request Asana Request Class 0.003 metacpan
WWW::Asana::Response Asana Response Class 0.003 metacpan
WWW::Asana::Role::CanCreate Role for Asana classes which can be created 0.003 metacpan
WWW::Asana::Role::CanReload Role for Asana classes which can be reloaded 0.003 metacpan
WWW::Asana::Role::CanUpdate Role for Asana classes which can be updated 0.003 metacpan
WWW::Asana::Role::HasClient Role for a class which has a WWW::Asana client 0.003 metacpan
WWW::Asana::Role::HasFollowers Role for a class which has followers 0.003 metacpan
WWW::Asana::Role::HasResponse 0.003 metacpan
WWW::Asana::Role::HasStories Role for Asana classes which have stories 0.003 metacpan
WWW::Asana::Role::NewFromResponse Role which implements new_from_response for Asana classes 0.003 metacpan
WWW::Asana::Story Asana Story Class 0.003 metacpan
WWW::Asana::Tag Asana Tag Class 0.003 metacpan
WWW::Asana::Task Asana Task Class 0.003 metacpan
WWW::Asana::User Asana User Class 0.003 metacpan
WWW::Asana::Workspace Asana Workspace Class 0.003 metacpan

Other Files

Changes metacpan
MANIFEST metacpan
META.json metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan
dist.ini metacpan