Kwalitee Issues

no_pax_headers

If you use Mac OS X >= 10.6, use gnu tar (/usr/bin/gnutar) to avoid PAX headers. It's also important to rename (shorten) long file names (>= 100 characters) in the distribution.

Error: PaxHeader/WWW-Salesforce-0.25,PaxHeader/WWW-Salesforce-0.25,WWW-Salesforce-0.25/PaxHeader/Changes,WWW-Salesforce-0.25/PaxHeader/Changes,WWW-Salesforce-0.25/PaxHeader/lib,WWW-Salesforce-0.25/PaxHeader/lib,WWW-Salesforce-0.25/PaxHeader/Makefile.PL,WWW-Salesforce-0.25/PaxHeader/Makefile.PL,WWW-Salesforce-0.25/PaxHeader/MANIFEST,WWW-Salesforce-0.25/PaxHeader/MANIFEST,WWW-Salesforce-0.25/PaxHeader/META.json,WWW-Salesforce-0.25/PaxHeader/META.json,WWW-Salesforce-0.25/PaxHeader/META.yml,WWW-Salesforce-0.25/PaxHeader/META.yml,WWW-Salesforce-0.25/PaxHeader/README,WWW-Salesforce-0.25/PaxHeader/README,WWW-Salesforce-0.25/PaxHeader/t,WWW-Salesforce-0.25/PaxHeader/t,WWW-Salesforce-0.25/t/PaxHeader/pod-coverage.t,WWW-Salesforce-0.25/t/PaxHeader/pod-coverage.t,WWW-Salesforce-0.25/t/PaxHeader/pod.t,WWW-Salesforce-0.25/t/PaxHeader/pod.t,WWW-Salesforce-0.25/t/PaxHeader/WWW-Salesforce.t,WWW-Salesforce-0.25/t/PaxHeader/WWW-Salesforce.t,WWW-Salesforce-0.25/lib/PaxHeader/WWW,WWW-Salesforce-0.25/lib/PaxHeader/WWW,WWW-Salesforce-0.25/lib/WWW/PaxHeader/Salesforce,WWW-Salesforce-0.25/lib/WWW/PaxHeader/Salesforce,WWW-Salesforce-0.25/lib/WWW/PaxHeader/Salesforce.pm,WWW-Salesforce-0.25/lib/WWW/PaxHeader/Salesforce.pm,WWW-Salesforce-0.25/lib/WWW/Salesforce/PaxHeader/Constants.pm,WWW-Salesforce-0.25/lib/WWW/Salesforce/PaxHeader/Constants.pm,WWW-Salesforce-0.25/lib/WWW/Salesforce/PaxHeader/Deserializer.pm,WWW-Salesforce-0.25/lib/WWW/Salesforce/PaxHeader/Deserializer.pm,WWW-Salesforce-0.25/lib/WWW/Salesforce/PaxHeader/Serializer.pm,WWW-Salesforce-0.25/lib/WWW/Salesforce/PaxHeader/Serializer.pm,WWW-Salesforce-0.25/lib/WWW/Salesforce/PaxHeader/Simple.pm,WWW-Salesforce-0.25/lib/WWW/Salesforce/PaxHeader/Simple.pm

meta_yml_declares_perl_version

If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.

no_invalid_versions

Fix the version numbers so that version::is_lax($version) returns true.

Error:

  • lib/WWW/Salesforce/Simple.pm: HASH(0x854adf8)

has_separate_license_file

This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.

meta_yml_has_provides

Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.

Modules

Name Abstract Version View
WWW::Salesforce this class provides a simple abstraction layer between SOAP::Lite and Salesforce.com. 0.25 metacpan
WWW::Salesforce::Constants metacpan
WWW::Salesforce::Deserializer metacpan
WWW::Salesforce::Serializer metacpan
WWW::Salesforce::Simple metacpan

Other Files

Changes metacpan
MANIFEST metacpan
META.json metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan