Weather-Google

Metadata

Analyzed metadata and errors of Weather-Google.

{
   "abstracts" : {
      "Weather::Google" : "Perl interface to Google's Weather API"
   },
   "author" : "POSSUM",
   "buildfile_executable" : 0,
   "dir_lib" : "lib",
   "dir_t" : "t",
   "dirs_array" : [
      "lib",
      "lib/Weather",
      "t"
   ],
   "dist" : "Weather-Google",
   "dynamic_config" : 0,
   "error" : {},
   "extension" : "tar.gz",
   "extractable" : 1,
   "extracts_nicely" : 1,
   "file__build" : 0,
   "file_blib" : 0,
   "file_build" : 0,
   "file_build_pl" : "Build.PL",
   "file_changelog" : "Changes",
   "file_makefile" : 0,
   "file_makefile_pl" : "Makefile.PL",
   "file_manifest" : "MANIFEST",
   "file_meta_yml" : "META.yml",
   "file_pm_to_blib" : 0,
   "file_readme" : "README",
   "files_array" : [
      "README",
      "Build.PL",
      "Changes",
      "INSTALL",
      "Makefile.PL",
      "META.yml",
      "MANIFEST",
      "lib/Weather/Google.pm",
      "t/00-load.t",
      "t/01init.t",
      "t/03forecast_conditions.t",
      "t/02current_conditions.t",
      "t/pod-coverage.t",
      "t/05language.t",
      "t/04forecast_information.t",
      "t/pod.t"
   ],
   "files_hash" : {
      "Build.PL" : {
         "mtime" : 1252691222,
         "size" : 361,
         "used" : [
            "Module::Build",
            "strict",
            "warnings"
         ]
      },
      "Changes" : {
         "mtime" : 1252691222,
         "size" : 169
      },
      "INSTALL" : {
         "mtime" : 1252691222,
         "size" : 60
      },
      "MANIFEST" : {
         "mtime" : 1252691222,
         "size" : 246
      },
      "META.yml" : {
         "mtime" : 1252691222,
         "size" : 487
      },
      "Makefile.PL" : {
         "mtime" : 1252691222,
         "size" : 147,
         "used" : [
            "Module::Build::Compat"
         ]
      },
      "README" : {
         "mtime" : 1252691222,
         "size" : 9705
      },
      "lib/Weather/Google.pm" : {
         "license" : "Perl_5",
         "module" : "Weather::Google",
         "mtime" : 1252691222,
         "required_in_eval" : [
            "Encode"
         ],
         "size" : 13747,
         "used" : [
            "LWP::Simple",
            "XML::Simple",
            "constant",
            "strict",
            "warnings"
         ]
      },
      "t/00-load.t" : {
         "mtime" : 1252691222,
         "size" : 155,
         "used" : [
            "Test::More"
         ]
      },
      "t/01init.t" : {
         "mtime" : 1252691222,
         "size" : 546,
         "used" : [
            "Test::Simple",
            "Weather::Google",
            "strict",
            "warnings"
         ]
      },
      "t/02current_conditions.t" : {
         "mtime" : 1252691222,
         "size" : 897,
         "used" : [
            "Test::More",
            "Weather::Google",
            "strict",
            "warnings"
         ]
      },
      "t/03forecast_conditions.t" : {
         "mtime" : 1252691222,
         "size" : 1885,
         "used" : [
            "Test::More",
            "Weather::Google",
            "strict",
            "warnings"
         ]
      },
      "t/04forecast_information.t" : {
         "mtime" : 1252691222,
         "size" : 832,
         "used" : [
            "Test::More",
            "Weather::Google",
            "strict",
            "warnings"
         ]
      },
      "t/05language.t" : {
         "mtime" : 1252691222,
         "size" : 876,
         "used" : [
            "Test::More",
            "Test::Warn",
            "Weather::Google",
            "strict",
            "warnings"
         ]
      },
      "t/pod-coverage.t" : {
         "mtime" : 1252691222,
         "size" : 271,
         "used" : [
            "Test::More",
            "strict",
            "warnings"
         ],
         "used_in_eval" : [
            "Test::Pod::Coverage"
         ]
      },
      "t/pod.t" : {
         "mtime" : 1252691222,
         "size" : 232,
         "used" : [
            "Test::More",
            "strict",
            "warnings"
         ],
         "used_in_eval" : [
            "Test::Pod"
         ]
      }
   },
   "got_prereq_from" : "META.yml",
   "kwalitee" : {
      "buildtool_not_executable" : 1,
      "consistent_version" : 1,
      "easily_repackageable_by_debian" : 1,
      "easily_repackageable_by_fedora" : 1,
      "extractable" : 1,
      "extracts_nicely" : 1,
      "fits_fedora_license" : 1,
      "has_abstract_in_pod" : 1,
      "has_buildtool" : 1,
      "has_changelog" : 1,
      "has_human_readable_license" : 1,
      "has_known_license_in_source_file" : 1,
      "has_license_in_source_file" : 1,
      "has_manifest" : 1,
      "has_meta_yml" : 1,
      "has_proper_version" : 1,
      "has_readme" : 1,
      "has_separate_license_file" : 0,
      "has_tests" : 1,
      "has_tests_in_t_dir" : 1,
      "has_version" : 1,
      "kwalitee" : "97.56",
      "manifest_matches_dist" : 1,
      "metayml_conforms_to_known_spec" : 1,
      "metayml_declares_perl_version" : 0,
      "metayml_has_license" : 1,
      "metayml_has_provides" : 1,
      "metayml_is_parsable" : 1,
      "no_abstract_stub_in_pod" : 1,
      "no_broken_auto_install" : 1,
      "no_broken_module_install" : 1,
      "no_dot_dirs" : 1,
      "no_dot_underscore_files" : 1,
      "no_generated_files" : 1,
      "no_invalid_versions" : 1,
      "no_local_dirs" : 1,
      "no_mymeta_files" : 1,
      "no_pax_headers" : 1,
      "no_pod_errors" : 1,
      "no_stdin_for_prompting" : 1,
      "no_symlinks" : 1,
      "package_version_matches_dist_version" : 1,
      "portable_filenames" : 1,
      "proper_libs" : 1,
      "use_strict" : 1,
      "use_warnings" : 1,
      "valid_signature" : 1
   },
   "latest_mtime" : 1252691222,
   "license" : "perl defined in META.yml",
   "license_file" : "lib/Weather/Google.pm",
   "license_from_yaml" : "perl",
   "license_in_pod" : 1,
   "license_type" : "Perl_5",
   "licenses" : {
      "Perl_5" : [
         "lib/Weather/Google.pm"
      ]
   },
   "manifest_matches_dist" : 1,
   "meta_yml" : {
      "abstract" : "Perl interface to Google's Weather API",
      "author" : [],
      "build_requires" : {
         "Test::More" : "0",
         "Test::Pod" : "0",
         "Test::Simple" : "0"
      },
      "generated_by" : "Module::Build version 0.280801",
      "license" : "perl",
      "meta-spec" : {
         "url" : "http://module-build.sourceforge.net/META-spec-v1.2.html",
         "version" : "1.2"
      },
      "name" : "Weather-Google",
      "provides" : {
         "Weather::Google" : {
            "file" : "lib/Weather/Google.pm",
            "version" : "0.04"
         }
      },
      "requires" : {
         "LWP::Simple" : "0",
         "XML::Simple" : "0"
      },
      "resources" : {
         "license" : "http://dev.perl.org/licenses/"
      },
      "version" : "0.04"
   },
   "metayml_is_parsable" : 1,
   "modules" : [
      {
         "file" : "lib/Weather/Google.pm",
         "in_basedir" : 0,
         "in_lib" : 1,
         "module" : "Weather::Google"
      }
   ],
   "no_pax_headers" : 1,
   "package" : "Weather-Google-0.04.tar.gz",
   "prereq" : [
      {
         "is_prereq" : 1,
         "requires" : "XML::Simple",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_build_prereq" : 1,
         "requires" : "Test::More",
         "type" : "build_requires",
         "version" : "0"
      },
      {
         "is_prereq" : 1,
         "requires" : "LWP::Simple",
         "type" : "runtime_requires",
         "version" : "0"
      },
      {
         "is_build_prereq" : 1,
         "requires" : "Test::Pod",
         "type" : "build_requires",
         "version" : "0"
      },
      {
         "is_build_prereq" : 1,
         "requires" : "Test::Simple",
         "type" : "build_requires",
         "version" : "0"
      }
   ],
   "released_epoch" : 1252691397,
   "size_packed" : 8509,
   "size_unpacked" : 30616,
   "uses" : {
      "required_in_eval_in_code" : {
         "Encode" : 1
      },
      "used_in_code" : {
         "LWP::Simple" : 1,
         "XML::Simple" : 1,
         "constant" : 1,
         "strict" : 1,
         "warnings" : 1
      },
      "used_in_config" : {
         "Module::Build" : 1,
         "Module::Build::Compat" : 1,
         "strict" : 1,
         "warnings" : 1
      },
      "used_in_eval_in_tests" : {
         "Test::Pod" : 1,
         "Test::Pod::Coverage" : 1
      },
      "used_in_tests" : {
         "Test::More" : 7,
         "Test::Simple" : 1,
         "Test::Warn" : 1,
         "strict" : 7,
         "warnings" : 7
      }
   },
   "valid_signature" : -1,
   "version" : "0.04",
   "versions" : {
      "lib/Weather/Google.pm" : {
         "Weather::Google" : "0.04"
      }
   },
   "vname" : "Weather-Google-0.04"
}