Kwalitee Issues

manifest_matches_dist

Run a proper command ("make manifest" or "./Build manifest", maybe with a force option), or use a distribution builder to generate the MANIFEST. Or update MANIFEST manually.

Error:

  • MANIFEST (32) does not match dist (31):
  • Duplicates in MANIFEST: META.yml

use_strict

Add 'use strict' (or its equivalents) to all modules, or convince us that your favorite module is well-known enough and people can easily see the modules are strictly written.

Error: WebService::EveOnline::API::Character, WebService::EveOnline::API::Corporation, WebService::EveOnline::API::Journal, WebService::EveOnline::API::Map, WebService::EveOnline::API::Transactions, WebService::EveOnline::Base

consistent_version

Split the distribution, or fix the version numbers to make them consistent (use the highest version number to avoid version downgrade).

Error: 0.61,0.62

has_meta_json

Add a META.json to the distribution. Your buildtool should be able to autogenerate it.

meta_yml_declares_perl_version

If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.

meta_yml_has_license

Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.

use_warnings

Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: WebService::EveOnline::API::Account, WebService::EveOnline::API::Character, WebService::EveOnline::API::Corporation, WebService::EveOnline::API::Journal, WebService::EveOnline::API::Map, WebService::EveOnline::API::Transactions, WebService::EveOnline::Base

has_separate_license_file

This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.

meta_yml_has_provides

Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.

meta_yml_has_repository_resource

Add a 'repository' resource to the META.yml via 'meta_add' accessor (for Module::Build) or META_ADD parameter (for ExtUtils::MakeMaker).

Modules

Name Abstract Version View
WebService::EveOnline a wrapper intended to (eventually) provide a useful interface to the MMORPG game, "Eve Online" 0.62 metacpan
WebService::EveOnline::API::Account 0.61 metacpan
WebService::EveOnline::API::Character 0.61 metacpan
WebService::EveOnline::API::Corporation 0.61 metacpan
WebService::EveOnline::API::Journal 0.61 metacpan
WebService::EveOnline::API::Map 0.61 metacpan
WebService::EveOnline::API::Skills 0.62 metacpan
WebService::EveOnline::API::Transactions 0.61 metacpan
WebService::EveOnline::Base 0.62 metacpan
WebService::EveOnline::Cache provide a cache for use by WebService::EveOnline 0.61 metacpan

Other Files

Changes metacpan
MANIFEST metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan