Under maintenance.

Most probably CPANTS databases are being regenerated from scratch due to major changes in Kwalitee metrics or updates of relevant modules/perl. Usually this maintenance takes about a day or two, and some of the information may be old or missing tentatively. Sorry for the inconvenience.

Kwalitee Issues

no_mymeta_files

Update MANIFEST.SKIP to exclude MYMETA files. If you are lazy, add "#!install_default" in your MANIFEST.SKIP and update your ExtUtils::Manifest if necessary, then some of the most common files will be excluded.

use_strict

Add 'use strict' (or its equivalents) to all modules, or convince us that your favorite module is well-known enough and people can easily see the modules are strictly written.

Error: WebService::Simple::Yahoo::JP::API::Auctions, WebService::Simple::Yahoo::JP::API::Cert, WebService::Simple::Yahoo::JP::API::Chiebukuro, WebService::Simple::Yahoo::JP::API::Dir, WebService::Simple::Yahoo::JP::API::Jlp, WebService::Simple::Yahoo::JP::API::Map, WebService::Simple::Yahoo::JP::API::News, WebService::Simple::Yahoo::JP::API::Search, WebService::Simple::Yahoo::JP::API::Shopping

consistent_version

Split the distribution, or fix the version numbers to make them consistent (use the highest version number to avoid version downgrade).

Error: 0.01,0.11

has_meta_json

Add a META.json to the distribution. Your buildtool should be able to autogenerate it.

meta_yml_declares_perl_version

If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.

use_warnings

Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: WebService::Simple::Yahoo::JP::API::Auctions, WebService::Simple::Yahoo::JP::API::Cert, WebService::Simple::Yahoo::JP::API::Chiebukuro, WebService::Simple::Yahoo::JP::API::Dir, WebService::Simple::Yahoo::JP::API::Jlp, WebService::Simple::Yahoo::JP::API::Map, WebService::Simple::Yahoo::JP::API::News, WebService::Simple::Yahoo::JP::API::Search, WebService::Simple::Yahoo::JP::API::Shopping

has_separate_license_file

This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.

meta_yml_has_provides

Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.

meta_yml_has_repository_resource

Add a 'repository' resource to the META.yml via 'meta_add' accessor (for Module::Build) or META_ADD parameter (for ExtUtils::MakeMaker).

Modules

Name Abstract Version View
WebService::Simple::Yahoo::JP::API Simple Interface to Yahoo! JAPAN Web APIs 0.11 metacpan
WebService::Simple::Yahoo::JP::API::Auctions 0.01 metacpan
WebService::Simple::Yahoo::JP::API::Cert 0.01 metacpan
WebService::Simple::Yahoo::JP::API::Chiebukuro 0.01 metacpan
WebService::Simple::Yahoo::JP::API::Dir 0.01 metacpan
WebService::Simple::Yahoo::JP::API::Jlp Search Subclass for WebService::Simple::Yahoo::JP::API. 0.01 metacpan
WebService::Simple::Yahoo::JP::API::Map 0.01 metacpan
WebService::Simple::Yahoo::JP::API::News 0.01 metacpan
WebService::Simple::Yahoo::JP::API::Search Search Subclass for WebService::Simple::Yahoo::JP::API. 0.01 metacpan
WebService::Simple::Yahoo::JP::API::Shopping 0.01 metacpan

Other Files

Changes metacpan
MANIFEST metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan