Kwalitee Issues

prereq_matches_use

List all used modules in META.yml requires

Error:

  • Lucy::Analysis::PolyAnalyzer
  • Lucy::Index::Indexer
  • Lucy::Index::PolyReader
  • Lucy::Plan::FullTextType
  • Lucy::Plan::Schema
  • Lucy::Search::IndexSearcher
  • Lucy::Search::QueryParser
  • Search::InvertedIndex
  • URI::Escape
  • Wiki::Toolkit::Formatter::Pod
  • Wiki::Toolkit::Formatter::UseMod

consistent_version

Split the distribution, or fix the version numbers to make them consistent (use the highest version number to avoid version downgrade).

Error: 0.01,0.02,0.03,0.04,0.05,0.06,0.07,0.09,0.10,0.11,0.31,0.84

meta_yml_declares_perl_version

If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.

meta_yml_has_license

Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.

use_warnings

Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: Wiki::Toolkit, Wiki::Toolkit::Feed::Atom, Wiki::Toolkit::Feed::Listing, Wiki::Toolkit::Feed::RSS, Wiki::Toolkit::Formatter::Default, Wiki::Toolkit::Formatter::Multiple, Wiki::Toolkit::Formatter::WikiLinkFormatterParent, Wiki::Toolkit::Plugin, Wiki::Toolkit::Search::Base, Wiki::Toolkit::Search::DBIxFTS, Wiki::Toolkit::Search::Lucy, Wiki::Toolkit::Search::Plucene, Wiki::Toolkit::Search::SII, Wiki::Toolkit::Setup::DBIxFTSMySQL, Wiki::Toolkit::Setup::Database, Wiki::Toolkit::Setup::MySQL, Wiki::Toolkit::Setup::Pg, Wiki::Toolkit::Setup::SII, Wiki::Toolkit::Setup::SQLite, Wiki::Toolkit::Store::Database, Wiki::Toolkit::Store::MySQL, Wiki::Toolkit::Store::Pg, Wiki::Toolkit::Store::SQLite, Wiki::Toolkit::TestConfig::Utilities, Wiki::Toolkit::TestLib

build_prereq_matches_use

List all modules used in the test suite in META.yml build_requires

Error:

  • URI::Escape

has_separate_license_file

This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.

meta_yml_has_provides

Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.

meta_yml_has_repository_resource

Add a 'repository' resource to the META.yml via 'meta_add' accessor (for Module::Build) or META_ADD parameter (for ExtUtils::MakeMaker).

Modules

Name Abstract Version View
Wiki::Toolkit A toolkit for building Wikis. 0.84 metacpan
Wiki::Toolkit::Feed::Atom A Wiki::Toolkit plugin to output RecentChanges Atom. 0.03 metacpan
Wiki::Toolkit::Feed::Listing parent class for Feeds from Wiki::Toolkit. metacpan
Wiki::Toolkit::Feed::RSS Output RecentChanges RSS for Wiki::Toolkit. 0.11 metacpan
Wiki::Toolkit::Formatter::Default A formatter for Wiki::Toolkit. 0.02 metacpan
Wiki::Toolkit::Formatter::Multiple Allows a Wiki::Toolkit wiki to use more than one formatter. 0.02 metacpan
Wiki::Toolkit::Formatter::WikiLinkFormatterParent The parent of Wiki::Toolkit formatters that work with Wiki Links. 0.01 metacpan
Wiki::Toolkit::Plugin A base class for Wiki::Toolkit plugins. 0.04 metacpan
Wiki::Toolkit::Search::Base Base class for Wiki::Toolkit search plugins. 0.01 metacpan
Wiki::Toolkit::Search::DBIxFTS DBIx::FullTextSearch search plugin for Wiki::Toolkit. 0.05 metacpan
Wiki::Toolkit::Search::Lucy Use Lucy to search your Wiki::Toolkit wiki. 0.03 metacpan
Wiki::Toolkit::Search::Plucene Use Plucene to search your Wiki::Toolkit wiki. 0.02 metacpan
Wiki::Toolkit::Search::SII Search::InvertedIndex plugin for Wiki::Toolkit. 0.09 metacpan
Wiki::Toolkit::Setup::DBIxFTSMySQL set up fulltext indexes for Wiki::Toolkit 0.04 metacpan
Wiki::Toolkit::Setup::Database parent class for database storage setup classes for Wiki::Toolkit 0.09 metacpan
Wiki::Toolkit::Setup::MySQL Set up tables for a Wiki::Toolkit store in a MySQL database. 0.10 metacpan
Wiki::Toolkit::Setup::Pg Set up tables for a Wiki::Toolkit store in a Postgres database. 0.10 metacpan
Wiki::Toolkit::Setup::SII Set up Search::InvertedIndex indexes for Wiki::Toolkit 0.03 metacpan
Wiki::Toolkit::Setup::SQLite Set up tables for a Wiki::Toolkit store in a SQLite database. 0.10 metacpan
Wiki::Toolkit::Store::Database parent class for database storage backends for Wiki::Toolkit 0.31 metacpan
Wiki::Toolkit::Store::MySQL MySQL storage backend for Wiki::Toolkit 0.05 metacpan
Wiki::Toolkit::Store::Pg Postgres storage backend for Wiki::Toolkit 0.07 metacpan
Wiki::Toolkit::Store::SQLite SQLite storage backend for Wiki::Toolkit 0.06 metacpan
Wiki::Toolkit::TestConfig::Utilities Utilities for testing Wiki::Toolkit things (deprecated). 0.06 metacpan
Wiki::Toolkit::TestLib Utilities for writing Wiki::Toolkit tests. 0.05 metacpan

Other Files

Changes metacpan
MANIFEST metacpan
META.json metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan