Kwalitee Issues

no_pax_headers

If you use Mac OS X >= 10.6, use gnu tar (/usr/bin/gnutar) to avoid PAX headers. It's also important to rename (shorten) long file names (>= 100 characters) in the distribution.

Error: PaxHeader/Wiki-Toolkit-Formatter-UseMod-0.25,PaxHeader/Wiki-Toolkit-Formatter-UseMod-0.25,Wiki-Toolkit-Formatter-UseMod-0.25/PaxHeader/Changes,Wiki-Toolkit-Formatter-UseMod-0.25/PaxHeader/Changes,Wiki-Toolkit-Formatter-UseMod-0.25/PaxHeader/lib,Wiki-Toolkit-Formatter-UseMod-0.25/PaxHeader/lib,Wiki-Toolkit-Formatter-UseMod-0.25/PaxHeader/Makefile.PL,Wiki-Toolkit-Formatter-UseMod-0.25/PaxHeader/Makefile.PL,Wiki-Toolkit-Formatter-UseMod-0.25/PaxHeader/MANIFEST,Wiki-Toolkit-Formatter-UseMod-0.25/PaxHeader/MANIFEST,Wiki-Toolkit-Formatter-UseMod-0.25/PaxHeader/META.json,Wiki-Toolkit-Formatter-UseMod-0.25/PaxHeader/META.json,Wiki-Toolkit-Formatter-UseMod-0.25/PaxHeader/META.yml,Wiki-Toolkit-Formatter-UseMod-0.25/PaxHeader/META.yml,Wiki-Toolkit-Formatter-UseMod-0.25/PaxHeader/README,Wiki-Toolkit-Formatter-UseMod-0.25/PaxHeader/README,Wiki-Toolkit-Formatter-UseMod-0.25/PaxHeader/SIGNATURE,Wiki-Toolkit-Formatter-UseMod-0.25/PaxHeader/SIGNATURE,Wiki-Toolkit-Formatter-UseMod-0.25/PaxHeader/t,Wiki-Toolkit-Formatter-UseMod-0.25/PaxHeader/t,Wiki-Toolkit-Formatter-UseMod-0.25/t/PaxHeader/default_links.t,Wiki-Toolkit-Formatter-UseMod-0.25/t/PaxHeader/default_links.t,Wiki-Toolkit-Formatter-UseMod-0.25/t/PaxHeader/encode-node-names.t,Wiki-Toolkit-Formatter-UseMod-0.25/t/PaxHeader/encode-node-names.t,Wiki-Toolkit-Formatter-UseMod-0.25/t/PaxHeader/external_links.t,Wiki-Toolkit-Formatter-UseMod-0.25/t/PaxHeader/external_links.t,Wiki-Toolkit-Formatter-UseMod-0.25/t/PaxHeader/linebreaks.t,Wiki-Toolkit-Formatter-UseMod-0.25/t/PaxHeader/linebreaks.t,Wiki-Toolkit-Formatter-UseMod-0.25/t/PaxHeader/links.t,Wiki-Toolkit-Formatter-UseMod-0.25/t/PaxHeader/links.t,Wiki-Toolkit-Formatter-UseMod-0.25/t/PaxHeader/lists.t,Wiki-Toolkit-Formatter-UseMod-0.25/t/PaxHeader/lists.t,Wiki-Toolkit-Formatter-UseMod-0.25/t/PaxHeader/macros.t,Wiki-Toolkit-Formatter-UseMod-0.25/t/PaxHeader/macros.t,Wiki-Toolkit-Formatter-UseMod-0.25/t/PaxHeader/macros_with_wiki_passed.t,Wiki-Toolkit-Formatter-UseMod-0.25/t/PaxHeader/macros_with_wiki_passed.t,Wiki-Toolkit-Formatter-UseMod-0.25/t/PaxHeader/munge_node_name.t,Wiki-Toolkit-Formatter-UseMod-0.25/t/PaxHeader/munge_node_name.t,Wiki-Toolkit-Formatter-UseMod-0.25/t/PaxHeader/node-suffix.t,Wiki-Toolkit-Formatter-UseMod-0.25/t/PaxHeader/node-suffix.t,Wiki-Toolkit-Formatter-UseMod-0.25/t/PaxHeader/paragraphs.t,Wiki-Toolkit-Formatter-UseMod-0.25/t/PaxHeader/paragraphs.t,Wiki-Toolkit-Formatter-UseMod-0.25/t/PaxHeader/pod.t,Wiki-Toolkit-Formatter-UseMod-0.25/t/PaxHeader/pod.t,Wiki-Toolkit-Formatter-UseMod-0.25/t/PaxHeader/tables.t,Wiki-Toolkit-Formatter-UseMod-0.25/t/PaxHeader/tables.t,Wiki-Toolkit-Formatter-UseMod-0.25/t/PaxHeader/twf-bug.t,Wiki-Toolkit-Formatter-UseMod-0.25/t/PaxHeader/twf-bug.t,Wiki-Toolkit-Formatter-UseMod-0.25/t/PaxHeader/usemod.t,Wiki-Toolkit-Formatter-UseMod-0.25/t/PaxHeader/usemod.t,Wiki-Toolkit-Formatter-UseMod-0.25/lib/PaxHeader/Wiki,Wiki-Toolkit-Formatter-UseMod-0.25/lib/PaxHeader/Wiki,Wiki-Toolkit-Formatter-UseMod-0.25/lib/Wiki/PaxHeader/Toolkit,Wiki-Toolkit-Formatter-UseMod-0.25/lib/Wiki/PaxHeader/Toolkit,Wiki-Toolkit-Formatter-UseMod-0.25/lib/Wiki/Toolkit/PaxHeader/Formatter,Wiki-Toolkit-Formatter-UseMod-0.25/lib/Wiki/Toolkit/PaxHeader/Formatter,Wiki-Toolkit-Formatter-UseMod-0.25/lib/Wiki/Toolkit/Formatter/PaxHeader/UseMod.pm,Wiki-Toolkit-Formatter-UseMod-0.25/lib/Wiki/Toolkit/Formatter/PaxHeader/UseMod.pm

prereq_matches_use

List all used modules in META.yml requires

Error:

  • strict
  • vars

meta_yml_declares_perl_version

If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.

meta_yml_has_license

Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.

use_warnings

Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: Wiki::Toolkit::Formatter::UseMod

build_prereq_matches_use

List all modules used in the test suite in META.yml build_requires

Error:

  • strict

has_separate_license_file

This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.

meta_yml_has_provides

Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.

meta_yml_has_repository_resource

Add a 'repository' resource to the META.yml via 'meta_add' accessor (for Module::Build) or META_ADD parameter (for ExtUtils::MakeMaker).

Modules

Name Abstract Version View
Wiki::Toolkit::Formatter::UseMod UseModWiki-style formatting for Wiki::Toolkit 0.25 metacpan

Other Files

Changes metacpan
MANIFEST metacpan
META.json metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan