Kwalitee Issues

manifest_matches_dist

Run a proper command ("make manifest" or "./Build manifest", maybe with a force option), or use a distribution builder to generate the MANIFEST. Or update MANIFEST manually.

Error:

  • MANIFEST (7) does not match dist (13):
  • Missing in MANIFEST: ._Changes, ._MANIFEST, ._Makefile.PL, ._README, lib/WoW/._Wiki.pm, t/._WoW-Wiki.t

no_pod_errors

Remove the POD errors. You can check for POD errors automatically by including Test::Pod to your test suite.

Error: WoW-Wiki-0.01/lib/WoW/Wiki.pm -- Around line 46: =cut found outside a pod block. Skipping to next block.Around line 50: =cut found outside a pod block. Skipping to next block.Around line 84: =cut found outside a pod block. Skipping to next block.Around line 86: =cut found outside a pod block. Skipping to next block.Around line 116: =cut found outside a pod block. Skipping to next block.Around line 118: =cut found outside a pod block. Skipping to next block.Around line 151: =cut found outside a pod block. Skipping to next block.Around line 153: =cut found outside a pod block. Skipping to next block.Around line 181: =cut found outside a pod block. Skipping to next block.Around line 183: =cut found outside a pod block. Skipping to next block.Around line 238: =cut found outside a pod block. Skipping to next block.Around line 240: =cut found outside a pod block. Skipping to next block.

use_strict

Add 'use strict' (or its equivalents) to all modules, or convince us that your favorite module is well-known enough and people can easily see the modules are strictly written.

Error: WoW::._Wiki

has_meta_json

Add a META.json to the distribution. Your buildtool should be able to autogenerate it.

meta_yml_declares_perl_version

If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.

meta_yml_has_license

Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.

no_dot_underscore_files

If you use Mac OS X, set COPYFILE_DISABLE (for OS 10.5 and better) or COPY_EXTENDED_ATTRIBUTES_DISABLE (for OS 10.4) environmental variable to true to exclude dot underscore files from a distribution.

Error:

  • ._Changes
  • ._MANIFEST
  • ._Makefile.PL
  • ._README
  • lib/WoW/._Wiki.pm
  • t/._WoW-Wiki.t

use_warnings

Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: WoW::._Wiki

has_separate_license_file

This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.

meta_yml_has_provides

Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.

meta_yml_has_repository_resource

Add a 'repository' resource to the META.yml via 'meta_add' accessor (for Module::Build) or META_ADD parameter (for ExtUtils::MakeMaker).

Modules

Name Abstract Version View
WoW::Wiki Perl extension to parse WoW wikki markup 0.01 metacpan

Other Files

Changes metacpan
MANIFEST metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan