Kwalitee Issues


Change the permissions of Build.PL/Makefile.PL to not-executable.


Add a README to the distribution. It should contain a quick description of your module and how to install it.


Add a META.json to the distribution. Your buildtool should be able to autogenerate it.


If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.


Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: YAX, YAX::Builder, YAX::Constants, YAX::Document, YAX::Element, YAX::Fragment, YAX::Node, YAX::Parser, YAX::Query, YAX::Text


This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.


Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.


Add a 'repository' resource to the META.yml via 'meta_add' accessor (for Module::Build) or META_ADD parameter (for ExtUtils::MakeMaker).


Name Abstract Version View
YAX Yet Another XML library 0.03 metacpan
YAX::Builder Declarative programmatic DOM construction metacpan
YAX::Constants constants used by YAX metacpan
YAX::Document A DOM document object for YAX metacpan
YAX::Element a DOM element node metacpan
YAX::Fragment YAX document fragment node metacpan
YAX::Node metacpan
YAX::Parser fast pure Perl tree and stream parser metacpan
YAX::Query Query the YAX DOM metacpan
YAX::Text a DOM text node metacpan

Other Files

Changes metacpan
MANIFEST metacpan
META.yml metacpan
Makefile.PL metacpan