Kwalitee Issues

has_license_in_source_file

Add =head1 LICENSE and the text of the license to the main module in your code.

no_pod_errors

Remove the POD errors. You can check for POD errors automatically by including Test::Pod to your test suite.

Error: asterisk-perl-1.08/lib/Asterisk/Astman.pm -- Around line 17: =over is the last thing in the document?! asterisk-perl-1.08/lib/Asterisk/Conf/IAX.pm -- Around line 17: =over is the last thing in the document?! asterisk-perl-1.08/lib/Asterisk/Conf/MeetMe.pm -- Around line 17: =over is the last thing in the document?! asterisk-perl-1.08/lib/Asterisk/Conf/Zapata.pm -- Around line 17: =over is the last thing in the document?! asterisk-perl-1.08/lib/Asterisk/Extension.pm -- Around line 17: =over is the last thing in the document?! asterisk-perl-1.08/lib/Asterisk/Zapata.pm -- Around line 17: =over is the last thing in the document?!

use_strict

Add 'use strict' (or its equivalents) to all modules, or convince us that your favorite module is well-known enough and people can easily see the modules are strictly written.

Error: Asterisk, Asterisk::Astman, Asterisk::Conf, Asterisk::Conf::IAX, Asterisk::Conf::MeetMe, Asterisk::Conf::Zapata, Asterisk::Extension, Asterisk::QCall, Asterisk::Voicemail, Asterisk::Zapata

consistent_version

Split the distribution, or fix the version numbers to make them consistent (use the highest version number to avoid version downgrade).

Error: 0.01,0.02,1.08

has_known_license_in_source_file

Add =head1 LICENSE and/or the proper text of the well-known license to the main module in your code.

meta_yml_declares_perl_version

If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.

meta_yml_has_license

Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.

no_invalid_versions

Fix the version numbers so that version::is_lax($version) returns true.

Error:

  • lib/Asterisk/AGI.pm: HASH(0x6f1a0d0)

use_warnings

Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: Asterisk, Asterisk::Astman, Asterisk::Conf, Asterisk::Conf::IAX, Asterisk::Conf::MeetMe, Asterisk::Conf::Zapata, Asterisk::Extension, Asterisk::QCall, Asterisk::Voicemail, Asterisk::Zapata

meta_yml_has_provides

Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.

Modules

Name Abstract Version View
Asterisk 1.08 metacpan
Asterisk::AGI Simple Asterisk Gateway Interface Class metacpan
Asterisk::Astman Interface to the astman port 0.01 metacpan
Asterisk::Conf 0.01 metacpan
Asterisk::Conf::IAX 0.01 metacpan
Asterisk::Conf::MeetMe 0.01 metacpan
Asterisk::Conf::Zapata 0.01 metacpan
Asterisk::Extension Stuff to deal with asterisk extension config 0.01 metacpan
Asterisk::Manager Asterisk Manager Interface 0.01 metacpan
Asterisk::Outgoing Create outgoing call queue file 0.02 metacpan
Asterisk::QCall 0.01 metacpan
Asterisk::Voicemail Stuff to deal with asterisk voicemail 0.01 metacpan
Asterisk::Zapata Zapata stuff 0.01 metacpan

Provides

Name File View
asterisk::perl lib/Asterisk.pm metacpan

Other Files

MANIFEST metacpan
META.json metacpan
META.yml metacpan
Makefile.PL metacpan
README metacpan
README.md metacpan