Kwalitee Issues

distname_matches_name_in_meta

Use a proper tool to make a distribution. You might also need to fix META files if you keep them in the repository.

Error: Class-AutoClass

has_readme

Add a README to the distribution. It should contain a quick description of your module and how to install it.

manifest_matches_dist

Run a proper command ("make manifest" or "./Build manifest", maybe with a force option), or use a distribution builder to generate the MANIFEST. Or update MANIFEST manually.

Error:

  • MANIFEST (47) does not match dist (70):
  • Missing in MANIFEST: .#Changes.1.10, .#Changes.1.11, .#MANIFEST.1.8, CVS/Entries, CVS/Repository, CVS/Root, lib/CVS/Entries, lib/CVS/Repository, lib/CVS/Root, lib/Class/AutoClass/CVS/Entries, lib/Class/AutoClass/CVS/Repository, lib/Class/AutoClass/CVS/Root, lib/Class/CVS/Entries, lib/Class/CVS/Repository, lib/Class/CVS/Root, t/CVS/Entries, t/CVS/Repository, t/CVS/Root, t/testUseOutOfOrder.t, t/testUseOutOfOrder_Child.pm, t/testUseOutOfOrder_GrandChild.pm, t/testUseOutOfOrder_Parent.pm, t/testUseOutOfOrder_StepParent.pm

package_version_matches_dist_version

Fix the version(s).

consistent_version

Split the distribution, or fix the version numbers to make them consistent (use the highest version number to avoid version downgrade).

Error: 1,1.0

has_meta_json

Add a META.json to the distribution. Your buildtool should be able to autogenerate it.

meta_yml_declares_perl_version

If you are using Build.PL define the {requires}{perl} = VERSION field. If you are using MakeMaker (Makefile.PL) you should upgrade ExtUtils::MakeMaker to 6.48 and use MIN_PERL_VERSION parameter. Perl::MinimumVersion can help you determine which version of Perl your module needs.

meta_yml_has_license

Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.

no_unauthorized_packages

Ask the owner of the distribution (the one who released it first, or the one who is designated in x_authority) to give you a (co-)maintainer's permission.

Error:

  • Class::AutoClass
  • Class::AutoClass::Args
  • Class::AutoClass::Root

use_warnings

Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: Class::AutoClass, Class::AutoClass::Args, Class::AutoClass::Root

build_prereq_matches_use

List all modules used in the test suite in META.yml build_requires

Error:

  • Test::Deep

has_separate_license_file

This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.

meta_yml_has_provides

Add all modules contained in this distribution to the META.yml field 'provides'. Module::Build or Dist::Zilla::Plugin::MetaProvides do this automatically for you.

meta_yml_has_repository_resource

Add a 'repository' resource to the META.yml via 'meta_add' accessor (for Module::Build) or META_ADD parameter (for ExtUtils::MakeMaker).

Modules

Name Abstract Version View
Class::AutoClass 1.0 metacpan
Class::AutoClass::Args metacpan
Class::AutoClass::Root 1 metacpan

Other Files

Changes metacpan
MANIFEST metacpan
META.yml metacpan
Makefile.PL metacpan