Kwalitee Issues

has_meta_yml

Add a META.yml to the distribution. Your buildtool should be able to autogenerate it.

manifest_matches_dist

Run a proper command ("make manifest" or "./Build manifest", maybe with a force option), or use a distribution builder to generate the MANIFEST. Or update MANIFEST manually.

Error:

  • MANIFEST (6) does not match dist (202):
  • Missing in MANIFEST: .svn/README.txt, .svn/empty-file, .svn/entries, .svn/format, .svn/prop-base/Changes.svn-base, .svn/prop-base/MANIFEST.svn-base, .svn/prop-base/Makefile.PL.svn-base, .svn/prop-base/README.svn-base, .svn/props/Changes.svn-work, .svn/props/MANIFEST.svn-work, .svn/props/Makefile.PL.svn-work, .svn/props/README.svn-work, .svn/text-base/Changes.svn-base, .svn/text-base/MANIFEST.svn-base, .svn/text-base/Makefile.PL.svn-base, .svn/text-base/README.svn-base, htdocs/Hub.html, htdocs/Hub/Apache2/Action.html, htdocs/Hub/Apache2/AuthenSHA.html, htdocs/Hub/Apache2/Config.html, htdocs/Hub/Apache2/Handler.html, htdocs/Hub/Apache2/Render.html, htdocs/Hub/Base/FileSystem.html, htdocs/Hub/Base/NoOp.html, htdocs/Hub/Base/Object.html, htdocs/Hub/Base/Package.html, htdocs/Hub/Base/Registry.html, htdocs/Hub/Config/Base.html, htdocs/Hub/Config/Webapp.html, htdocs/Hub/Console/Output.html, htdocs/Hub/Data/Address.html, htdocs/Hub/Data/Create.html, htdocs/Hub/Data/Directory.html, htdocs/Hub/Data/File.html, htdocs/Hub/Data/FileCache.html, htdocs/Hub/Data/Handlers.html, htdocs/Hub/Data/HashFile.html, htdocs/Hub/Data/Nest.html, htdocs/Hub/Data/SortedHash.html, htdocs/Hub/Data/Subset.html, htdocs/Hub/Knots/FileSystem.html, htdocs/Hub/Knots/Nest.html, htdocs/Hub/Knots/Object.html, htdocs/Hub/Knots/SortedHash.html, htdocs/Hub/Knots/TiedObject.html, htdocs/Hub/Misc/Time.html, htdocs/Hub/Misc/Transform.html, htdocs/Hub/Net/HTTP.html, htdocs/Hub/Parse/DataExtractor.html, htdocs/Hub/Parse/DataInjector.html, htdocs/Hub/Parse/FileParser.html, htdocs/Hub/Parse/Hash.html, htdocs/Hub/Parse/HtmlParser.html, htdocs/Hub/Parse/Parser.html, htdocs/Hub/Parse/StandardParser.html, htdocs/Hub/Parse/Template.html, htdocs/Hub/Parse/TextTemplate.html, htdocs/Hub/Perl/Compare.html, htdocs/Hub/Perl/Language.html, htdocs/Hub/Perl/Sort.html, htdocs/Hub/Webapp/Response.html, htdocs/Hub/Webapp/Session.html, htdocs/hubaddr.html, htdocs/hublib.html, htdocs/hubparse.html, htdocs/hubtest.html, htdocs/hubuse.html, htdocs/hubvar.html, htdocs/styles.css, lib/.svn/README.txt, lib/.svn/empty-file, lib/.svn/entries, lib/.svn/format, lib/Hub.pod, lib/Hub/Apache2/Action.pm, lib/Hub/Apache2/Action.pod, lib/Hub/Apache2/AuthenSHA.pm, lib/Hub/Apache2/AuthenSHA.pod, lib/Hub/Apache2/Config.pm, lib/Hub/Apache2/Config.pod, lib/Hub/Apache2/Handler.pm, lib/Hub/Apache2/Handler.pod, lib/Hub/Apache2/Render.pm, lib/Hub/Apache2/Render.pod, lib/Hub/Base/FileSystem.pm, lib/Hub/Base/FileSystem.pod, lib/Hub/Base/NoOp.pm, lib/Hub/Base/NoOp.pod, lib/Hub/Base/Object.pm, lib/Hub/Base/Object.pod, lib/Hub/Base/Package.pm, lib/Hub/Base/Package.pod, lib/Hub/Base/Registry.pm, lib/Hub/Base/Registry.pod, lib/Hub/Config/Base.pm, lib/Hub/Config/Base.pod, lib/Hub/Config/Webapp.pm, lib/Hub/Config/Webapp.pod, lib/Hub/Console/Output.pm, lib/Hub/Console/Output.pod, lib/Hub/Data/Address.pm, lib/Hub/Data/Address.pod, lib/Hub/Data/Create.pm, lib/Hub/Data/Create.pod, lib/Hub/Data/Directory.pm, lib/Hub/Data/Directory.pod, lib/Hub/Data/File.pm, lib/Hub/Data/File.pod, lib/Hub/Data/FileCache.pm, lib/Hub/Data/FileCache.pod, lib/Hub/Data/Handlers.pm, lib/Hub/Data/Handlers.pod, lib/Hub/Data/HashFile.pm, lib/Hub/Data/HashFile.pod, lib/Hub/Data/Nest.pm, lib/Hub/Data/Nest.pod, lib/Hub/Data/SortedHash.pm, lib/Hub/Data/SortedHash.pod, lib/Hub/Data/Subset.pm, lib/Hub/Data/Subset.pod, lib/Hub/Knots/FileSystem.pm, lib/Hub/Knots/FileSystem.pod, lib/Hub/Knots/Nest.pm, lib/Hub/Knots/Nest.pod, lib/Hub/Knots/Object.pm, lib/Hub/Knots/Object.pod, lib/Hub/Knots/SortedHash.pm, lib/Hub/Knots/SortedHash.pod, lib/Hub/Knots/TiedObject.pm, lib/Hub/Knots/TiedObject.pod, lib/Hub/Misc/Time.pm, lib/Hub/Misc/Time.pod, lib/Hub/Misc/Transform.pm, lib/Hub/Misc/Transform.pod, lib/Hub/Net/HTTP.pm, lib/Hub/Net/HTTP.pod, lib/Hub/Parse/DataExtractor.pm, lib/Hub/Parse/DataExtractor.pod, lib/Hub/Parse/DataInjector.pm, lib/Hub/Parse/DataInjector.pod, lib/Hub/Parse/FileParser.pm, lib/Hub/Parse/FileParser.pod, lib/Hub/Parse/Hash.pm, lib/Hub/Parse/Hash.pod, lib/Hub/Parse/HtmlParser.pm, lib/Hub/Parse/HtmlParser.pod, lib/Hub/Parse/Parser.pm, lib/Hub/Parse/Parser.pod, lib/Hub/Parse/StandardParser.pm, lib/Hub/Parse/StandardParser.pod, lib/Hub/Parse/Template.pm, lib/Hub/Parse/Template.pod, lib/Hub/Parse/TextTemplate.pm, lib/Hub/Parse/TextTemplate.pod, lib/Hub/Perl/Compare.pm, lib/Hub/Perl/Compare.pod, lib/Hub/Perl/Language.pm, lib/Hub/Perl/Language.pod, lib/Hub/Perl/Sort.pm, lib/Hub/Perl/Sort.pod, lib/Hub/Webapp/Response.pm, lib/Hub/Webapp/Response.pod, lib/Hub/Webapp/Session.pm, lib/Hub/Webapp/Session.pod, lib/hubaddr.pod, lib/hublib.pod, lib/hubparse.pod, lib/hubtest.pod, lib/hubuse.pod, lib/hubvar.pod, scripts/.conf, scripts/.svn/README.txt, scripts/.svn/empty-file, scripts/.svn/entries, scripts/.svn/format, scripts/.svn/prop-base/.conf.svn-base, scripts/.svn/prop-base/hub-get.svn-base, scripts/.svn/prop-base/hub-info.svn-base, scripts/.svn/prop-base/hub-parse.svn-base, scripts/.svn/prop-base/hub-passwd.svn-base, scripts/.svn/props/.conf.svn-work, scripts/.svn/props/hub-get.svn-work, scripts/.svn/props/hub-info.svn-work, scripts/.svn/props/hub-parse.svn-work, scripts/.svn/props/hub-passwd.svn-work, scripts/.svn/text-base/.conf.svn-base, scripts/.svn/text-base/hub-get.svn-base, scripts/.svn/text-base/hub-info.svn-base, scripts/.svn/text-base/hub-parse.svn-base, scripts/.svn/text-base/hub-passwd.svn-base, scripts/hub-get, scripts/hub-info, scripts/hub-parse, scripts/hub-passwd, t/all.hf, t/harness.pl

package_version_matches_dist_version

Fix the version(s).

prereq_matches_use

List all used modules in META.yml requires

Error:

  • APR::OS
  • Apache2::Access
  • Apache2::RequestRec
  • Compress::Zlib
  • Digest::SHA1
  • LWP::UserAgent
  • Net::HTTP

use_strict

Add 'use strict' (or its equivalents) to all modules, or convince us that your favorite module is well-known enough and people can easily see the modules are strictly written.

Error: Hub::Data::Address

has_known_license_in_source_file

Add =head1 LICENSE and/or the proper text of the well-known license to the main module in your code.

has_meta_json

Add a META.json to the distribution. Your buildtool should be able to autogenerate it.

meta_yml_has_license

Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.

no_dot_dirs

Fix MANIFEST (or MANIFEST.SKIP) to exclude dot directories from a distribution. Use an appropriate tool and avoid archiving your working directory by hand. If you switch your version control system, remove old VCS directories after you migrate.

Error: .svn

use_warnings

Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: Hub, Hub::Apache2::Action, Hub::Apache2::AuthenSHA, Hub::Apache2::Config, Hub::Apache2::Handler, Hub::Apache2::Render, Hub::Base::FileSystem, Hub::Base::NoOp, Hub::Base::Object, Hub::Base::Package, Hub::Base::Registry, Hub::Config::Base, Hub::Config::Webapp, Hub::Console::Output, Hub::Data::Address, Hub::Data::Create, Hub::Data::Directory, Hub::Data::File, Hub::Data::FileCache, Hub::Data::Handlers, Hub::Data::HashFile, Hub::Data::Nest, Hub::Data::SortedHash, Hub::Data::Subset, Hub::Knots::FileSystem, Hub::Knots::Nest, Hub::Knots::Object, Hub::Knots::SortedHash, Hub::Knots::TiedObject, Hub::Misc::Time, Hub::Misc::Transform, Hub::Net::HTTP, Hub::Parse::DataExtractor, Hub::Parse::DataInjector, Hub::Parse::FileParser, Hub::Parse::Hash, Hub::Parse::HtmlParser, Hub::Parse::Parser, Hub::Parse::StandardParser, Hub::Parse::Template, Hub::Parse::TextTemplate, Hub::Perl::Language, Hub::Perl::Sort, Hub::Webapp::Response, Hub::Webapp::Session

has_separate_license_file

This is not a critical issue. Currently mainly informative for the CPANTS authors. It might be removed later.

Modules

Name Abstract Version View
Hub Hub Library Interface 4.00043 metacpan

Other Files

Changes metacpan
MANIFEST metacpan
Makefile.PL metacpan
README metacpan