Kwalitee Issues

has_meta_yml

Add a META.yml to the distribution. Your buildtool should be able to autogenerate it.

no_pod_errors

Remove the POD errors. You can check for POD errors automatically by including Test::Pod to your test suite.

Error: newslib-0.84/Net/NNTP/Client.pm -- Around line 308: You forgot a '=back' before '=head1' newslib-0.84/Net/NNTP/Proxy.pm -- Around line 61: You forgot a '=back' before '=head2'Around line 65: '=item' outside of any '=over'Around line 230: You forgot a '=back' before '=head2'Around line 235: '=item' outside of any '=over'Around line 255: You forgot a '=back' before '=head2'Around line 262: '=item' outside of any '=over' newslib-0.84/News/Article/Cancel.pm -- Around line 243: You forgot a '=back' before '=head1' newslib-0.84/News/Article/Clean.pm -- Around line 577: You forgot a '=back' before '=head1'

package_version_matches_dist_version

Fix the version(s).

prereq_matches_use

List all used modules in META.yml requires

Error:

  • Date::Parse

use_strict

Add 'use strict' (or its equivalents) to all modules, or convince us that your favorite module is well-known enough and people can easily see the modules are strictly written.

Error: News::NNTPAuth, Version

consistent_version

Split the distribution, or fix the version numbers to make them consistent (use the highest version number to avoid version downgrade).

Error: 0.2,0.21,0.54,0.6,0.71,1,1.0,1.02

has_meta_json

Add a META.json to the distribution. Your buildtool should be able to autogenerate it.

has_tests_in_t_dir

Add tests or move tests.pl to the t/ directory!

meta_yml_has_license

Define the license if you are using in Build.PL. If you are using MakeMaker (Makefile.PL) you should upgrade to ExtUtils::MakeMaker version 6.31.

no_unauthorized_packages

Ask the owner of the distribution (the one who released it first, or the one who is designated in x_authority) to give you a (co-)maintainer's permission.

Error:

  • News::Article

use_warnings

Add 'use warnings' (or its equivalents) to all modules (this will require perl > 5.6), or convince us that your favorite module is well-known enough and people can easily see the modules warn when something bad happens.

Error: Net::NNTP::Auth, Net::NNTP::Client, Net::NNTP::Functions, Net::NNTP::Proxy, News::Article, News::Article, News::Article::Cancel, News::Article::Ref, News::NNTPAuth, Version

Modules

Name Abstract Version View
Net::NNTP::Auth a standard NNTP authentication method 1 metacpan
Net::NNTP::Client a module to simulate an entire NNTP client 0.6 metacpan
Net::NNTP::Functions code to implement NNTP-standard functions 0.21 metacpan
Net::NNTP::Proxy a news server in perl 0.54 metacpan
News::Article 1.02 metacpan
News::Article::Cancel a module to generate accurate cancel messages 0.71 metacpan
News::Article::Ref reference functions for news articles 0.2 metacpan
News::NNTPAuth a standard NNTP authentication method (deprecated) 1.0 metacpan

Provides

Name File View
Net::NNTP2 Net/NNTP/Client.pm metacpan

Other Files

Changes metacpan
MANIFEST metacpan
Makefile.PL metacpan
README.txt metacpan